

<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#  profile: http://ogp.me/ns/profile# fb: http://ogp.me/ns/fb#" lang="ru-RU">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="color-scheme" content="dark light">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="preconnect" href="https://mc.yandex.ru">
<link rel="preconnect" href="https://mc.yandex.ru" crossorigin>
<link rel="preconnect" href="https://vk.com">
<link rel="preconnect" href="https://cdn.onesignal.com">
<link rel="preconnect" href="https://onesignal.com" crossorigin>
<link rel="preconnect" href="https://tproger.ru" crossorigin>
<link rel="preconnect" href="https://sentry.tproger.ru" crossorigin>
<link rel="dns-prefetch" href="https://track.tproger.ru"><script defer src="https://tproger.ru/wp-content/themes/gecko/modules/sentry/sentry.es6.min.x78180.js" onload="Sentry.init({ dsn: 'https://63f279b4a66348b9ade9e95f8bcb2e0e@sentry.tproger.ru/5302604', environment: 'tproger.ru', release: 'bfdaa76ccc17e74b8e9308777c4d04be8c0ff81a', tracesSampleRate: 0, beforeSend(event) { return ((window.ses = window.ses ? window.ses + 1 : 1) > 16) ? null : event }, }); window.setAnalyticsSentryTags && setAnalyticsSentryTags()"></script>

<title>DevOps Инженер &mdash; вакансия на Tproger</title>
<link rel="canonical" href="https://tproger.ru/jobs/devops-inzhener-2/" />
<meta property="og:locale" content="ru_RU" />
<meta property="og:type" content="article" />
<meta property="og:title" content="DevOps Инженер" />
<meta property="og:description" content="В команду КРОК открыт набор на вакансию DevOps инженер." />
<meta property="og:url" content="https://tproger.ru/jobs/devops-inzhener-2/" />
<meta property="og:site_name" content="Tproger" />
<meta property="article:publisher" content="https://www.facebook.com/tproger/" />
<meta property="article:modified_time" content="2022-02-11T16:05:37+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@tproger" />

<link rel='dns-prefetch' href='//tproger.ru' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel="stylesheet" href="https://tproger.ru/wp-content/cache/minify/95fc3.x78180.css" media="all" />
<script defer src="https://tproger.ru/wp-content/cache/minify/739a7.x78180.js"></script>
<script async src="https://tproger.ru/wp-content/cache/minify/94b99.x78180.js"></script>
<script type='text/javascript' id='gecko-auth-script-js-extra'>
/* <![CDATA[ */
var authTelegram = {"botUsername":"tproger_official_bot"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/30b2f.x78180.js"></script>
<script type='text/javascript' id='event_jobs_widget_script-js-extra'>
/* <![CDATA[ */
var EventJobsBannerStatistic = {"event":{"view":"postStaticBanner.view.fromPost","click":"postStaticBanner.click.fromPost"}};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/0c140.x78180.js"></script>
<link rel="https://api.w.org/" href="https://tproger.ru/wp-json/" /><link rel='shortlink' href='https://tproger.ru/?p=192138' />
<link rel="icon" href="/favicon.ico?v=2">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="192x192" href="/android-chrome-192x192.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#2aa5a0">
<meta name="apple-mobile-web-app-title" content="Tproger">
<meta name="application-name" content="Tproger">
<meta name="theme-color" content="#2aa5a0">
</head>
<body class="jobs-template-default single single-jobs postid-192138 grid theme--auto dark">
<div id="tproger-login-popup" class="show-on-idle">
<div class="tproger-login-popup__cover"></div>
<div class="tproger-login-popup__container box">
<div id="tproger-login-popup__close" class="close-post">
<svg class="tproger-login-popup__close-icon">
<use xlink:href="#cancel"></use>
</svg>
</div>
<div class="tproger-login-popup__header">
<h3>Авторизуйтесь</h3>
<div class="tproger-login-popup__header-text">Это не займет больше 5 секунд</div>
</div>
<div class="tproger-login-popup__social-buttons">
<div class="tproger-login-popup__social-buttons__top">
<span class="btn-social btn-social__vk colored">
<svg class="tproger-login-popup__social-icon">
<use xlink:href="#vk"></use>
</svg>
<span class="button-menu__text">Войти с VK</span>
</span>
<span class="btn-social btn-social__google colored">
<svg class="tproger-login-popup__social-icon">
<use xlink:href="#google"></use>
</svg>
<span class="button-menu__text">Войти с Google</span>
</span>
</div>
<div class="tproger-login-popup__social-buttons__bottom">
<span class="btn-social btn-social__github colored">
<svg class="tproger-login-popup__social-icon">
<use xlink:href="#github"></use>
</svg>
</span>
<span class="btn-social btn-social__facebook colored">
<svg class="tproger-login-popup__social-icon">
<use xlink:href="#facebook"></use>
</svg>
</span>
<span class="btn-social btn-social__yandex colored">
<svg class="tproger-login-popup__social-icon">
<use xlink:href="#yandex"></use>
</svg>
</span>
<span class="btn-social btn-social__twitter colored">
<svg class="tproger-login-popup__social-icon">
<use xlink:href="#twitter"></use>
</svg>
</span>
</div>
<div class="telegram-auth-button">
<div class="telegram-auth-button__inner"></div>
<div class="loading-vertical"><i></i><i></i><i></i></div>
</div>
</div>
<div class="agreement__container">
<label for="user-login-checkbox" class="agreement__container-label">
<input type="checkbox" id="user-login-checkbox" name="user-login-checkbox" value="false">
<label for="user-login-checkbox">
<span>
<svg class="tproger-login-popup__check-icon">
<use xlink:href="#check"></use>
</svg>
</span>
</label>
<div class="agreement__text">
<div class="highlight"><span>Я соглашаюсь с</span> <a class="agreement__text-link" href="/wp-content/uploads/custom/terms.pdf" target="_blank">правилами пользования сайтом</a></div>
<div class="highlight"><span>и даю</span> <a class="agreement__text-link" href="/wp-content/uploads/custom/privacy.pdf" target="_blank">согласие на обработку персональных данных</a></div>
</div>
</label>
</div>
<div class="warning__container" style="display:none">
<div class="text-warning">Пожалуйста, согласитесь с правилами пользования</div>
</div>
</div>
</div>
<div class="container-header">
<header class="header">
<div class="header__container-left">
<div class="header__container-humburger-button">
<button id="buttonShowAsideMenu" class="hamburger-button" aria-label="Гамбургер меню">
<svg class="hamburger-button__icon">
<use xlink:href="#hamburger"></use>
</svg>
</button>
</div>
<div class="header__container-logo">
<div class="logo-tproger">
<a class="logo-tproger__link" href="/" aria-label="Логотип">
<div class="logo-tproger__container-image">
<svg class="logo-tproger__image">
<use xlink:href="#logo"></use>
</svg>
</div>
<div class="logo-tproger__container-text">
<span class="logo-tproger__text">Tproger</span>
</div>
</a>
</div>
</div>
</div>
<div class="header__container-center">
<div class="header__container-search">
<form method="get" action="/search" class="search">
<input name="searchid" type="hidden" value="2415386">
<input id="searchButtonGroupSelectList" autocomplete="off" name="text" class="search__input" type="text" placeholder="Поиск">
<input name="web" type="hidden" value="0">
<button class="search__button" type="submit" aria-label="Искать">
<div class="search__wrapper-button">
<svg class="search__icon">
<use xlink:href="#search"></use>
</svg>
</div>
</button>
</form>
<div id="searchGroupSelectList" class="header__container-search-list buttons-group group-buttons-select__container-list">
<span class="search__tags-header">
Популярные темы
</span>
<div class="search__tags-content">
<a class="search__popular_link" href="/tag/python/">Python</a><a class="search__popular_link" href="/tag/cpp/">С++</a><a class="search__popular_link" href="/tag/javascript/">JavaScript</a><a class="search__popular_link" href="/tag/web/">Web-разработка</a><a class="search__popular_link" href="/problems/">Задачи с разбором</a><a class="search__popular_link" href="/tag/gamedev/">Разработка игр</a><a class="search__popular_link" href="/quiz/">Тесты и викторины</a><a class="search__popular_link" href="/tag/for-beginners/">Для начинающих</a> </div>
</div>
</div>
<div class="header__container-group-buttons-select">
<div class="group-buttons-select">
<div class="group-buttons-select__group">
<a class="group-buttons-select__button group-buttons-select__button--minced-right" href="/editor/?utm_source=desktop-header-button">
<div class="group-buttons-select__wrapper-content-button">
<svg class="group-buttons-select__icon group-buttons-select__icon--fill">
<use xlink:href="#pen"></use>
</svg>
<span class="group-buttons-select__text group-buttons-select__text--mobile-hidden">Написать пост</span>
</div>
</a>
<button id="buttonShowGroupButtonsSelectList" class="group-buttons-select__button group-buttons-select__button--minced-left group-buttons-select__button--pseudo-slash" aria-label="Ещё">
<div class="group-buttons-select__wrapper-content-button">
<svg class="group-buttons-select__icon group-buttons-select__icon--stroke group-buttons-select__icon--arrow-down">
<use xlink:href="#arrow-down"></use>
</svg>
</div>
</button>
</div>
<div id="groupButtonsSelectList" class="group-buttons-select__container-list">
<ul class="group-buttons-select__list">
<li class="group-buttons-select__item">
<a class="group-buttons-select__button" href="/ad/jobs/?utm_source=post_button">
<div class="group-buttons-select__wrapper-content-button">
<svg class="group-buttons-select__icon group-buttons-select__icon--fill">
<use xlink:href="#job"></use>
</svg>
<span class="group-buttons-select__text group-buttons-select__text--mobile-hidden">Разместить вакансию</span>
</div>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="header__container-right">
<div class="header__container-button-mobile-search">
<button id="buttonMobileSearch" class="button-menu" aria-label="Поиск">
<div class="button-menu__wrapper">
<svg class="button-menu__icon button-menu__icon--stroke">
<use xlink:href="#search"></use>
</svg>
</div>
</button>
</div>
<div class="header__container-button-notification" aria-label="Уведомления">
<div id="tproger-notification-button" class="button-menu__wrapper button-menu">
<svg class="button-menu__icon button-menu__icon--fill">
<use xlink:href="#notification"></use>
</svg>
<span class="notifications__count-badge notifications__count-badge--hide"></span>
</div>
<div class="button-menu__notification-bottom">

<div id="notification__auth-popup" class="notification__auth-popup notification-auth-popup">
<div class="notification__auth-popup--header">
<span class="notification__auth-popup--heading">Уведомления</span>
<button id="closeButtonNotificationAuthPopup" class="notification-auth-popup__button-close">
<svg class="notification-auth-popup__icon-button-close">
<use xlink:href="#cancel"></use>
</svg>
</button>

</div>
<div class="notification__auth-popup--content">
<div class="notification__auth-popup--image-container">
<img width="60" height="68" sizes="60px, 60w" class="lazy" data-src="/wp-content/themes/gecko/icons/bell.svg" alt="Уведомления" />
</div>
<div class="notification__auth-popup--content-text">
Авторизуйтесь, чтобы оценивать посты, писать комментарии и создавать записи.
</div>
<div class="notification__auth-popup--social">
<span class="notification-button--social btn-social btn-social__vk colored">
<svg class="tproger-notification-login-popup__social-icon">
<use xlink:href="#vk"></use>
</svg>
</span>
<span class="notification-button--social btn-social btn-social__google colored">
<svg class="tproger-notification-login-popup__social-icon">
<use xlink:href="#google"></use>
</svg>
</span>
<span class="notification-button--social btn-social btn-social__github colored">
<svg class="tproger-notification-login-popup__social-icon">
<use xlink:href="#github"></use>
</svg>
</span>
<span class="notification-button--social btn-social btn-social__facebook colored">
<svg class="tproger-notification-login-popup__social-icon">
<use xlink:href="#facebook"></use>
</svg>
</span>
<span class="notification-button--social btn-social btn-social__yandex colored">
<svg class="tproger-notification-login-popup__social-icon">
<use xlink:href="#yandex"></use>
</svg>
</span>
<span class="notification-button--social btn-social btn-social__twitter colored">
<svg class="tproger-notification-login-popup__social-icon">
<use xlink:href="#twitter"></use>
</svg>
</span>
</div>
</div>
</div>
</div>
</div>
<button id="tproger-login-button" class="button-menu" aria-label="Войти">
<div class="button-menu__wrapper">
<svg class="button-menu__icon button-menu__icon--fill">
<use xlink:href="#user"></use>
</svg>
<span class="button-menu__text button-menu__text--mobile-hidden">Войти</span>
</div>
</button>
</div>
</header>
<div id="mobileSearch" class="mobile-search">
<div class="mobile-search__wrapper">
<form method="get" action="/search" class="search">
<input name="searchid" type="hidden" value="2415386">
<input id="searchButtonGroupSelectList" autocomplete="off" name="text" class="search__input" type="text" placeholder="Поиск">
<input name="web" type="hidden" value="0">
<button class="search__button" type="submit" aria-label="Искать">
<div class="search__wrapper-button">
<svg class="search__icon">
<use xlink:href="#search"></use>
</svg>
</div>
</button>
</form>
<div class="header__container-search-list buttons-group group-buttons-select__container-list">
<span class="search__tags-header">
Популярные темы
</span>
<div class="search__tags-content">
<a class="search__popular_link" href="/tag/python/">Python</a><a class="search__popular_link" href="/tag/cpp/">С++</a><a class="search__popular_link" href="/tag/javascript/">JavaScript</a><a class="search__popular_link" href="/tag/web/">Web-разработка</a><a class="search__popular_link" href="/problems/">Задачи с разбором</a><a class="search__popular_link" href="/tag/gamedev/">Разработка игр</a><a class="search__popular_link" href="/quiz/">Тесты и викторины</a><a class="search__popular_link" href="/tag/for-beginners/">Для начинающих</a> </div>
</div>
</div>
</div>
</div>
<div style="position: absolute; width: 0px; height: 0px; overflow: hidden; z-index: -9999;" class="show-on-idle">
<svg width="0" height="0">
<defs>
<symbol viewBox="0 0 24 24" id="rocket">
<path fill-rule="evenodd" clip-rule="evenodd" d="M21.252 2.324c.204.032.28.13.298.176.045.02.132.107.162.309.286 1.288.296 2.28.286 3.226 0 4.073-2.189 6.514-4.97 8.314v3.969c0 .624-.455 1.379-1.04 1.678-1.223.616-3.827 1.913-3.827 1.913-.156.065-.416.091-.416.091a.937.937 0 0 1-.934-.924V17.46c-.035.03-.83.43-.83.43-.727.338-1.337-.17-1.428-.26-.498-.486-1.125-1.146-1.125-1.146-.024-.024-.633-.636-1.103-1.13-.09-.092-.589-.71-.243-1.434 0 0 .407-.794.437-.828l-3.608-.04A.94.94 0 0 1 2 12.1s.029-.26.096-.416c0 0 1.323-2.596 1.95-3.816.305-.582 1.062-1.03 1.685-1.022l3.958.046c1.827-2.77 4.286-4.937 8.348-4.892.945 0 1.933.022 3.215.323ZM17.038 8.37a1.553 1.553 0 0 0 1.438-.963 1.564 1.564 0 0 0-.337-1.7 1.555 1.555 0 0 0-2.657 1.102 1.563 1.563 0 0 0 .96 1.442c.19.078.392.119.596.119Z" />
</symbol>
<symbol viewBox="0 0 24 24" id="bug">
<path fill-rule="evenodd" clip-rule="evenodd" d="M7.566 6.36h8.72a4.36 4.36 0 0 0-8.72 0Zm-2.25-.55 2.14 2.18h9l2.14-2.17a1.22 1.22 0 0 1 1.73 0 1.26 1.26 0 0 1 0 1.78l-1.85 1.83v2.28h2.23a1.23 1.23 0 0 1-.07 2.46h-2.16v.62a5.09 5.09 0 0 1-.51 2.39l2.37 2.34a1.244 1.244 0 1 1-1.77 1.75l-2.12-2.11a5.59 5.59 0 0 1-3.53 1.25v-9.52a.48.48 0 0 0-.46-.48h-1a.47.47 0 0 0-.49.48v9.52a5.59 5.59 0 0 1-3.53-1.25l-2.08 2.11a1.21 1.21 0 0 1-1.77 0 1.2 1.2 0 0 1 0-1.75l2.38-2.34a5.21 5.21 0 0 1-.52-2.39v-.62h-2.18a1.23 1.23 0 1 1-.07-2.46h2.23V9.43l-1.84-1.84a1.26 1.26 0 0 1 .396-2.046 1.22 1.22 0 0 1 1.333.266Z" />
</symbol>
<symbol viewBox="0 0 32 32" id="check">
<path d="M24.976 9.728a1.334 1.334 0 0 0-1.894 0l-9.933 9.947-4.173-4.187a1.355 1.355 0 0 0-1.49-.27 1.356 1.356 0 0 0-.725.75 1.355 1.355 0 0 0 .018 1.043c.072.165.174.313.303.437l5.12 5.12a1.334 1.334 0 0 0 1.894 0l10.88-10.88a1.337 1.337 0 0 0 .317-1.515 1.337 1.337 0 0 0-.317-.445z" />
</symbol>

<symbol viewBox="0 0 24 24" id="vk">
<path d="M12.9824 19C5.46589 19 1.17864 13.7447 1 5H4.76515C4.88882 11.4184 7.66452 14.1371 9.86314 14.6977V5H13.4086V10.5355C15.5797 10.2973 17.8605 7.77477 18.63 5H22.1754C21.5845 8.41942 19.111 10.9419 17.3521 11.979C19.111 12.8198 21.9282 15.02 23 19H19.0973C18.2591 16.3373 16.1706 14.2773 13.4086 13.997V19H12.9824Z" fill="#2787f5" />
</symbol>
<symbol viewBox="0 0 24 36" id="yandex">
<path d="M23.6346 35.5H17.5192V5.23077H14.7885C9.78846 5.23077 7.17308 7.73077 7.17308 11.4615C7.17308 15.6923 8.98077 17.6538 12.7115 20.1538L15.7885 22.2308L6.94231 35.5H0.365387L8.32693 23.6538C3.75 20.3846 1.17308 17.1923 1.17308 11.8077C1.17308 5.07692 5.86539 0.5 14.75 0.5H23.5962L23.6346 35.5Z" fill="#FC3F1D" />
</symbol>
<symbol viewBox="0 0 24 24" id="google">
<g transform="matrix(1, 0, 0, 1, 27.009001, -39.238998)">
<path fill="#4285F4" d="M -3.264 51.509 C -3.264 50.719 -3.334 49.969 -3.454 49.239 L -14.754 49.239 L -14.754 53.749 L -8.284 53.749 C -8.574 55.229 -9.424 56.479 -10.684 57.329 L -10.684 60.329 L -6.824 60.329 C -4.564 58.239 -3.264 55.159 -3.264 51.509 Z" />
<path fill="#34A853" d="M -14.754 63.239 C -11.514 63.239 -8.804 62.159 -6.824 60.329 L -10.684 57.329 C -11.764 58.049 -13.134 58.489 -14.754 58.489 C -17.884 58.489 -20.534 56.379 -21.484 53.529 L -25.464 53.529 L -25.464 56.619 C -23.494 60.539 -19.444 63.239 -14.754 63.239 Z" />
<path fill="#FBBC05" d="M -21.484 53.529 C -21.734 52.809 -21.864 52.039 -21.864 51.239 C -21.864 50.439 -21.724 49.669 -21.484 48.949 L -21.484 45.859 L -25.464 45.859 C -26.284 47.479 -26.754 49.299 -26.754 51.239 C -26.754 53.179 -26.284 54.999 -25.464 56.619 L -21.484 53.529 Z" />
<path fill="#EA4335" d="M -14.754 43.989 C -12.984 43.989 -11.404 44.599 -10.154 45.789 L -6.734 42.369 C -8.804 40.429 -11.514 39.239 -14.754 39.239 C -19.444 39.239 -23.494 41.939 -25.464 45.859 L -21.484 48.949 C -20.534 46.099 -17.884 43.989 -14.754 43.989 Z" />
</g>
</symbol>
<symbol viewBox="0 0 20 36" id="facebook">
<path d="M18.0831 20.0388L19.0473 13.7524H13.0158V9.67289C13.0158 7.95305 13.8582 6.2767 16.5599 6.2767H19.3022V0.924757C19.3022 0.924757 16.8134 0.5 14.434 0.5C9.46642 0.5 6.21966 3.51068 6.21966 8.96117V13.7524H0.697815V20.0388H6.21966V35.2358C7.32683 35.4095 8.4617 35.5 9.61772 35.5C10.7737 35.5 11.9085 35.4095 13.0158 35.2358V20.0388H18.0831Z" fill="#1877F2" />
</symbol>
<symbol viewBox="0 0 24 24" id="github">
<path d="M12 0c-6.626 0-12 5.373-12 12 0 5.302 3.438 9.8 8.207 11.387.599.111.793-.261.793-.577v-2.234c-3.338.726-4.033-1.416-4.033-1.416-.546-1.387-1.333-1.756-1.333-1.756-1.089-.745.083-.729.083-.729 1.205.084 1.839 1.237 1.839 1.237 1.07 1.834 2.807 1.304 3.492.997.107-.775.418-1.305.762-1.604-2.665-.305-5.467-1.334-5.467-5.931 0-1.311.469-2.381 1.236-3.221-.124-.303-.535-1.524.117-3.176 0 0 1.008-.322 3.301 1.23.957-.266 1.983-.399 3.003-.404 1.02.005 2.047.138 3.006.404 2.291-1.552 3.297-1.23 3.297-1.23.653 1.653.242 2.874.118 3.176.77.84 1.235 1.911 1.235 3.221 0 4.609-2.807 5.624-5.479 5.921.43.372.823 1.102.823 2.222v3.293c0 .319.192.694.801.576 4.765-1.589 8.199-6.086 8.199-11.386 0-6.627-5.373-12-12-12z" />
</symbol>
<symbol viewBox="0 0 36 29" id="twitter">
<path d="M33.9546 4.96642C33.4887 5.31584 33.0228 5.60702 32.4987 5.8982C32.5569 6.36409 32.5569 6.88822 32.5569 7.41235C32.5569 14.1678 29.6451 20.2826 25.0445 24.5338C21.4338 27.2127 16.9496 28.7851 12.0578 28.7851C7.80652 28.7851 3.84645 27.5621 0.46875 25.4656C1.16759 25.5821 1.86642 25.6403 2.62349 25.6403C6.0012 25.6403 9.08772 24.4756 11.5336 22.5538C8.38888 22.4955 5.71001 20.399 4.77823 17.4872C5.18589 17.5455 5.65178 17.6037 6.11767 17.6037C6.75827 17.6037 7.34063 17.5455 7.92299 17.3708C6.58356 17.0796 5.41883 16.3807 4.48705 15.449C3.14762 14.1678 2.33231 12.3042 2.33231 10.3242C2.33231 10.2659 2.33231 10.2659 2.33231 10.2077C3.20585 10.6736 4.13764 10.9648 5.18589 11.0812C4.13764 10.2659 3.26409 9.15944 2.7982 7.87824C2.50702 7.06293 2.33231 6.18938 2.33231 5.31584C2.33231 4.96642 2.33231 4.55877 2.39055 4.20935C2.56526 3.21934 2.91467 2.28755 3.38056 1.53048C3.90469 2.11285 4.48705 2.69521 5.12765 3.27757C5.41883 3.56875 5.76825 3.8017 6.05943 4.09288C7.86476 5.54879 9.90303 6.71351 12.0578 7.58706C12.349 7.70353 12.5819 7.82 12.8731 7.87824C13.8631 8.22765 14.8531 8.51884 15.9014 8.69355C16.1343 8.75178 16.3673 8.81002 16.6002 8.81002C16.7167 8.81002 16.7749 8.86825 16.8914 8.86825C17.3573 8.92649 17.7649 8.98473 18.2308 9.04296C18.1143 8.51884 17.9979 7.93647 17.9979 7.29587C17.9979 4.84995 19.2208 2.69521 21.0844 1.41401C21.2009 1.29754 21.3173 1.2393 21.492 1.18107C21.492 1.18107 21.5503 1.18107 21.5503 1.2393V1.18107C22.6568 0.540467 23.8797 0.132812 25.2774 0.132812C27.3739 0.132812 29.2375 1.00636 30.5769 2.46226C31.0428 2.34579 31.5669 2.22932 32.0328 2.11285C32.5569 1.93814 33.0228 1.82166 33.4887 1.58872C34.0711 1.35577 34.5952 1.06459 35.1193 0.773412C34.8282 1.64696 34.3623 2.46226 33.7799 3.1611C33.3722 3.62699 32.9064 4.03464 32.4405 4.4423C32.324 4.50053 32.2075 4.61701 32.091 4.67524C32.0328 4.67524 32.0328 4.67524 31.9746 4.67524C31.9746 4.67524 31.9746 4.67524 31.9746 4.73348L32.0328 4.67524C32.1493 4.67524 32.2658 4.61701 32.4405 4.61701C32.9646 4.55877 33.4305 4.4423 33.9546 4.32582C34.4787 4.20935 35.0029 4.03464 35.4688 3.85993C34.9446 4.20935 34.4205 4.55877 33.9546 4.96642Z" fill="#1DA1F3" />
</symbol>
<symbol viewBox="0 0 25 24" id="telegram">
<path d="M22.454 2.177s2.22-.866 2.035 1.236c-.062.866-.617 3.896-1.048 7.173l-1.48 9.709s-.124 1.422-1.234 1.67c-1.11.247-2.775-.866-3.084-1.114-.246-.185-4.625-2.968-6.167-4.328-.431-.371-.925-1.113.062-1.98l6.476-6.183c.74-.742 1.48-2.473-1.604-.37l-8.634 5.874s-.987.618-2.837.062L.931 12.689s-1.48-.928 1.048-1.855c6.167-2.907 13.753-5.875 20.475-8.657Z" />
</symbol>
<symbol viewBox="0 0 24 24" id="check">
<path d="M18.7319 7.2958C18.639 7.20207 18.5284 7.12768 18.4065 7.07691C18.2846 7.02614 18.1539 7 18.0219 7C17.8899 7 17.7592 7.02614 17.6373 7.07691C17.5155 7.12768 17.4049 7.20207 17.3119 7.2958L9.86192 14.7558L6.73192 11.6158C6.6354 11.5226 6.52146 11.4492 6.3966 11.4C6.27175 11.3508 6.13843 11.3267 6.00424 11.329C5.87006 11.3314 5.73765 11.3601 5.61458 11.4136C5.4915 11.4671 5.38016 11.5443 5.28692 11.6408C5.19368 11.7373 5.12037 11.8513 5.07117 11.9761C5.02196 12.101 4.99783 12.2343 5.00015 12.3685C5.00247 12.5027 5.0312 12.6351 5.0847 12.7581C5.13819 12.8812 5.2154 12.9926 5.31192 13.0858L9.15192 16.9258C9.24489 17.0195 9.35549 17.0939 9.47735 17.1447C9.59921 17.1955 9.72991 17.2216 9.86192 17.2216C9.99393 17.2216 10.1246 17.1955 10.2465 17.1447C10.3684 17.0939 10.479 17.0195 10.5719 16.9258L18.7319 8.7658C18.8334 8.67216 18.9144 8.5585 18.9698 8.432C19.0252 8.30551 19.0539 8.1689 19.0539 8.0308C19.0539 7.8927 19.0252 7.75609 18.9698 7.62959C18.9144 7.50309 18.8334 7.38944 18.7319 7.2958Z" />
</symbol>
<symbol viewBox="0 0 32 32" id="logo">
<path fill="#2aa29f" d="M16.088 32c8.813 0 16-7.187 16-16s-7.187-16-16-16-16 7.187-16 16 7.187 16 16 16z" />
<path fill="#fff" d="M15.073 9.446c.753-.662 4.723-.707 5.579-.291 1.164.565 2.333 1.055 2.316 2.424-.017 1.352-.131 2.789-.137 3.388-.006.548.536.856 1.061 2.287.188.508 1.369.97 1.084 1.466-.171.285-.456.736-1.186 1.175-.222.131-1.209.833-.359 2.27.297.513.177.314-.605 1.329-.565.736-.074 2.293-.456 2.436-.006.006-1.323-.388-2.658-.051-2.076.53-4.523 1.877-4.546 1.865-.04-.012-1.534-2.133-2.835-3.588-.936-1.044-1.848-1.397-1.694-1.991.553-2.133-3.143-5.596-1.785-7.98.799-1.397 3.023-.154 4.027.622 1.466 1.141 1.015-4.329 2.196-5.362z" />
<path fill="#363634" d="M21.758 22.931c-.028.16-.217.873-.28.975-.137-.046-1.181-.684-1.34-.799.137-.194 2.521-1.232 2.909-1.244.086.108.359.553.354.707l-1.643.359zm-8.984-6.834.605-.017c.017 1.877-.143 2.51-.759 4.449-.2.491.462 2.019.65 2.447.108.245.143.336.205.388.285.24 4.506 1.723 5.527 2.293-1.797.616-2.926 1.295-3.89 1.837-1.038-1.506-2.55-3.651-4.124-4.9.074-.371.405-1.785.376-2.071-.023-.245-1.523-2.162-1.888-3.576-.342-1.318-.32-2.31.964-2.424 1.272-.108 1.837.502 2.333 1.574zm8.927-1.409c.148-.012.411-.063.542-.074.017.182-.057 1.9-.108 2.076-.034.108-.222.302-.342.382-.165.103-.154-2.059-.091-2.384zm-6.206.93c1.409-.268 3.953-.639 5.299-.827-.131 1.437.114 3.468.183 3.588.046.085.57.103.696.023a55.517 55.517 0 0 0 1.164-1.164c.034-.12.006-.319.029-.89.291.502.667 1.175 1.004 1.688.354.542.65.901.65.901-.023.103-.616.605-.73.628-.405.08-1.951.194-2.624.342-.696.154-2.316 1.021-2.989 1.369-.376-.24-1.939-2.447-2.282-2.932-.245-.342-.177-.274-.228-.816-.063-.628-.142-1.272-.171-1.911zm3.639-4.592c.188.325.245 1.603.308 1.939.57.086 1.557.297 2.053.336.2-.667.103-2.076.057-2.812.228.074.97.588 1.044.804.125.342.097 1.934-.006 2.276-.336.028-.684 0-1.021.028-.861.068-1.882.194-2.732.348-.508.097-3.017.662-3.44.662l-.103-.559c0-.063.582-.998.696-1.221.143-.274.285-.565.433-.856.051-.103.348-.838.405-.89 1.129 1.169 1.403 1.746 1.477 1.803s.684.08.804.074c.126-.268.08-1.466.023-1.934zM8.935 8.008c-.217-.473-.108-2.818-.126-2.84-.394-.194-1.996 1.768-2.116 2.156-.251.844.034 1.204.251 1.945-1.386.782-2.533 2.333-2.31 4.107.274-.257.913-.816 1.346-.953-.428 1.877-.519 4.615 1.888 6.508.388.302.622 2.886.684 3.742.388-.046.987-.103 1.392-.017 1.534.331 4.187 4.261 5.071 5.527.97-.513 4.01-1.985 5.054-1.939.154.006.542.268.873.325.428.068 1.289-.211 1.694-.32 1.044-.274.827-.085.73-1.135-.063-.679 0-1.363.023-2.031.012-.365.422-.302.365-.616-.051-.257-.24-.496-.342-.702.177-.063.667-.057.673-.205.028-.565-.012-1.124-.012-1.688.2-.16 1.284-.901 1.369-1.295-.793-.776-2.749-3.519-2.51-4.272.308-.964.234-1.7.234-2.396.097.085 1.842-.525 2.105-.616-.308-1.671-1.557-2.829-2.527-3.303-.051-.61.262-1.837.433-2.202-3.827-2.116-8.442-.599-9.805.268.063-.354.456-1.072.588-1.363-2.63.046-4.814 2.527-5.025 3.314z" />
</symbol>
<symbol viewBox="0 0 66 32" id="logo-regru">
<path d="m3.625 9.683 9.914-5.158a1.36 1.36 0 0 0-1.422-1.049l-8.677.677a1.293 1.293 0 0 0-1.19 1.418l.121 1.224c.072.723-.433 1.361-1.12 1.414l-1.253.097L1.9 27.509l1.673-17.304.05-.522zM13.249 14.808h-2.294v2.771h2.294c.878 0 1.541-.523 1.541-1.386 0-.862-.662-1.385-1.541-1.385z" />
<path d="M24.195 0 4.555 10.217 2.448 32l37.587-2.951 2.107-21.782L24.195 0zm-9.179 23.152-2.239-3.648h-1.822v3.648H8.77V12.883h4.803c2.141 0 3.449 1.4 3.449 3.31 0 1.816-.918 2.787-2.025 3.049l2.53 3.91h-2.512zm11.144-8.344h-5.081v2.17h4.53v1.925h-4.53v2.326h5.081v1.923h-7.267V12.883h7.267v1.925zm11.056 6.605c-1.047 1.17-2.509 1.941-4.373 1.941-3.002 0-5.466-2.093-5.466-5.328 0-3.249 2.463-5.312 5.466-5.312 2.141 0 3.479 1.079 4.249 2.295l-1.818.986a2.903 2.903 0 0 0-2.432-1.341c-1.863 0-3.218 1.432-3.218 3.371s1.355 3.373 3.218 3.373c.907 0 1.77-.401 2.186-.786v-1.097h-2.709v-1.936h4.895v3.834zM42.544 22.077c0-.678.57-1.248 1.247-1.248.679 0 1.249.57 1.249 1.248 0 .677-.57 1.247-1.249 1.247-.677 0-1.247-.57-1.247-1.247zM53.026 23.152l-2.459-3.648h-1.601v3.648h-2.187V12.883h4.803c2.142 0 3.45 1.4 3.45 3.31 0 1.816-1.141 2.787-2.248 3.049l2.752 3.91h-2.51zm-.226-6.959c0-.862-.663-1.385-1.541-1.385h-2.294v2.771h2.294c.878 0 1.541-.523 1.541-1.386zM56.681 19.058v-6.174h2.218v6.096c0 1.431.61 2.418 2.197 2.418s2.182-.986 2.182-2.418v-6.096h2.233v6.158c0 2.557-1.289 4.297-4.415 4.297-3.127-.001-4.415-1.757-4.415-4.281z" />
</symbol>
<symbol viewBox="0 0 32 32" id="arrow-down">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2.4" d="m8 12 8 8 8-8" />
</symbol>
<symbol viewBox="0 0 32 32" id="cancel">
<path stroke-linejoin="round" stroke-linecap="round" stroke-width="4.364" d="M29.091 2.909 2.909 29.091M2.909 2.909l26.182 26.182" />
</symbol>
<symbol viewBox="0 0 32 32" id="hamburger">
 <path stroke-linejoin="round" stroke-linecap="round" stroke-width="1.882" d="M27.294 13.176H3.765m23.411-4.941H3.882m23.294 10.353H3.882m23.412 4.941H3.765" />
</symbol>
<symbol viewBox="0 0 32 32" id="hamburger-open">
<path stroke-linejoin="round" stroke-linecap="round" stroke-width="1.939" d="M19.394 13.576H3.879M28 8H4M28 18.667H4M19.394 24.242H3.879" />
</symbol>
<symbol viewBox="0 0 32 32" id="job">
<path d="M8.597 7.88a2.54 2.54 0 0 1 2.533-2.547h8.405a2.54 2.54 0 0 1 2.533 2.547v.959h3.397a2.54 2.54 0 0 1 2.533 2.547v.577c-.528.813-1.448 1.653-2.871 2.429-2.411 1.316-5.871 2.188-9.796 2.188s-7.385-.872-9.796-2.187c-1.423-.779-2.343-1.62-2.871-2.432v-.577a2.54 2.54 0 0 1 2.533-2.547h3.397V7.88zm2.242.959h8.989v-.754a.89.89 0 0 0-.887-.889h-7.216a.89.89 0 0 0-.887.892v.751zM28 14.755c-2.18 1.813-5.635 3.131-9.669 3.573a1.624 1.624 0 0 1-1.571 2.029h-2.853a1.624 1.624 0 0 1-1.568-2.041l-.003.011c-4.033-.443-7.488-1.76-9.668-3.573v9.365A2.538 2.538 0 0 0 5.2 26.666h20.267A2.54 2.54 0 0 0 28 24.119v-9.365z" />
</symbol>
<symbol viewBox="0 0 16 16" id="letter-a">
<path d="m5.08 13.09.934-2.694H9.99l.93 2.695h1.63L8.888 2.909H7.113L3.448 13.091H5.08ZM6.46 9.105l1.502-4.345h.08l1.5 4.345H6.462Z" />
</symbol>
<symbol viewBox="0 0 32 32" id="line">
<path stroke-linecap="round" stroke-width="3.2" d="M15.601 7.601v18.133" />
</symbol>
<symbol viewBox="0 0 32 32" id="moon">
<path stroke-linejoin="round" stroke-linecap="round" stroke-width="2.56" d="M27.733 17.056c-.571 6.013-5.595 10.679-11.709 10.679-6.494 0-11.759-5.265-11.759-11.759 0-6.114 4.666-11.138 10.632-11.706l.047-.004a9.083 9.083 0 0 0-1.791 5.436 9.146 9.146 0 0 0 8.432 9.118l.031.002c2.185.164 4.354-.843 6.116-2.144v.38z" />
</symbol>
<symbol viewBox="0 0 32 32" id="notification">
<path d="M16 4c-1.461 0-2.68 1.011-2.937 2.347-3.133.719-5.473 3.588-5.473 7.02v5.319a1.472 1.472 0 0 1-.239.803l.003-.006L6.238 21.2c-.62.956.048 2.236 1.167 2.236h17.192c1.12 0 1.787-1.28 1.167-2.236l-1.116-1.717a1.448 1.448 0 0 1-.235-.794v-5.323c0-3.429-2.343-6.3-5.475-7.019C18.681 5.011 17.463 4 16.001 4zm.284 24c-1.673 0-3.057-1.28-3.272-2.936h6.544C19.341 26.721 17.959 28 16.284 28z" />
</symbol>
<symbol viewBox="0 0 24 24" id="pen">
<path fill-rule="evenodd" clip-rule="evenodd" d="M14.367 5.19724L16.011 3.49803C16.6587 2.8286 17.7291 2.81991 18.3878 3.47856L20.5117 5.60249C21.1628 6.25353 21.1628 7.30908 20.5117 7.96013L18.799 9.67286C18.6354 9.83643 18.3699 9.8355 18.2075 9.67078L14.3702 5.77917C14.2113 5.61799 14.2096 5.35992 14.367 5.19724ZM17.6028 10.9937L8.42704 20.1695C8.36555 20.231 8.28638 20.2717 8.2006 20.2859L3.97047 20.9883C3.40368 21.0824 2.91386 20.5883 3.01285 20.0224L3.7461 15.8301C3.76088 15.7456 3.80133 15.6678 3.86194 15.6072L13.0391 6.43002C13.2019 6.26726 13.4657 6.26726 13.6285 6.43002L17.6028 10.4043C17.7656 10.5671 17.7656 10.831 17.6028 10.9937ZM5.56093 19.6389L7.85319 19.2429L7.85319 17.9717L6.14441 17.9717L6.14441 16.263L4.83157 16.263L4.43563 18.5552L5.56093 19.6389Z" />
</symbol>
<symbol viewBox="0 0 32 32" id="search">
<path stroke-linejoin="round" stroke-linecap="round" stroke-width="2.667" d="M14.667 25.333c5.891 0 10.667-4.776 10.667-10.667S20.558 3.999 14.667 3.999v0C8.776 3.999 4 8.775 4 14.666s4.776 10.667 10.667 10.667v0zM28 28l-5.8-5.8" />
</symbol>
<symbol viewBox="0 0 32 32" id="sun">
<path stroke-linejoin="round" stroke-linecap="round" stroke-width="2.667" d="M16 22.667a6.667 6.667 0 0 0 0-13.334v0a6.667 6.667 0 0 0 0 13.334v0zm0-21.334V4m0 24v2.667M5.626 5.626 7.52 7.52m16.96 16.96 1.894 1.894M1.333 16H4m24 0h2.667M5.626 26.374 7.52 24.48M24.48 7.52l1.894-1.894" />
</symbol>
<symbol viewBox="0 0 32 32" id="user">
<path d="M16 16c2.945 0 5.333-2.687 5.333-6S18.945 4 16 4c-2.947 0-5.333 2.687-5.333 6s2.387 6 5.333 6zm-.784 1.333c-4.944.001-9.116 3.31-10.421 7.834l-.019.077A2.17 2.17 0 0 0 6.862 28h18.272a2.169 2.169 0 0 0 2.084-2.771l.004.015c-1.324-4.6-5.495-7.909-10.438-7.911h-1.568z" />
</symbol>
<symbol viewBox="0 0 64 64" id="icon-view" stroke-width="3.5" fill="none" stroke-linejoin="round" stroke-linecap="round">
<path d="M53.79 33.1a.51.51 0 000-.4c-.96-1.81-8.5-15.53-21.79-15.86S11 30.61 9.92 32.65a.48.48 0 000 .48C11.1 35.06 19.35 48.05 29.68 49c11.39 1 20.63-7 24.11-15.9z"></path>
<circle cx="31.7" cy="32.76" r="6.91"></circle>
</symbol>
<symbol viewBox="0 0 32 32" id="book">
<path d="m25.467 4.667.2.933a4.327 4.327 0 0 0-.64-.24L10.84 2.4l10-1.04a4.255 4.255 0 0 1 4.626 3.306zM8.733 3.773 23.24 6.6a4.187 4.187 0 0 1 3.426 4.094v14.507a4.237 4.237 0 0 1-1.514 3.242 4.214 4.214 0 0 1-3.458.918L7.707 26.974a2.787 2.787 0 0 1-2.374-2.666V6.495a2.828 2.828 0 0 1 3.399-2.72zm1.08 13.36 10.893 2.107a1.069 1.069 0 0 0 1.24-.813 1.034 1.034 0 0 0-.457-1.077 1.04 1.04 0 0 0-.383-.15l-10.88-2.107a1.067 1.067 0 0 0-1.253.814 1.034 1.034 0 0 0 .457 1.077c.116.075.247.126.383.15zm0-5.533 10.893 2.107a1.069 1.069 0 0 0 1.24-.813 1.034 1.034 0 0 0-.457-1.077 1.04 1.04 0 0 0-.383-.15L10.226 9.56a1.067 1.067 0 0 0-1.253.814 1.034 1.034 0 0 0 .457 1.077c.116.075.247.126.383.15z" />
</symbol>
<symbol viewBox="0 0 32 32" id="clock">
<path d="M9.047 3.344a4.103 4.103 0 0 0-4.813.214 4.274 4.274 0 0 0-1.333 4.707 1.082 1.082 0 0 0 1.747.36l4.333-3.467a1.11 1.11 0 0 0 .496-.89 1.113 1.113 0 0 0-.43-.924zm6.747 2.84a11.194 11.194 0 0 0-7.883 3.342A11.195 11.195 0 0 0 4.7 17.463a11.19 11.19 0 0 0 11.094 11.28 11.194 11.194 0 0 0 7.883-3.342 11.189 11.189 0 0 0 3.211-7.938 11.19 11.19 0 0 0-6.82-10.392 11.19 11.19 0 0 0-4.274-.887zm1.334 13.04a1.052 1.052 0 0 1-1.04 1.053h-4.8a1.028 1.028 0 0 1-.653-.28 1.056 1.056 0 0 1-.333-.773 1.052 1.052 0 0 1 1.04-1.053h3.76v-5.333a1.064 1.064 0 0 1 .633-.97c.128-.055.267-.083.406-.083a1.056 1.056 0 0 1 1.04 1.053l-.053 6.387zm7.841-16.553a4.105 4.105 0 0 1 2.372.887 4.276 4.276 0 0 1 1.386 4.72 1.082 1.082 0 0 1-1.747.36l-4.373-3.48a1.335 1.335 0 0 1-.48-.733.974.974 0 0 1 .4-1.08 4.103 4.103 0 0 1 2.441-.673z" />
</symbol>
<symbol viewBox="0 0 32 32" id="cmd">
<path d="M6 5.333a3.333 3.333 0 0 0-3.333 3.333v13.333A3.333 3.333 0 0 0 6 25.332h20a3.333 3.333 0 0 0 3.333-3.333V8.666A3.33 3.33 0 0 0 26 5.332H6zm2.552 13.959a1 1 0 0 1 .156-1.406l3.191-2.552-3.191-2.553a1 1 0 1 1 1.25-1.561l4.167 3.333a1.002 1.002 0 0 1 0 1.561l-4.167 3.333a.997.997 0 0 1-1.406-.155zm7.448.041a1 1 0 0 1 1-1h6.333a1 1 0 0 1 .696 1.719 1 1 0 0 1-.696.282H17a1 1 0 0 1-1-1z" />
</symbol>
<symbol viewBox="0 0 32 32" id="company">
<path d="m29.68 11.72-7.747 4.067a.489.489 0 0 1-.494-.008.499.499 0 0 1-.24-.432V12.6a1.007 1.007 0 0 0-.482-.845 1.002 1.002 0 0 0-.971-.036l-7.747 4.067a.489.489 0 0 1-.494-.008.499.499 0 0 1-.24-.432V4.999a1.001 1.001 0 0 0-.986-1h-8a1.001 1.001 0 0 0-.947 1v23.333a.997.997 0 0 0 1 1h27.813a.997.997 0 0 0 1-1V12.599a1.001 1.001 0 0 0-1.467-.88zM10.773 23.867a.997.997 0 0 1-1 1h-1.48a.997.997 0 0 1-1-1v-1.493a1.003 1.003 0 0 1 .607-.96.996.996 0 0 1 .392-.08h1.48a.997.997 0 0 1 1 1v1.533zm7.454 0a.997.997 0 0 1-1 1h-1.493a.997.997 0 0 1-1-1v-1.493a.991.991 0 0 1 .607-.96.996.996 0 0 1 .392-.08h1.493a.997.997 0 0 1 1 1v1.533zm6.96 0a.997.997 0 0 1-1 1h-1.52a.997.997 0 0 1-1-1v-1.493a.991.991 0 0 1 .607-.96.996.996 0 0 1 .392-.08h1.493a.997.997 0 0 1 1 1l.027 1.533z" />
</symbol>
<symbol viewBox="0 0 32 32" id="game">
<path d="m31.725 21.64-4.133-12a6.416 6.416 0 0 0-6.106-4.307H10.459a6.414 6.414 0 0 0-6.187 4.613l-4 11.267a4 4 0 0 0 1.626 4.853 5.788 5.788 0 0 0 6.107-1.333l2.427-3.627a1.326 1.326 0 0 1 1.107-.586h8.693a1.332 1.332 0 0 1 1.12.6l2.587 4c1.107 1.507 4.467 1.973 6.133 1.067a3.623 3.623 0 0 0 1.654-4.546zm-18.293-7.387h-1.627V15.8a.997.997 0 0 1-1 1 .997.997 0 0 1-1-1v-1.547h-1.6a.987.987 0 1 1 0-1.96h1.613v-1.56a.997.997 0 0 1 1-1 .997.997 0 0 1 1 1v1.56h1.613a.987.987 0 1 1 0 1.96zm6.293 2.76a1.66 1.66 0 0 1-1.521-1.047 1.67 1.67 0 0 1 .378-1.807 1.668 1.668 0 0 1 2.836 1.187 1.684 1.684 0 0 1-1.05 1.544 1.673 1.673 0 0 1-.644.123zm2.667-3.68a1.671 1.671 0 0 1-1.608-1.985 1.662 1.662 0 0 1 1.28-1.311 1.67 1.67 0 0 1 1.711.657c.19.265.298.579.311.904a1.683 1.683 0 0 1-1.033 1.604 1.677 1.677 0 0 1-.66.129z" />
</symbol>
<symbol viewBox="0 0 32 32" id="topic">
<path d="M2.667 8.408A4.414 4.414 0 0 1 7.088 4h19.158a4.415 4.415 0 0 1 4.421 4.408v10.286a4.414 4.414 0 0 1-4.421 4.408h-8.842l-4.763 5.699c-.882 1.056-2.606.434-2.606-.941v-4.758H7.088a4.415 4.415 0 0 1-4.421-4.408V8.408zm13.998-1.469c-.806 0-1.451.665-1.426 1.468l.196 6.166c.021.659.563 1.183 1.225 1.183s1.202-.522 1.224-1.181l.206-6.166a1.424 1.424 0 0 0-1.426-1.47zm.002 13.225c.814 0 1.474-.658 1.474-1.469s-.66-1.469-1.474-1.469-1.474.658-1.474 1.469.66 1.469 1.474 1.469z" />
</symbol>
<symbol viewBox="0 0 32 32" id="extinguisher">
<path d="m28.355 2.781-7.928 1.245a.467.467 0 0 0-.392.465v.529h-4.412a2.514 2.514 0 0 0-.119-2.516 2.543 2.543 0 0 0-3.493-.782 2.519 2.519 0 0 0-.815 3.471c-2.761.116-4.71 2.93-4.925 3.715-.364 1.356 1.399 1.857 2.332.293.825-1.393 1.809-1.834 3.498-1.857h2.397v1.857c-1.191.264-2.256.925-3.019 1.873s-1.179 2.127-1.178 3.342v14.86c0 .369.147.724.41.985s.618.408.989.408h7.928c.371 0 .727-.147.989-.408s.41-.616.41-.985v-14.86c-.001-1.214-.417-2.392-1.18-3.339S18.02 9.47 16.83 9.206V7.349h3.199v.534a.468.468 0 0 0 .392.465l7.928 1.245a.47.47 0 0 0 .5-.267.461.461 0 0 0 .041-.197V3.245a.464.464 0 0 0-.536-.46zM13.362 4.922a1.063 1.063 0 0 1-.983-.653 1.05 1.05 0 0 1 .231-1.154 1.068 1.068 0 0 1 1.635.16 1.054 1.054 0 0 1-.132 1.337c-.199.199-.47.31-.752.31z" />
</symbol>
<symbol viewBox="0 0 32 32" id="funnel">
<path d="M27.14 5.736a1.88 1.88 0 0 0-1.737-1.131H4.998a1.901 1.901 0 0 0-1.406 3.179l7.808 8.589v9.258a1.902 1.902 0 0 0 1.992 1.898c.344-.017.676-.126.962-.317l3.8-2.533A1.892 1.892 0 0 0 19 23.098v-6.724l7.808-8.589a1.878 1.878 0 0 0 .332-2.046z" />
</symbol>
<symbol viewBox="0 0 24 24" id="trash">
<path fill-rule="evenodd" clip-rule="evenodd" d="M8.23 2.41A.57.57 0 0 1 8.78 2h6.43a.57.57 0 0 1 .55.43l.2.82h4.48a.56.56 0 0 1 .56.56v1.48a.56.56 0 0 1-.56.55H3.56A.56.56 0 0 1 3 5.29V3.81a.56.56 0 0 1 .56-.56H8l.23-.84Zm-3.92 4.4h15.42v13.8a1.4 1.4 0 0 1-1.4 1.39H5.72a1.401 1.401 0 0 1-1.41-1.39V6.81ZM7.5 10a.66.66 0 0 1 1.31 0v8.85a.66.66 0 0 1-1.31 0V10Zm3.89 0a.66.66 0 0 1 1.31 0v8.85a.66.66 0 0 1-1.31 0V10Zm4.5-.65a.66.66 0 0 0-.66.65v8.85a.66.66 0 1 0 1.32 0V10a.658.658 0 0 0-.66-.69v.04Z" />
</symbol>
<symbol viewBox="0 0 32 32" id="cup">
<path d="M29.001 6.978h-2.998v-.993c-.001-.526-.211-1.031-.586-1.403S24.534 4 24.004 4H8.012c-.53.001-1.038.21-1.413.582s-.586.877-.586 1.403v.993H2.999c-.53.001-1.038.21-1.413.582S1 8.437 1 8.963v1.985c.002 1.316.528 2.577 1.465 3.508s2.207 1.454 3.532 1.455h.505c1.205 3.714 3.787 6.498 7.777 6.899v3.027h-2.27c-.265 0-.519.105-.707.291s-.293.439-.293.702c0 .263.105.694.293.88s.442.291.707.291h7.996c.265 0 .519-.105.707-.291s.293-.617.293-.88-.105-.516-.293-.702-.442-.291-.707-.291h-2.282V22.81c1.946-.196 3.076-.953 4.594-2.179s2.64-2.867 3.229-4.72h.457c1.325-.001 2.595-.525 3.532-1.455s1.464-2.192 1.465-3.508V8.963c-.001-.526-.211-1.031-.586-1.403s-.883-.582-1.413-.582zM5.997 13.926c-.795-.001-1.557-.315-2.119-.873S3 11.738 2.999 10.948V8.963h3.014v3.858c.001.369.021.738.062 1.105h-.078zm23.004-2.978c-.001.789-.317 1.546-.879 2.105s-1.324.872-2.119.873h-.049c.033-.328.049-.659.049-.993v-3.97h2.998v1.985z" />
</symbol>
<symbol viewBox="0 0 24 24" id="fill-bookmark">

<path stroke-width="2" d="M6.00001 21.002V20.998V4.99801C6.00001 4.46758 6.21072 3.95887 6.5858 3.5838C6.96087 3.20873 7.46958 2.99801 8.00001 2.99801H16C16.5304 2.99801 17.0391 3.20873 17.4142 3.5838C17.7893 3.95887 18 4.46758 18 4.99801V20.998L17.9932 20.998L12.5005 17.8223L12 17.5329L11.4995 17.8223L6.00001 21.002Z" />
</symbol>
<symbol viewBox="0 0 25 25" id="bookmark">
<path d="M16.537 3.26H8.463c-.803 0-1.573.31-2.141.86a2.889 2.889 0 0 0-.887 2.075v15.65c0 .172.045.34.134.49.089.15.216.274.37.36a1.034 1.034 0 0 0 1.01 0l5.551-3.11 5.551 3.11c.154.084.328.128.505.127a.994.994 0 0 0 .875-.487.955.955 0 0 0 .134-.49V6.194c0-.778-.319-1.524-.887-2.075a3.078 3.078 0 0 0-2.14-.86Zm1.01 16.892-4.542-2.543a1.035 1.035 0 0 0-1.01 0l-4.542 2.543V6.195c0-.26.107-.508.296-.692.19-.183.446-.286.714-.286h8.074c.268 0 .525.103.714.286.19.184.296.433.296.692v13.957Z" />
</symbol>
<symbol viewBox="0 0 25 25" id="commentary">
<path d="m21.453 4.835-2.377-2.377a.978.978 0 0 0-1.38 0l-5.458 5.459a.978.978 0 0 0-.284.694v2.368a.978.978 0 0 0 .979.978H15.3a.979.979 0 0 0 .694-.284l5.459-5.458a.978.978 0 0 0 0-1.38ZM14.889 10h-.978v-.978l4.48-4.48.978.978L14.89 10Zm3.913 1.957a.978.978 0 0 0-.978.978 6.848 6.848 0 0 1-6.848 6.848H5.508l.626-.617a.978.978 0 0 0 0-1.389 6.847 6.847 0 0 1 4.842-11.69.978.978 0 1 0 0-1.956A8.804 8.804 0 0 0 4.13 18.433l-1.673 1.633a.978.978 0 0 0-.206 1.067.978.978 0 0 0 .9.606h7.826a8.803 8.803 0 0 0 8.804-8.804.978.978 0 0 0-.978-.978Z" />
</symbol>
<symbol viewBox="0 0 24 24" id="sharing">
<path d="M18.5437 15.0062C18.0262 15.0069 17.5164 15.1316 17.057 15.3697C16.5976 15.6079 16.2019 15.9526 15.9031 16.3751L9.06665 13.2647C9.19406 12.9304 9.26522 12.5773 9.27725 12.2198C9.27524 11.9827 9.24809 11.7465 9.19625 11.5151L15.0769 7.30311C15.5783 7.87173 16.2633 8.24648 17.0126 8.36213C17.7619 8.47778 18.528 8.327 19.1776 7.93605C19.8272 7.54509 20.3191 6.93871 20.5677 6.22247C20.8163 5.50622 20.8059 4.72548 20.5382 4.01614C20.2705 3.30681 19.7626 2.7138 19.1028 2.34036C18.443 1.96691 17.6731 1.83668 16.9272 1.97233C16.1812 2.10798 15.5065 2.50092 15.0204 3.08275C14.5343 3.66458 14.2677 4.39845 14.2669 5.15661C14.2689 5.39371 14.296 5.62993 14.3479 5.86131L8.46725 10.0733C8.10878 9.668 7.65451 9.35892 7.1459 9.17428C6.63729 8.98964 6.09053 8.93532 5.55554 9.01628C5.02054 9.09723 4.51433 9.31089 4.08312 9.63774C3.65191 9.96459 3.30942 10.3942 3.08692 10.8875C2.86441 11.3807 2.76897 11.9218 2.80931 12.4614C2.84965 13.0009 3.02448 13.5218 3.31785 13.9765C3.61122 14.4311 4.01378 14.8051 4.4888 15.0642C4.96382 15.3233 5.49616 15.4593 6.03725 15.4598C6.83039 15.4626 7.597 15.1744 8.19185 14.6498L15.3037 17.9222C15.3037 18.0275 15.3037 18.1328 15.3037 18.2462C15.3037 18.887 15.4937 19.5134 15.8497 20.0463C16.2057 20.5791 16.7117 20.9943 17.3038 21.2396C17.8958 21.4848 18.5472 21.549 19.1757 21.424C19.8042 21.2989 20.3816 20.9904 20.8347 20.5372C21.2878 20.0841 21.5964 19.5068 21.7214 18.8783C21.8464 18.2498 21.7823 17.5983 21.537 17.0063C21.2918 16.4143 20.8765 15.9083 20.3437 15.5522C19.8109 15.1962 19.1845 15.0062 18.5437 15.0062ZM17.5069 3.53661C17.8273 3.53661 18.1405 3.63162 18.4069 3.80963C18.6733 3.98764 18.8809 4.24065 19.0035 4.53666C19.1262 4.83268 19.1582 5.15841 19.0957 5.47266C19.0332 5.78691 18.8789 6.07556 18.6524 6.30212C18.4258 6.52868 18.1371 6.68297 17.8229 6.74548C17.5086 6.80799 17.1829 6.77591 16.8869 6.65329C16.5909 6.53068 16.3379 6.32304 16.1599 6.05663C15.9819 5.79023 15.8869 5.47702 15.8869 5.15661C15.8869 4.72696 16.0575 4.31491 16.3613 4.0111C16.6651 3.70729 17.0772 3.53661 17.5069 3.53661ZM6.03725 13.8398C5.71685 13.8398 5.40364 13.7448 5.13723 13.5668C4.87082 13.3888 4.66318 13.1358 4.54057 12.8398C4.41795 12.5437 4.38587 12.218 4.44838 11.9038C4.51089 11.5895 4.66518 11.3009 4.89174 11.0743C5.1183 10.8477 5.40696 10.6934 5.72121 10.6309C6.03546 10.5684 6.36118 10.6005 6.6572 10.7231C6.95322 10.8457 7.20623 11.0534 7.38423 11.3198C7.56224 11.5862 7.65725 11.8994 7.65725 12.2198C7.65725 12.6495 7.48657 13.0615 7.18277 13.3653C6.87896 13.6691 6.4669 13.8398 6.03725 13.8398ZM18.5437 19.8662C18.2232 19.8662 17.91 19.7712 17.6436 19.5932C17.3772 19.4152 17.1696 19.1622 17.047 18.8662C16.9244 18.5701 16.8923 18.2444 16.9548 17.9302C17.0173 17.6159 17.1716 17.3273 17.3981 17.1007C17.6247 16.8741 17.9134 16.7198 18.2276 16.6573C18.5419 16.5948 18.8676 16.6269 19.1636 16.7495C19.4596 16.8721 19.7126 17.0798 19.8906 17.3462C20.0686 17.6126 20.1637 17.9258 20.1637 18.2462C20.1637 18.6759 19.993 19.0879 19.6892 19.3917C19.3854 19.6955 18.9733 19.8662 18.5437 19.8662Z" />
</symbol>
<symbol viewBox="0 0 61 61" id="video-play">
<circle cx="30.5" cy="30.5" r="30.5" fill="white" fill-opacity="0.8" />
<path d="M44.4698 29.6305C45.1444 30.0139 45.1444 30.9861 44.4698 31.3695L25.494 42.1511C24.8274 42.5299 24 42.0484 24 41.2817L24 19.7183C24 18.9516 24.8274 18.4701 25.494 18.8489L44.4698 29.6305Z" fill="#1D706D" />
</symbol>

<symbol viewBox="0 0 25 25" id="angry">
<path d="M12.5 0C19.402 0 25 5.597 25 12.5S19.402 25 12.5 25 0 19.403 0 12.5 5.598 0 12.5 0Z" fill="#FFE67E" />
<path d="M12.5 0C19.402 0 25 5.597 25 12.5S19.402 25 12.5 25 0 19.403 0 12.5 5.598 0 12.5 0Z" fill="url(#angryA)" fill-opacity=".6" />
<path d="M12.5 0C19.402 0 25 5.597 25 12.5S19.402 25 12.5 25 0 19.403 0 12.5 5.598 0 12.5 0Z" fill="url(#angryB)" fill-opacity=".7" />
<path d="M15.594 15.395c-.154.049-.22-.019-.505-.361-.294-.31-.875-.966-2.508-.983-.743.011-1.347.17-1.718.383-.385.21-.603.435-.751.6-.147.166-.228.275-.3.328a.237.237 0 0 1-.205.035c-.134-.033-.308-.132-.106-.664.112-.252.337-.63.843-.969.505-.348 1.253-.604 2.276-.608.428.008.924.06 1.292.173.378.116.698.258.946.435.505.339.73.717.842.97.202.53.03.632-.106.66ZM7.492 12a2.057 2.057 0 1 0 0-4.114 2.057 2.057 0 0 0 0 4.114Z" fill="#1C1B1A" />
<path d="M10.605 9.193c-.13.328-.43.264-2.721-.653-2.292-.916-2.553-1.076-2.422-1.404.132-.328.346-.55 2.81.434 2.463.986 2.464 1.295 2.333 1.623ZM17.158 12a2.057 2.057 0 1 1 0-4.114 2.057 2.057 0 0 1 0 4.114Z" fill="#1C1B1A" />
<path d="M14.044 9.193c.132.328.43.264 2.722-.653 2.292-.916 2.552-1.076 2.421-1.404-.13-.328-.345-.55-2.809.434-2.464.986-2.465 1.295-2.334 1.623Z" fill="#1C1B1A" />
<defs>
<radialGradient id="angryA" cx="0" cy="0" r="1" gradientUnits="userSpaceOnUse" gradientTransform="rotate(78.253 -1.623 10.97) scale(14.9877 14.9994)">
<stop stop-color="#FFC42B" stop-opacity="0" />
<stop offset="1" stop-color="#FFAA2B" />
</radialGradient>
<linearGradient id="angryB" x1="13" y1="29.5" x2="13" y2="0" gradientUnits="userSpaceOnUse">
<stop stop-color="#FD0606" />
<stop offset="1" stop-color="#FC5B00" stop-opacity="0" />
</linearGradient>
</defs>
</symbol>
<symbol viewBox="0 0 25 25" id="laugh">
<path d="M12.5 0C19.402 0 25 5.597 25 12.5S19.402 25 12.5 25 0 19.403 0 12.5 5.598 0 12.5 0Z" fill="#FFE67E" />
<path d="M12.5 0C19.402 0 25 5.597 25 12.5S19.402 25 12.5 25 0 19.403 0 12.5 5.598 0 12.5 0Z" fill="url(#laughA)" fill-opacity=".6" />
<path d="M12.5 0C19.402 0 25 5.597 25 12.5S19.402 25 12.5 25 0 19.403 0 12.5 5.598 0 12.5 0Z" fill="url(#laughB)" fill-opacity=".3" />
<path d="M9.588 10.11c-.195.002-.27-.1-.409-.465-.078-.178-.177-.434-.42-.703a1.622 1.622 0 0 0-1.2-.561 1.62 1.62 0 0 0-1.2.561c-.243.27-.342.525-.42.703a2.82 2.82 0 0 1-.182.372c-.061.084-.135.105-.227.1-.093-.005-.18-.02-.257-.093a.482.482 0 0 1-.107-.16c-.024-.08-.047-.2-.048-.344-.005-.28.067-.713.4-1.225a2.482 2.482 0 0 1 2.04-1.091A2.482 2.482 0 0 1 9.6 8.295c.334.512.406.945.4 1.225-.005.284-.077.431-.154.507-.077.076-.164.084-.257.084ZM19.47 10.11c-.194.002-.27-.1-.409-.465-.078-.178-.177-.434-.42-.703a1.622 1.622 0 0 0-1.2-.561 1.62 1.62 0 0 0-1.2.561c-.243.27-.342.525-.42.703-.075.179-.12.265-.182.372-.06.084-.135.105-.227.1-.093-.005-.18-.02-.257-.093a.482.482 0 0 1-.106-.16c-.025-.08-.048-.2-.049-.344-.005-.28.067-.713.4-1.225a2.482 2.482 0 0 1 2.041-1.091 2.482 2.482 0 0 1 2.04 1.091c.334.512.406.945.401 1.225-.006.284-.077.431-.154.507-.077.076-.165.084-.258.084Z" fill="#1C1B1A" />
<path d="M6 11s-.54 4.222-1.555 5.236A2.616 2.616 0 0 1 2.602 17c-.469 0-.938-.125-1.347-.382a2.595 2.595 0 0 1-.693-3.835c.06-.081.13-.158.202-.229C1.778 11.54 6 11 6 11Z" fill="#45D4FF" />
<path d="M6 11s-.54 4.222-1.555 5.236A2.616 2.616 0 0 1 2.602 17c-.469 0-.938-.125-1.347-.382a2.595 2.595 0 0 1-.693-3.835c.06-.081.13-.158.202-.229C1.778 11.54 6 11 6 11Z" fill="url(#laughC)" />
<path d="M7.22 12.02h10.56c.558 0 .975.543.882 1.135-.042.268-.1.53-.17.787H6.508a7.047 7.047 0 0 1-.171-.787c-.093-.592.325-1.136.882-1.136Z" fill="#fff" />
<path d="M6.509 13.942h11.982a6.732 6.732 0 0 1-2.152 3.385c-.343-.856-1.13-1.462-2.053-1.462-.732 0-1.38.38-1.786.962-.406-.582-1.053-.962-1.786-.962-.924 0-1.714.606-2.053 1.462a6.732 6.732 0 0 1-2.152-3.385Z" fill="#1C1B1A" />
<path d="M14.286 15.865c.924 0 1.71.606 2.053 1.462-1.062.894-2.393 1.423-3.84 1.423-1.446 0-2.776-.529-3.838-1.423.339-.856 1.13-1.462 2.053-1.462.732 0 1.38.38 1.786.962.406-.582 1.053-.962 1.786-.962Z" fill="#ED464E" />
<path d="M14.286 15.865c.924 0 1.71.606 2.053 1.462-1.062.894-2.393 1.423-3.84 1.423-1.446 0-2.776-.529-3.838-1.423.339-.856 1.13-1.462 2.053-1.462.732 0 1.38.38 1.786.962.406-.582 1.053-.962 1.786-.962Z" fill="url(#laughD)" />
<path d="M24.438 12.784a2.595 2.595 0 0 1-.692 3.835c-.41.256-.878.381-1.347.381-.666 0-1.331-.256-1.845-.764C19.54 15.222 19 11 19 11s4.222.54 5.236 1.555c.071.07.142.147.202.229Z" fill="#45D4FF" />
<path d="M24.438 12.784a2.595 2.595 0 0 1-.692 3.835c-.41.256-.878.381-1.347.381-.666 0-1.331-.256-1.845-.764C19.54 15.222 19 11 19 11s4.222.54 5.236 1.555c.071.07.142.147.202.229Z" fill="url(#laughE)" />
<defs>
<radialGradient id="laughA" cx="0" cy="0" r="1" gradientUnits="userSpaceOnUse" gradientTransform="rotate(78.253 -1.623 10.97) scale(14.9877 14.9994)">
<stop stop-color="#FFC42B" stop-opacity="0" />
<stop offset="1" stop-color="#FFAA2B" />
</radialGradient>
<radialGradient id="laughC" cx="0" cy="0" r="1" gradientUnits="userSpaceOnUse" gradientTransform="matrix(0 3 -3 0 3 14)">
<stop stop-color="#45D4FF" stop-opacity="0" />
<stop offset="1" stop-color="#2CA9CE" />
</radialGradient>
<radialGradient id="laughE" cx="0" cy="0" r="1" gradientUnits="userSpaceOnUse" gradientTransform="matrix(0 3 -3 0 22 14)">
<stop stop-color="#45D4FF" stop-opacity="0" />
<stop offset="1" stop-color="#2CA9CE" />
</radialGradient>
<linearGradient id="laughB" x1="13.043" y1="7.609" x2="9.239" y2="29.348" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFD52B" stop-opacity="0" />
<stop offset=".562" stop-color="#FF9913" stop-opacity=".562" />
<stop offset=".734" stop-color="#FF870B" stop-opacity=".734" />
<stop offset="1" stop-color="#FF6B00" />
</linearGradient>
<linearGradient id="laughD" x1="12.5" y1="19.231" x2="12.5" y2="16.827" gradientUnits="userSpaceOnUse">
<stop stop-color="#891319" />
<stop offset="1" stop-color="#ED464E" stop-opacity="0" />
</linearGradient>
</defs>
</symbol>
<symbol viewBox="0 0 25 25" id="like">
<path d="M12.5 0C19.402 0 25 5.597 25 12.5S19.402 25 12.5 25 0 19.403 0 12.5 5.598 0 12.5 0Z" fill="#2AA5A0" />
<path d="M7.04 9.384H5.982c-.541 0-.982.428-.982.95v7.715c0 .523.44.951.982.951H7.04c.541 0 .982-.428.982-.951v-7.714c0-.523-.44-.951-.982-.951ZM18.172 9.507h-2.955c-1.017 0-1.4-.37-1.436-1.344 0-.042 0-.089.006-.13l.425-3.176a.809.809 0 0 0-.012-.293c-.177-.59-1.741-.828-2.088-.165l-.054.088-3.327 5.126a.994.994 0 0 0-.113.205 1.782 1.782 0 0 0-.102.587v6.787c0 .998.826 1.808 1.843 1.808h6.366c1.25 0 2.321-1.41 2.524-2.624l.724-4.78c.192-1.091-.67-2.09-1.8-2.09Z" fill="#fff" />
</symbol>
<symbol viewBox="0 0 25 25" id="surprised">
<path d="M12.5 25C19.404 25 25 19.404 25 12.5S19.404 0 12.5 0 0 5.596 0 12.5 5.596 25 12.5 25Z" fill="#FFE67E" />
<path d="M12.5 25C19.404 25 25 19.404 25 12.5S19.404 0 12.5 0 0 5.596 0 12.5 5.596 25 12.5 25Z" fill="url(#surprisedA)" fill-opacity=".6" />
<path d="M12.5 25C19.404 25 25 19.404 25 12.5S19.404 0 12.5 0 0 5.596 0 12.5 5.596 25 12.5 25Z" fill="url(#surprisedB)" fill-opacity=".3" />
<path d="M18 10.73a2 2 0 1 0 0-4 2 2 0 0 0 0 4ZM16.827 16.346a6.24 6.24 0 0 1-.476 2.409 2.409 2.409 0 0 0-1.928-.966c-.788 0-1.48.38-1.923.961a2.402 2.402 0 0 0-3.851.01 6.244 6.244 0 0 1-.476-2.414c0-2.923 1.938-5.288 4.327-5.288 2.39 0 4.327 2.365 4.327 5.288Z" fill="#1C1B1A" />
<path d="M12.5 18.75a2.408 2.408 0 0 1 1.923-.962c.788 0 1.486.38 1.928.967-.716 1.711-2.173 2.88-3.851 2.88s-3.135-1.169-3.851-2.875a2.402 2.402 0 0 1 3.851-.01Z" fill="#ED464E" />
<path d="M12.5 18.75a2.408 2.408 0 0 1 1.923-.962c.788 0 1.486.38 1.928.967-.716 1.711-2.173 2.88-3.851 2.88s-3.135-1.169-3.851-2.875a2.402 2.402 0 0 1 3.851-.01Z" fill="url(#surprisedE)" />
<path d="M7 10.73a2 2 0 1 0 0-4 2 2 0 0 0 0 4Z" fill="#1C1B1A" />
<defs>
<linearGradient id="surprisedB" x1="13.043" y1="7.609" x2="9.239" y2="29.348" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFD52B" stop-opacity="0" />
<stop offset=".562" stop-color="#FF9913" stop-opacity=".562" />
<stop offset=".734" stop-color="#FF870B" stop-opacity=".734" />
<stop offset="1" stop-color="#FF6B00" />
</linearGradient>
<linearGradient id="surprisedE" x1="12.5" y1="22.276" x2="12.5" y2="19.07" gradientUnits="userSpaceOnUse">
<stop stop-color="#891319" />
<stop offset="1" stop-color="#ED464E" stop-opacity="0" />
</linearGradient>
<radialGradient id="surprisedA" cx="0" cy="0" r="1" gradientUnits="userSpaceOnUse" gradientTransform="rotate(78.253 -1.623 10.97) scale(14.9877 14.9994)">
<stop stop-color="#FFC42B" stop-opacity="0" />
<stop offset="1" stop-color="#FFAA2B" />
</radialGradient>
</defs>
</symbol>
<symbol viewBox="0 0 25 25" id="thinking">
<path d="M12.5 0C19.403 0 25 5.597 25 12.5S19.403 25 12.5 25 0 19.403 0 12.5 5.597 0 12.5 0Z" fill="#FFE67E" />
<path d="M12.5 0C19.403 0 25 5.597 25 12.5S19.403 25 12.5 25 0 19.403 0 12.5 5.597 0 12.5 0Z" fill="url(#thinkingA)" fill-opacity=".7" />
<path d="M12.5 0C19.403 0 25 5.597 25 12.5S19.403 25 12.5 25 0 19.403 0 12.5 5.597 0 12.5 0Z" fill="url(#thinkingB)" fill-opacity=".3" />
<path d="M7.01 9.572c1.111 0 2.012-.922 2.012-2.06 0-1.137-.9-2.06-2.011-2.06C5.9 5.453 5 6.376 5 7.513c0 1.138.9 2.06 2.01 2.06ZM15.01 10.119c1.111 0 2.012-.922 2.012-2.06 0-1.137-.9-2.059-2.011-2.059C13.9 6 13 6.922 13 8.06c0 1.137.9 2.059 2.01 2.059ZM10.03 4.767c-.124.39-.37-.05-3.023-.932-2.072-.69-3.062-.205-2.939-.594.124-.39.45-1.504 3.303-.556 2.853.949 2.781 1.693 2.658 2.082ZM19.263 4.734c.004.384-.671.023-3.13.023-2.244-.023-2.912.36-2.916-.023-.003-.385.09-1.087 2.907-1.112 2.816-.024 3.136.728 3.14 1.112ZM17.996 13.607c-.15.095-.238.04-.63-.253-.392-.253-1.18-.805-2.91-.379-.78.215-1.376.55-1.711.883-.35.332-.52.634-.634.853-.11.22-.166.36-.229.437a.255.255 0 0 1-.207.094c-.15 0-.36-.06-.288-.69.05-.303.187-.774.631-1.277.441-.514 1.163-.996 2.242-1.278.454-.108.991-.187 1.41-.165.43.023.806.09 1.114.213.624.228.962.575 1.148.818.354.519.199.676.064.744Z" fill="#1C1B1A" />
<path d="M4.422 16.896c.141-.38.909-2.267 1.337-3.354.172-.439.593-.729 1.054-.713 1.086.448.415 2.719-.056 3.798 1.926-.697 5.957-2.16 6.669-2.438a.828.828 0 0 1 .73.038c.378.206.66.703.477 1.091-.362.77-1.83 1.412-2.84 1.707l.3.246a.756.756 0 0 1 .206.24c.3.602-.01 1.35-.461 1.68l.394.241c.985.785.313 1.409-.144 1.873 1.533 1.202.905 1.711-2.349 3.024-3.254 1.313-4.013.136-4.437-.211-.423-.348-1.154-2.22-1.535-3.61-.38-1.391.465-3.104.655-3.612Z" fill="#fff" />
<path d="M4.422 16.896c.141-.38.909-2.267 1.337-3.354.172-.439.593-.729 1.054-.713 1.086.448.415 2.719-.056 3.798 1.926-.697 5.957-2.16 6.669-2.438a.828.828 0 0 1 .73.038c.378.206.66.703.477 1.091-.362.77-1.83 1.412-2.84 1.707l.3.246a.756.756 0 0 1 .206.24c.3.602-.01 1.35-.461 1.68l.394.241c.985.785.313 1.409-.144 1.873 1.533 1.202.905 1.711-2.349 3.024-3.254 1.313-4.013.136-4.437-.211-.423-.348-1.154-2.22-1.535-3.61-.38-1.391.465-3.104.655-3.612Z" fill="url(#thinkingE)" fill-opacity=".5" />
<defs>
<linearGradient id="thinkingB" x1="13.043" y1="7.609" x2="9.239" y2="29.348" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFD52B" stop-opacity="0" />
<stop offset=".562" stop-color="#FF9913" stop-opacity=".562" />
<stop offset=".734" stop-color="#FF870B" stop-opacity=".734" />
<stop offset="1" stop-color="#FF6B00" />
</linearGradient>
<linearGradient id="thinkingE" x1="9.445" y1="17.129" x2="4.846" y2="26.766" gradientUnits="userSpaceOnUse">
<stop stop-color="#fff" />
<stop offset="1" stop-color="#FDBC3C" />
</linearGradient>
<radialGradient id="thinkingA" cx="0" cy="0" r="1" gradientUnits="userSpaceOnUse" gradientTransform="rotate(87.614 -.254 12.21) scale(13.0548 12.5192)">
<stop stop-color="#FFD52B" stop-opacity="0" />
<stop offset="1" stop-color="#FAB124" />
</radialGradient>
</defs>
</symbol>
<symbol viewBox="0 0 24 24" id="emoji-like">
<path d="M11.797 0c-.929 0-1.282.744-1.21 2.185.048.95.367 3.597-.973 4.939C8.364 8.374 8 8.264 6.576 9.878c-1.425 1.614-2.61 1.282-4.272 1.14-2.088-.18-1.376 11.408.095 11.207 1.044-.142 3.417-.427 3.797-.427.38 0 2.984 2.019 5.269 2.043 3.702.039 5.744-.617 5.744-.617l1.085-2.462.363-7.508-1.733-3.613s-2.326.38-2.99-.665c-.665-1.044.522-2.327.522-5.319C14.456.666 12.272 0 11.797 0Z" fill="url(#emoji-like-a)" />
<path d="m17.338 23.201-.141-.514c-.417-.044-.954.146-1.687.14-3.5-.027-6.847-1.033-8.283-2.17-.94-.745-1.353-1.736-2.018-1.451-.82.352-3.145.898-4-.185.239 1.854.665 3.276 1.19 3.205 1.044-.143 3.417-.428 3.797-.428.38 0 2.911 1.965 5.27 2.043 3.05.1 5.76-.426 5.76-.426l.112-.214Z" fill="url(#emoji-like-b)" />
<path d="M3.786 11.75c1.377.38 2.251-.25 2.955-1.104.699-.85 1.305-1.603 3.062-2.743 1.756-1.14 1.53-4.274 1.388-5.32C11.048 1.54 11.143 0 11.797 0c-.929 0-1.282.744-1.21 2.184.048.95.367 3.598-.973 4.94C8.364 8.374 8 8.264 6.576 9.878c-1.424 1.614-2.61 1.282-4.272 1.14 0 .36.106.352 1.482.732Z" fill="url(#emoji-like-c)" />
<path d="M13.933 8.976c-.664-1.045.523-2.327.523-5.32C14.456.666 12.271 0 11.797 0a1.3 1.3 0 0 0-.335.04c1.936.122 3.102 2.565 2.435 5.085-.541 2.044-.811 3.683.073 4.645.572.622 1.71.516 2.954-.13 0 0-2.326.381-2.99-.664Z" fill="url(#emoji-like-d)" />
<path d="M17.362 10.73c-1.685 0-2.611 1.646-1.97 2.912.64 1.266-1.187 2.942-.997 3.766.19.825.522 2.913.783 3.258.26.346-.428 1.129-.428 1.129l2.136.261 1.994-.88-.072-6.03.214-3.775-1.66-.642Z" fill="url(#emoji-like-e)" />
<path d="M6.576 9.878c-.925 1.05-1.75 1.277-2.67 1.268.265.428.45.896.43 1.354-.05 1.2.215 2.678.417 1.14.153-1.171.947-2.62 1.902-3.85l-.08.088Z" fill="url(#emoji-like-f)" />
<path d="M18.638 9.593c-1.992-.076-5.574-.188-5.654 1.9-.057 1.514 1.016 2.011 2.676 2.074l3.178.121c.688.027 2.851.013 2.872-1.815.027-2.285-3.072-2.28-3.072-2.28Z" fill="url(#emoji-like-g)" />
<path d="M15.361 17.143c-.534-.016-2.12.384-2.268 1.392-.117.793.287 1.817 1.668 2.059 1.748.306 4.661.466 5.75.059.486-.182.91-.691.932-1.463.023-.772-.55-1.812-1.796-1.849-1.245-.035-1.894-.016-2.604-.1-.854-.1-1.254-.086-1.682-.098Z" fill="url(#emoji-like-h)" />
<path d="M14.806 20.665c-.606 0-1.354.534-1.354 1.425 0 .89.232 1.55 1.531 1.798 1.3.25 3.382.036 4.165-.213.61-.195.837-.766.837-1.71s-.587-1.108-1.228-1.108-1.419.117-1.863.094c-1.24-.067-1.483-.286-2.088-.286Z" fill="url(#emoji-like-i)" />
<path d="M14.901 9.773c-1.064.232-1.88.735-1.917 1.72-.048 1.259.687 1.814 1.89 2.002-2.44-.974-1.565-3.375.027-3.722Z" fill="url(#emoji-like-j)" />
<path d="M14.916 17.213c-.094-.003-.193 0-.295.01-.457.101-.975.31-1.278.703-.1.145-.18.317-.235.518l-.014.09c-.14.784.248 1.707 1.453 2.013-2.057-1.135-1.18-3.333.37-3.334Z" fill="url(#emoji-like-k)" />
<path d="M14.778 20.666c-.6.015-1.326.546-1.326 1.424 0 .815.195 1.437 1.228 1.727-1.612-1.036-1.095-2.784.098-3.151Z" fill="url(#emoji-like-l)" />
<path d="M21.71 11.873c.003-.205-.02-.391-.064-.56.161.713-.475 1.422-2.16 1.766-1.116.228-4.082.513-6.134-.302.443.535 1.258.75 2.309.79l3.177.12c.688.028 2.851.014 2.872-1.814Z" fill="url(#emoji-like-m)" />
<path d="M21.443 19.14c-.002-.766-.577-1.764-1.796-1.799-1.246-.035-1.895-.016-2.605-.1-.853-.101-1.254-.086-1.68-.098-.323-.01-1.12.088-1.661.425.609.21 1.6.529 2.996.44 3.344-.216 4.296.189 4.746 1.133Z" fill="url(#emoji-like-n)" />
<path d="M14.644 13.688c-.711-.015-1.842.404-1.871 1.883-.03 1.479 1.263 1.83 1.833 1.842.57.011 2.56.147 5.016.196 2.456.05 2.785-1.27 2.8-1.96.013-.691-.425-1.941-1.902-1.971-4.272-.086-5.876.01-5.876.01Z" fill="url(#emoji-like-o)" />
<path d="M14.511 13.69c-.711.038-1.71.492-1.738 1.88-.029 1.406 1.138 1.793 1.743 1.838-2.34-.945-1.573-3.579-.005-3.718Z" fill="url(#emoji-like-p)" />
<path d="M22.417 15.499c-.308 2.187-6.088 1.787-9.211 1.317.421.452 1.048.589 1.4.596.57.012 2.56.148 5.016.197 2.456.048 2.785-1.27 2.8-1.96 0-.048-.001-.098-.005-.15Z" fill="url(#emoji-like-q)" />
<path d="M19.522 20.37c-1.12.05-4.082.418-6.242-.74.241.448.708.828 1.48.964 1.749.306 4.662.466 5.75.059.487-.182.91-.691.933-1.463-.072.67-.71 1.126-1.921 1.18Z" fill="url(#emoji-like-r)" />
<path d="M19.9 22.8c-.734.559-2.002.889-3.832.58-1.13-.192-1.904-.257-2.413-.27.203.368.596.638 1.328.779 1.3.25 3.382.036 4.165-.214.402-.129.637-.421.751-.875Z" fill="url(#emoji-like-s)" />
<path d="M13.693 21.288c1.355-.494 2.02.24 3.47.24 1.506 0 2.224-.61 2.76-.03-.169-.534-.65-.642-1.166-.642-.64 0-1.419.117-1.863.094-1.24-.065-1.483-.285-2.088-.285-.392 0-.843.224-1.113.623Z" fill="url(#emoji-like-t)" />
<path d="M6.196 21.799c-.295-.252-.651-.675-.971-1.085 0 0-1.729.885-3.582.469.214.677.47 1.082.756 1.043 1.044-.142 3.418-.427 3.797-.427Z" fill="url(#emoji-like-u)" />
<path d="M12.905 4.356c-.677.146-1.225-.789-1.535-1.88-.253-.892.091-2.028.756-2.156.664-.128 1.277-.134 1.644 1.757.215 1.114-.204 2.136-.865 2.279Z" fill="url(#emoji-like-v)" />
<path d="M16.924 9.64s-2.326.38-2.99-.664c-.665-1.045.522-2.327.522-5.32C14.456.666 12.272 0 11.797 0c-.929 0-1.282.744-1.21 2.184.047.95.367 3.598-.973 4.94C8.364 8.374 8 8.264 6.576 9.878c-1.425 1.614 8.828.45 10.348-.237Z" fill="url(#emoji-like-w)" />
<path d="M14.778 20.666a1.369 1.369 0 0 0-1.012.45c-.269.28-.39.686-.374 1.067.012.372.069.777.312 1.09.24.314.617.463.976.544-.348-.126-.692-.303-.899-.602-.207-.296-.262-.67-.264-1.035a1.405 1.405 0 0 1 .32-1.001c.232-.275.57-.474.941-.513ZM14.181 17.353c-.252.082-.505.194-.71.377-.214.177-.344.439-.417.7l-.001.004a1.894 1.894 0 0 0-.02.729c.049.24.15.471.293.67.293.4.758.625 1.22.715-.45-.147-.87-.397-1.131-.779-.267-.377-.343-.86-.253-1.313l-.001.004c.07-.249.171-.494.362-.673a2.21 2.21 0 0 1 .658-.434Z" fill="#804B24" />
<path d="M14.511 13.69c-.444.005-.9.157-1.236.472-.34.313-.516.772-.553 1.222-.037.448.037.934.318 1.304.275.374.707.588 1.143.668-.425-.125-.822-.365-1.065-.724-.246-.357-.316-.807-.271-1.237a1.81 1.81 0 0 1 .495-1.165c.303-.307.729-.49 1.169-.54ZM14.9 9.773c-.48.084-.967.23-1.368.538-.41.3-.636.826-.61 1.329.001.495.171 1.029.573 1.351.393.327.896.448 1.378.505-.475-.102-.957-.257-1.315-.577-.363-.317-.518-.804-.512-1.28-.032-.481.171-.95.545-1.255.372-.305.84-.483 1.31-.611ZM13.28 19.63c.142.284.369.528.642.699.276.168.59.265.906.317.627.111 1.259.191 1.893.246.635.041 1.272.059 1.908.043.633-.022 1.283-.058 1.882-.283-.303.1-.62.131-.935.157-.315.03-.632.039-.948.043-.634.002-1.267-.03-1.898-.084a21.202 21.202 0 0 1-1.889-.203c-.614-.084-1.237-.374-1.56-.935Z" fill="#804B24" />
<path d="M13.206 16.817c.227.256.535.437.864.54.333.11.687.093 1.024.116l2.046.102 2.047.059c.676.037 1.39.015 2.023-.255-.65.223-1.342.213-2.02.172l-2.047-.1-2.048-.06c-.342-.015-.683.006-1.008-.091a1.899 1.899 0 0 1-.881-.483ZM20.52 13.677a67.577 67.577 0 0 0-2.938-.082 38.51 38.51 0 0 0-2.94.044h.004c-.507 0-1.022.183-1.379.55-.179.18-.31.403-.388.643-.076.24-.103.49-.106.738.022-.495.19-.991.543-1.333.347-.344.846-.508 1.327-.5h.004c.488-.02.978-.023 1.467-.026l1.468-.02 1.469-.003c.49.005.979-.009 1.469-.01Z" fill="#804B24" />
<defs>
<linearGradient id="emoji-like-a" x1="17" y1="11.723" x2="9.86" y2="12.01" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFCB4B" />
<stop offset="1" stop-color="#FFD748" />
</linearGradient>
<linearGradient id="emoji-like-b" x1="9.8" y1="15.442" x2="9.302" y2="20.802" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFCB4B" />
<stop offset="1" stop-color="#FFD748" />
</linearGradient>
<linearGradient id="emoji-like-c" x1="8.378" y1="7.489" x2="13.757" y2="15.18" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFCB4B" />
<stop offset="1" stop-color="#FFD748" />
</linearGradient>
<linearGradient id="emoji-like-d" x1="4.484" y1="4.425" x2="18.262" y2="5.457" gradientUnits="userSpaceOnUse">
<stop offset=".312" stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#FF8900" />
</linearGradient>
<linearGradient id="emoji-like-e" x1="13.756" y1="16.825" x2="18.685" y2="16.177" gradientUnits="userSpaceOnUse">
<stop stop-color="#643800" stop-opacity="0" />
<stop offset="1" stop-color="#643800" />
</linearGradient>
<linearGradient id="emoji-like-f" x1="5.008" y1="5.943" x2="6.077" y2="23.645" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#FFA754" />
</linearGradient>
<linearGradient id="emoji-like-g" x1="21.373" y1="11.628" x2="14.378" y2="11.628" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#FFD748" />
</linearGradient>
<linearGradient id="emoji-like-h" x1="21.373" y1="19.02" x2="14.374" y2="19.02" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#FFD748" />
</linearGradient>
<linearGradient id="emoji-like-i" x1="21.373" y1="22.333" x2="14.378" y2="22.333" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#FFD748" />
</linearGradient>
<linearGradient id="emoji-like-j" x1="14.917" y1="11.634" x2="12.639" y2="11.634" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#E89043" />
</linearGradient>
<linearGradient id="emoji-like-k" x1="14.9" y1="18.88" x2="13.353" y2="18.88" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#FBA23B" />
</linearGradient>
<linearGradient id="emoji-like-l" x1="15.06" y1="22.242" x2="13.641" y2="22.242" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#FBA23B" />
</linearGradient>
<linearGradient id="emoji-like-m" x1="17.323" y1="11.187" x2="18.226" y2="15.556" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
</linearGradient>
<linearGradient id="emoji-like-n" x1="18.009" y1="19.82" x2="17.024" y2="16.266" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
</linearGradient>
<linearGradient id="emoji-like-o" x1="21.373" y1="15.627" x2="14.378" y2="15.627" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#FFD748" />
</linearGradient>
<linearGradient id="emoji-like-p" x1="14.326" y1="15.55" x2="13.063" y2="15.55" gradientUnits="userSpaceOnUse">
<stop offset=".001" stop-color="#FFBC47" />
<stop offset="1" stop-color="#FBA23B" />
</linearGradient>
<linearGradient id="emoji-like-q" x1="17.655" y1="15.164" x2="18.415" y2="19.996" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
</linearGradient>
<linearGradient id="emoji-like-r" x1="17.128" y1="18.902" x2="19.076" y2="23.128" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
</linearGradient>
<linearGradient id="emoji-like-s" x1="16.74" y1="22.61" x2="17.025" y2="25.281" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
</linearGradient>
<linearGradient id="emoji-like-t" x1="16.807" y1="22.204" x2="16.807" y2="20.272" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
</linearGradient>
<linearGradient id="emoji-like-u" x1="3.966" y1="19.729" x2="3.823" y2="25.179" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
 </linearGradient>
<linearGradient id="emoji-like-w" x1="11.593" y1="10.695" x2="13.423" y2="-5.843" gradientUnits="userSpaceOnUse">
<stop stop-color="#FFBC47" stop-opacity="0" />
<stop offset="1" stop-color="#C86F34" />
</linearGradient>
<radialGradient id="emoji-like-v" cx="0" cy="0" r="1" gradientUnits="userSpaceOnUse" gradientTransform="rotate(79.071 4.88 8.783) scale(2.50958 1.4722)">
<stop stop-color="#FBE07A" />
<stop offset="1" stop-color="#FFD748" stop-opacity="0" />
</radialGradient>
</defs>
</symbol>
<symbol viewBox="0 0 25 24" id="eye">
<path d="M6.21429 20.6428C6.21225 20.7985 6.14951 20.9472 6.03944 21.0573C5.92936 21.1674 5.78066 21.2301 5.625 21.2321C5.31306 21.2342 5.01448 21.359 4.7939 21.5796C4.57332 21.8002 4.44849 22.0988 4.44643 22.4107C4.44643 22.567 4.38434 22.7169 4.27383 22.8274C4.16332 22.9379 4.01343 23 3.85714 23C3.70085 23 3.55097 22.9379 3.44045 22.8274C3.32994 22.7169 3.26786 22.567 3.26786 22.4107C3.26786 22.0981 3.14369 21.7984 2.92266 21.5773C2.70164 21.3563 2.40186 21.2321 2.08929 21.2321C1.933 21.2321 1.78311 21.17 1.6726 21.0595C1.56209 20.949 1.5 20.7991 1.5 20.6428C1.5 20.4866 1.56209 20.3367 1.6726 20.2262C1.78311 20.1156 1.933 20.0536 2.08929 20.0536C2.40186 20.0536 2.70164 19.9294 2.92266 19.7084C3.14369 19.4873 3.26786 19.1876 3.26786 18.875C3.26786 18.7187 3.32994 18.5688 3.44045 18.4583C3.55097 18.3478 3.70085 18.2857 3.85714 18.2857C4.01343 18.2857 4.16332 18.3478 4.27383 18.4583C4.38434 18.5688 4.44643 18.7187 4.44643 18.875C4.44849 19.1869 4.57332 19.4855 4.7939 19.7061C5.01448 19.9267 5.31306 20.0515 5.625 20.0536C5.78066 20.0556 5.92936 20.1183 6.03944 20.2284C6.14951 20.3385 6.21225 20.4872 6.21429 20.6428Z" fill="#627070" />
<path d="M23.5 4.14286C23.5 4.35124 23.4172 4.55109 23.2699 4.69844C23.1225 4.84579 22.9227 4.92857 22.7143 4.92857C22.2975 4.92857 21.8978 5.09413 21.6031 5.38883C21.3084 5.68353 21.1429 6.08323 21.1429 6.5C21.1429 6.70838 21.0601 6.90823 20.9127 7.05558C20.7654 7.20293 20.5655 7.28571 20.3572 7.28571C20.1488 7.28571 19.9489 7.20293 19.8016 7.05558C19.6542 6.90823 19.5714 6.70838 19.5714 6.5C19.5714 6.08323 19.4059 5.68353 19.1112 5.38883C18.8165 5.09413 18.4168 4.92857 18 4.92857C17.7916 4.92857 17.5918 4.84579 17.4444 4.69844C17.2971 4.55109 17.2143 4.35124 17.2143 4.14286C17.2143 3.93447 17.2971 3.73462 17.4444 3.58727C17.5918 3.43992 17.7916 3.35714 18 3.35714C18.4168 3.35714 18.8165 3.19158 19.1112 2.89688C19.4059 2.60218 19.5714 2.20248 19.5714 1.78571C19.5714 1.57733 19.6542 1.37748 19.8016 1.23013C19.9489 1.08278 20.1488 1 20.3572 1C20.5655 1 20.7654 1.08278 20.9127 1.23013C21.0601 1.37748 21.1429 1.57733 21.1429 1.78571C21.1429 2.20248 21.3084 2.60218 21.6031 2.89688C21.8978 3.19158 22.2975 3.35714 22.7143 3.35714C22.9227 3.35714 23.1225 3.43992 23.2699 3.58727C23.4172 3.73462 23.5 3.93447 23.5 4.14286Z" fill="#627070" />
<path d="M21.3784 11.0179C20.3571 9.62151 19.0208 8.48573 17.4782 7.70278C15.9355 6.91983 14.2299 6.51178 12.4999 6.51178C10.7699 6.51178 9.06424 6.91983 7.52155 7.70278C5.97887 8.48573 4.6426 9.62151 3.62128 11.0179C3.32657 11.4157 3.16748 11.8977 3.16748 12.3929C3.16748 12.888 3.32657 13.37 3.62128 13.7679C4.6426 15.1642 5.97887 16.3 7.52155 17.0829C9.06424 17.8659 10.7699 18.2739 12.4999 18.2739C14.2299 18.2739 15.9355 17.8659 17.4782 17.0829C19.0208 16.3 20.3571 15.1642 21.3784 13.7679C21.6743 13.3705 21.8342 12.8883 21.8342 12.3929C21.8342 11.8974 21.6743 11.4152 21.3784 11.0179V11.0179ZM4.87842 12.8486C4.78368 12.7155 4.73277 12.5562 4.73277 12.3929C4.73277 12.2295 4.78368 12.0702 4.87842 11.9371C6.12835 10.2301 7.9161 8.99308 9.95414 8.425C9.28912 8.85167 8.74201 9.43864 8.36308 10.132C7.98415 10.8253 7.78556 11.6027 7.78556 12.3929C7.78556 13.183 7.98415 13.9604 8.36308 14.6538C8.74201 15.3471 9.28912 15.9341 9.95414 16.3607C7.92185 15.7895 6.14006 14.5527 4.89414 12.8486H4.87842ZM20.0977 12.8486C18.8498 14.5542 17.065 15.7911 15.0299 16.3607C15.6949 15.9341 16.242 15.3471 16.6209 14.6538C16.9998 13.9604 17.1984 13.183 17.1984 12.3929C17.1984 11.6027 16.9998 10.8253 16.6209 10.132C16.242 9.43864 15.6949 8.85167 15.0299 8.425C17.065 8.99466 18.8498 10.2315 20.0977 11.9371C20.1948 12.0686 20.2484 12.227 20.2513 12.3904C20.2541 12.5537 20.2059 12.7139 20.1134 12.8486H20.0977Z" fill="#627070" />
</symbol>
<symbol viewBox="0 0 16 16" id="eye-two-variation">
<path d="M1.5 7.727S3.865 3 8 3s6.5 4.727 6.5 4.727-2.364 4.727-6.5 4.727-6.5-4.727-6.5-4.727Z" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round" />
<path d="M8 9.5a1.773 1.773 0 1 0 0-3.546A1.773 1.773 0 0 0 8 9.5Z" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round" />
</symbol>
<symbol viewBox="0 0 21 21" id="wordpress">
<path d="M0.5 10.0014C0.5 13.9581 2.80002 17.3812 6.13654 19.0001L1.36632 5.93059C0.810704 7.17503 0.5 8.55066 0.5 10.0014ZM17.252 9.49617C17.252 8.26026 16.8069 7.40369 16.4271 6.73801C15.9203 5.91353 15.4459 5.21699 15.4459 4.3921C15.4459 3.47257 16.1408 2.61763 17.1253 2.61763C17.168 2.61763 17.211 2.62332 17.2536 2.62616C15.4751 0.996284 13.1048 0 10.5014 0C7.00651 0 3.93318 1.79355 2.14572 4.50826C2.38088 4.51557 2.60101 4.52085 2.78865 4.52085C3.8353 4.52085 5.45421 4.3925 5.45421 4.3925C5.99195 4.36245 6.05571 5.15241 5.51675 5.21739C5.51675 5.21739 4.97576 5.27994 4.37263 5.31243L8.01498 16.1436L10.2037 9.58106L8.64491 5.31243C8.10636 5.27994 7.59624 5.21739 7.59624 5.21739C7.05687 5.1849 7.12104 4.36245 7.66041 4.3925C7.66041 4.3925 9.311 4.52085 10.2931 4.52085C11.3385 4.52085 12.9598 4.3925 12.9598 4.3925C13.4968 4.36245 13.5609 5.15241 13.0216 5.21739C13.0216 5.21739 12.4814 5.27994 11.8779 5.31243L15.4926 16.0612L16.4905 12.7295C16.9974 11.4294 17.252 10.3531 17.252 9.49617ZM10.6765 10.8767L7.67544 19.5963C8.57099 19.8595 9.51732 20.0024 10.501 20.0024C11.6646 20.0024 12.7824 19.801 13.8217 19.4346C13.7949 19.392 13.7701 19.3473 13.7502 19.2982L10.6765 10.8767ZM19.2755 5.20236C19.3197 5.522 19.3445 5.86317 19.3445 6.23195C19.3445 7.24611 19.154 8.38657 18.583 9.81378L15.5287 18.6443C18.5009 16.9116 20.5 13.6913 20.5 10.0018C20.5004 8.26189 20.0561 6.62795 19.2755 5.20236Z" fill="#627070" />
</symbol>
<symbol viewBox="0 0 21 20" id="save">
<path fill-rule="evenodd" clip-rule="evenodd" d="M2.16003 2.73297e-10C1.94119 -3.97056e-06 1.72451 0.0432623 1.52246 0.12731C1.3204 0.211357 1.13696 0.334527 0.982683 0.489733C0.828407 0.644939 0.706341 0.829118 0.623508 1.03167C0.540676 1.23423 0.498712 1.45117 0.50003 1.67V18.33C0.498712 18.5488 0.540676 18.7658 0.623508 18.9683C0.706341 19.1709 0.828407 19.3551 0.982683 19.5103C1.13696 19.6655 1.3204 19.7886 1.52246 19.8727C1.72451 19.9567 1.94119 20 2.16003 20H18.84C19.0589 20 19.2755 19.9567 19.4776 19.8727C19.6797 19.7886 19.8631 19.6655 20.0174 19.5103C20.1717 19.3551 20.2937 19.1709 20.3766 18.9683C20.4594 18.7658 20.5013 18.5488 20.5 18.33V5.72C20.5 5.27423 20.3239 4.84652 20.01 4.53L15.96 0.53C15.8088 0.367179 15.6265 0.236372 15.4238 0.145332C15.2211 0.0542912 15.0022 0.00487083 14.78 2.73297e-10L2.16003 2.73297e-10ZM3.08003 3.43C3.08001 3.20894 3.16714 2.99678 3.32251 2.83954C3.47789 2.68229 3.68899 2.59263 3.91003 2.59H13.72C13.9411 2.59263 14.1522 2.68229 14.3075 2.83954C14.4629 2.99678 14.55 3.20894 14.55 3.43V7.57C14.5514 7.67984 14.5309 7.78884 14.4897 7.8907C14.4486 7.99256 14.3877 8.08524 14.3105 8.16337C14.2333 8.24151 14.1413 8.30354 14.04 8.34588C13.9386 8.38821 13.8299 8.41001 13.72 8.41H3.91003C3.80019 8.41001 3.69143 8.38821 3.59008 8.34588C3.48872 8.30354 3.39677 8.24151 3.31957 8.16337C3.24236 8.08524 3.18143 7.99256 3.14032 7.8907C3.0992 7.78884 3.07871 7.67984 3.08003 7.57V3.43ZM10.5 16.69C11.065 16.694 11.6183 16.5299 12.0899 16.2187C12.5614 15.9076 12.9298 15.4633 13.1483 14.9423C13.3667 14.4213 13.4255 13.8471 13.3169 13.2927C13.2084 12.7382 12.9376 12.2286 12.5388 11.8284C12.14 11.4282 11.6313 11.1556 11.0773 11.0451C10.5232 10.9346 9.94886 10.9913 9.4271 11.208C8.90534 11.4246 8.45974 11.7914 8.14689 12.2618C7.83404 12.7323 7.66806 13.2851 7.67003 13.85C7.67003 14.6015 7.96787 15.3223 8.49831 15.8547C9.02875 16.387 9.74855 16.6874 10.5 16.69Z" fill="#627070" />
</symbol>
<symbol viewBox="0 0 20 20" id="magic">
<path d="M13.6674 5.99498L13.126 5.78433L0.395785 17.6934C-0.131929 18.2211 -0.131929 19.0767 0.395785 19.6044C0.923499 20.1321 1.77909 20.1321 2.30681 19.6044L13.9554 7.15244L13.6674 5.99498ZM19.8771 5.8617L18.6036 4.28886C18.3688 3.99865 18.2869 3.48124 18.4205 3.13276L19.1457 1.24319C19.2793 0.894869 19.1053 0.72071 18.7568 0.854328L16.8669 1.57934C16.5186 1.71296 16.001 1.63103 15.711 1.39623L14.1381 0.122894C13.8481 -0.111909 13.6288 -0.00025107 13.6484 0.372561L13.7538 2.39372C13.7733 2.76636 13.5354 3.23326 13.2224 3.43648L11.5254 4.53904C11.2124 4.74225 11.2509 4.9855 11.6114 5.08212L13.5662 5.60612C13.9267 5.70274 14.2971 6.07336 14.3937 6.43367L14.9177 8.38844C15.0143 8.74892 15.2576 8.78727 15.4608 8.47442L16.5632 6.77743C16.7664 6.46441 17.2333 6.22657 17.606 6.246L19.6273 6.35141C20.0003 6.37117 20.1119 6.15191 19.8771 5.8617ZM3.21781 2.51821C3.59096 2.51821 3.8935 2.21567 3.8935 1.84252C3.8935 1.46937 3.59096 1.16683 3.21781 1.16683C2.84466 1.16683 2.54212 1.46937 2.54212 1.84252C2.54212 2.21567 2.84466 2.51821 3.21781 2.51821ZM10.3126 3.02498C10.6857 3.02498 10.9882 2.72244 10.9882 2.34929C10.9882 1.97614 10.6857 1.6736 10.3126 1.6736C9.9394 1.6736 9.63686 1.97614 9.63686 2.34929C9.63686 2.72244 9.9394 3.02498 10.3126 3.02498ZM6.76518 3.8696C7.13833 3.8696 7.44087 3.56705 7.44087 3.19391C7.44087 2.82076 7.13833 2.51821 6.76518 2.51821C6.39203 2.51821 6.08949 2.82076 6.08949 3.19391C6.08949 3.56705 6.39203 3.8696 6.76518 3.8696ZM3.8935 6.9102C4.6398 6.9102 5.24488 6.30512 5.24488 5.55882C5.24488 4.81252 4.6398 4.20744 3.8935 4.20744C3.1472 4.20744 2.54212 4.81252 2.54212 5.55882C2.54212 6.30512 3.1472 6.9102 3.8935 6.9102ZM6.76518 7.75481C6.76518 8.12796 7.06772 8.4305 7.44087 8.4305C7.81402 8.4305 8.11656 8.12796 8.11656 7.75481C8.11656 7.38166 7.81402 7.07912 7.44087 7.07912C7.06772 7.07912 6.76518 7.38166 6.76518 7.75481ZM3.21781 9.95081C3.21781 10.324 3.52035 10.6265 3.8935 10.6265C4.26665 10.6265 4.56919 10.324 4.56919 9.95081C4.56919 9.57766 4.26665 9.27512 3.8935 9.27512C3.52035 9.27512 3.21781 9.57766 3.21781 9.95081ZM12.0018 10.7954C11.6286 10.7954 11.3261 11.098 11.3261 11.4711C11.3261 11.8443 11.6286 12.1468 12.0018 12.1468C12.3749 12.1468 12.6775 11.8443 12.6775 11.4711C12.6775 11.098 12.3749 10.7954 12.0018 10.7954ZM10.9531 14.5499C10.58 14.5499 10.2774 14.8524 10.2774 15.2256C10.2774 15.5987 10.58 15.9013 10.9531 15.9013C11.3263 15.9013 11.6288 15.5987 11.6288 15.2256C11.6288 14.8524 11.3263 14.5499 10.9531 14.5499ZM14.6387 12.8884C13.8924 12.8884 13.2873 13.4935 13.2873 14.2397C13.2873 14.986 13.8924 15.5911 14.6387 15.5911C15.385 15.5911 15.99 14.986 15.99 14.2397C15.99 13.4935 15.385 12.8884 14.6387 12.8884ZM17.4073 11.0723C17.0341 11.0723 16.7316 11.3748 16.7316 11.748C16.7316 12.1211 17.0341 12.4237 17.4073 12.4237C17.7804 12.4237 18.083 12.1211 18.083 11.748C18.083 11.3748 17.7804 11.0723 17.4073 11.0723Z" fill="#485656" />
</symbol>

<symbol viewBox="0 0 25 24" id="facebook-colorless">
<path d="m18.765 13.398.659-4.31h-4.12V6.29c0-1.18.576-2.329 2.421-2.329h1.873V.291S17.898 0 16.273 0c-3.392 0-5.61 2.064-5.61 5.802v3.285h-3.77v4.311h3.77v10.42a14.896 14.896 0 0 0 4.642 0v-10.42h3.46Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="rss-colorless">
<path d="M1.85 12.663a9.72 9.72 0 0 1 6.94 2.887 9.833 9.833 0 0 1 2.878 6.987h4.04c0-7.673-6.217-13.915-13.858-13.915v4.041Zm.006-7.164c9.346 0 16.95 7.645 16.95 17.043h4.04c0-11.627-9.416-21.084-20.99-21.084V5.5Zm5.588 14.22a2.8 2.8 0 1 1-5.598-.001 2.8 2.8 0 0 1 5.598 0Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="telegram-colorless">
<path d="M22.495 2.177s2.22-.866 2.035 1.236c-.062.866-.617 3.896-1.048 7.173l-1.48 9.709s-.124 1.422-1.234 1.67c-1.11.247-2.775-.866-3.084-1.114-.246-.185-4.625-2.968-6.167-4.328-.431-.371-.925-1.113.062-1.98l6.476-6.183c.74-.742 1.48-2.473-1.604-.37l-8.634 5.874s-.987.618-2.837.062L.972 12.689s-1.48-.928 1.048-1.855c6.167-2.907 13.753-5.875 20.475-8.657Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="twitter-colorless">
<path d="M23.4 4.813c-.32.24-.64.439-.999.638.04.32.04.679.04 1.038 0 4.63-1.996 8.82-5.151 11.734-2.476 1.836-5.55 2.913-8.905 2.913-2.915 0-5.63-.838-7.947-2.275.48.08.958.12 1.478.12a9.856 9.856 0 0 0 6.11-2.115c-2.157-.04-3.994-1.477-4.633-3.472.28.04.6.08.919.08.439 0 .838-.04 1.237-.16-.918-.2-1.717-.679-2.356-1.317-.918-.878-1.477-2.156-1.477-3.513v-.08c.599.32 1.238.52 1.957.6-.72-.56-1.318-1.318-1.638-2.196a5.254 5.254 0 0 1-.32-1.756c0-.24 0-.519.04-.758.12-.679.36-1.317.68-1.836.36.399.758.798 1.198 1.197.2.2.439.36.639.559a16.31 16.31 0 0 0 4.113 2.395c.2.08.36.16.559.2.679.239 1.357.438 2.076.558.16.04.32.08.48.08.08 0 .12.04.2.04.319.04.598.08.918.12-.08-.36-.16-.759-.16-1.198a4.88 4.88 0 0 1 2.116-4.03c.08-.08.16-.12.28-.16 0 0 .04 0 .04.04v-.04c.759-.44 1.597-.719 2.556-.719 1.437 0 2.715.599 3.634 1.596.319-.08.678-.16.998-.239.36-.12.679-.2.998-.36.4-.159.759-.358 1.118-.558-.2.599-.519 1.157-.918 1.636-.28.32-.6.6-.919.878-.08.04-.16.12-.24.16h-.079v.04l.04-.04c.08 0 .16-.04.28-.04.359-.04.678-.12 1.038-.2.36-.08.719-.199 1.038-.319-.36.24-.719.48-1.038.759Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="vk-colorless">
<path d="M13.19 19.5C4.992 19.5.315 13.87.12 4.5h4.107c.134 6.877 3.163 9.79 5.561 10.39V4.5h3.868v5.93c2.368-.254 4.856-2.957 5.696-5.93h3.868c-.645 3.664-3.343 6.366-5.262 7.477 1.919.901 4.992 3.259 6.161 7.523h-4.257c-.915-2.853-3.193-5.06-6.206-5.36v5.36h-.465Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="yandex-zen-colorless">
<path d="M24.665 12.129v-.258c-5.314-.171-7.74-.3-9.686-2.185C13.094 7.74 12.957 5.314 12.794 0h-.258c-.171 5.314-.3 7.74-2.185 9.686C8.405 11.57 5.979 11.709.665 11.87v.258c5.314.171 7.74.3 9.686 2.185 1.885 1.946 2.023 4.372 2.185 9.686h.258c.171-5.314.3-7.74 2.185-9.686 1.946-1.885 4.372-2.023 9.686-2.185Z" />
</symbol>

<symbol viewBox="0 0 17 17" id="angle-double-up">
<path d="M9.003 8.882a.708.708 0 0 0-1.006 0l-2.125 2.126a.721.721 0 0 0 1.006 1.034L8.5 10.384l1.622 1.658a.71.71 0 0 0 1.215-.503.71.71 0 0 0-.21-.503L9.004 8.882Zm-2.125-.765L8.5 6.488l1.622 1.63a.708.708 0 0 0 1.006 0 .709.709 0 0 0 0-1.006L9.003 4.987a.708.708 0 0 0-1.006 0L5.872 7.112a.711.711 0 0 0 1.006 1.005Z" />
</symbol>

<symbol viewBox="0 0 25 24" id="facebook-colorless">
<path d="m18.765 13.398.659-4.31h-4.12V6.29c0-1.18.576-2.329 2.421-2.329h1.873V.291S17.898 0 16.273 0c-3.392 0-5.61 2.064-5.61 5.802v3.285h-3.77v4.311h3.77v10.42a14.896 14.896 0 0 0 4.642 0v-10.42h3.46Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="rss-colorless">
<path d="M1.85 12.663a9.72 9.72 0 0 1 6.94 2.887 9.833 9.833 0 0 1 2.878 6.987h4.04c0-7.673-6.217-13.915-13.858-13.915v4.041Zm.006-7.164c9.346 0 16.95 7.645 16.95 17.043h4.04c0-11.627-9.416-21.084-20.99-21.084V5.5Zm5.588 14.22a2.8 2.8 0 1 1-5.598-.001 2.8 2.8 0 0 1 5.598 0Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="telegram-colorless">
<path d="M22.495 2.177s2.22-.866 2.035 1.236c-.062.866-.617 3.896-1.048 7.173l-1.48 9.709s-.124 1.422-1.234 1.67c-1.11.247-2.775-.866-3.084-1.114-.246-.185-4.625-2.968-6.167-4.328-.431-.371-.925-1.113.062-1.98l6.476-6.183c.74-.742 1.48-2.473-1.604-.37l-8.634 5.874s-.987.618-2.837.062L.972 12.689s-1.48-.928 1.048-1.855c6.167-2.907 13.753-5.875 20.475-8.657Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="twitter-colorless">
<path d="M23.4 4.813c-.32.24-.64.439-.999.638.04.32.04.679.04 1.038 0 4.63-1.996 8.82-5.151 11.734-2.476 1.836-5.55 2.913-8.905 2.913-2.915 0-5.63-.838-7.947-2.275.48.08.958.12 1.478.12a9.856 9.856 0 0 0 6.11-2.115c-2.157-.04-3.994-1.477-4.633-3.472.28.04.6.08.919.08.439 0 .838-.04 1.237-.16-.918-.2-1.717-.679-2.356-1.317-.918-.878-1.477-2.156-1.477-3.513v-.08c.599.32 1.238.52 1.957.6-.72-.56-1.318-1.318-1.638-2.196a5.254 5.254 0 0 1-.32-1.756c0-.24 0-.519.04-.758.12-.679.36-1.317.68-1.836.36.399.758.798 1.198 1.197.2.2.439.36.639.559a16.31 16.31 0 0 0 4.113 2.395c.2.08.36.16.559.2.679.239 1.357.438 2.076.558.16.04.32.08.48.08.08 0 .12.04.2.04.319.04.598.08.918.12-.08-.36-.16-.759-.16-1.198a4.88 4.88 0 0 1 2.116-4.03c.08-.08.16-.12.28-.16 0 0 .04 0 .04.04v-.04c.759-.44 1.597-.719 2.556-.719 1.437 0 2.715.599 3.634 1.596.319-.08.678-.16.998-.239.36-.12.679-.2.998-.36.4-.159.759-.358 1.118-.558-.2.599-.519 1.157-.918 1.636-.28.32-.6.6-.919.878-.08.04-.16.12-.24.16h-.079v.04l.04-.04c.08 0 .16-.04.28-.04.359-.04.678-.12 1.038-.2.36-.08.719-.199 1.038-.319-.36.24-.719.48-1.038.759Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="vk-colorless">
<path d="M13.19 19.5C4.992 19.5.315 13.87.12 4.5h4.107c.134 6.877 3.163 9.79 5.561 10.39V4.5h3.868v5.93c2.368-.254 4.856-2.957 5.696-5.93h3.868c-.645 3.664-3.343 6.366-5.262 7.477 1.919.901 4.992 3.259 6.161 7.523h-4.257c-.915-2.853-3.193-5.06-6.206-5.36v5.36h-.465Z" />
</symbol>
<symbol viewBox="0 0 25 24" id="yandex-zen-colorless">
<path d="M24.665 12.129v-.258c-5.314-.171-7.74-.3-9.686-2.185C13.094 7.74 12.957 5.314 12.794 0h-.258c-.171 5.314-.3 7.74-2.185 9.686C8.405 11.57 5.979 11.709.665 11.87v.258c5.314.171 7.74.3 9.686 2.185 1.885 1.946 2.023 4.372 2.185 9.686h.258c.171-5.314.3-7.74 2.185-9.686 1.946-1.885 4.372-2.023 9.686-2.185Z" />
</symbol>
</defs>
</svg>
</div>
<meta itemprop="description" content="В команду КРОК открыт набор на вакансию DevOps инженер." />
<meta itemprop="wordCount" content="186" />
<meta itemprop="dateModified" content="2022-02-11T19:05:37+03:00" />
<span itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="image" content="https://cdn.tproger.ru/android-chrome-32x32.png">
<meta itemprop="width" content="32">
<meta itemprop="height" content="32">
<link itemprop="url" href="https://cdn.tproger.ru/android-chrome-32x32.png">
</span>
<meta itemprop="name" content="Tproger">
<meta itemprop="url" content="https://tproger.ru">
<meta itemprop="address" content="Москва, Деловой Центр «Калибр»">
<meta itemprop="telephone" content="+7 916 559-71-10">
</span>
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://tproger.ru/jobs/devops-inzhener-2/" content="DevOps Инженер" />
<div class="wrapper">
<div class="wrapper__center-section wrapper__center-section--single">
<aside id="asideMenu" class="aside-left mobile-show-on-idle">
<div class="aside-left__wrapper">
<div class="aside-left__header">
<div class="aside-left__header-wrapper">
<div class="aside-left__container-humburger-button">
<button id="buttonHideAsideMenu" class="hamburger-button" aria-label="Кнопка закрытия меню">
<svg class="hamburger-button__icon">
<use xlink:href="#hamburger-open"></use>
</svg>
</button>
</div>
<div class="aside-left__container-logo">
<div class="logo-tproger logo-tproger--full">
<a class="logo-tproger__link" href="/">
<div class="logo-tproger__container-image">
<svg class="logo-tproger__image">
<use xlink:href="#logo"></use>
</svg>
</div>
<div class="logo-tproger__container-text">
<span class="logo-tproger__text">Tproger</span>
</div>
</a>
</div>
</div>
</div>
</div>
<div class="aside-left__main">
<div class="menu-category">
<nav class="menu-category__navigation">
<ul class="menu-category__list">
<li class="menu-category__item">
 <a class="menu-category__button" href="/company/">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#company"></use>
</svg>
<span class="menu-category__text ">Компании</span>
</a>
</li>
<li class="menu-category__item">
<a class="menu-category__button" href="/editor/?utm_source=sidebar">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#pen"></use>
</svg>
<span class="menu-category__text ">Написать пост</span>
</a>
</li>
<li class="menu-category__item">
<a class="menu-category__button" href="/jobs/?utm_source=tproger_ru_main_menu">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#job"></use>
</svg>
<span class="menu-category__text ">Вакансии</span>
</a>
</li>
<li class="menu-category__item">
<a class="menu-category__button" href="/events/">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#clock"></use>
</svg>
<span class="menu-category__text ">События и курсы</span>
</a>
</li>
<li class="menu-category__item">
<a class="menu-category__button" href="/category/interactive/">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#game"></use>
</svg>
<span class="menu-category__text ">Игры</span>
</a>
</li>
<li class="menu-category__item">
<button class="menu-category__button">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#topic"></use>
</svg>
<span class="menu-category__text  menu-category__text--more ">Рубрики</span>
</button>
<div class="menu-category__popup-subcategory popup-subcategories">
<ul class="popup-subcategories__list">
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/curriculum/">
<span class="popup-subcategories__text">Планы обучения</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/problems/">
<span class="popup-subcategories__text">Задачки</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/quiz/">
<span class="popup-subcategories__text">Тесты и викторины</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/books/">
<span class="popup-subcategories__text">Книги</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/video/">
<span class="popup-subcategories__text">Видео</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/explain/">
<span class="popup-subcategories__text">Коротко о главном</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/experts/">
<span class="popup-subcategories__text">Ответы экспертов</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/articles/">
 <span class="popup-subcategories__text">Статьи</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/translations/">
<span class="popup-subcategories__text">Переводы</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/digest/">
<span class="popup-subcategories__text">Подборки</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/devnull/">
<span class="popup-subcategories__text">Юмор</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="https://tproger.ru/interview/">
<span class="popup-subcategories__text">Интервью</span>
</a>
</li>
</ul>
</div>
</li>
<li class="menu-category__item">
<button class="menu-category__button">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#book"></use>
</svg>
<span class="menu-category__text  menu-category__text--more ">Темы</span>
</button>
<div class="menu-category__popup-subcategory popup-subcategories">
<ul class="popup-subcategories__list">
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/for-beginners/">
<span class="popup-subcategories__text">Для начинающих</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/algorithms/">
<span class="popup-subcategories__text">Алгоритмы</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/design-patterns/">
<span class="popup-subcategories__text">Паттерны проектирования</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/software-development/">
<span class="popup-subcategories__text">Методологии разработки</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/web/">
<span class="popup-subcategories__text">Веб-разработка</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/gamedev/">
<span class="popup-subcategories__text">Разработка игр</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/mobiledev/">
<span class="popup-subcategories__text">Мобильная разработка</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/machine-learning/">
<span class="popup-subcategories__text">Машинное обучение</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/neural-network/">
<span class="popup-subcategories__text">Нейронные сети</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/ai/">
<span class="popup-subcategories__text">Искусственный интеллект</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/data-science/">
<span class="popup-subcategories__text">Data Science</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/interface-design-ux/">
<span class="popup-subcategories__text">Дизайн интерфейсов и UX</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/sysadm/">
<span class="popup-subcategories__text">Системное администрирование</span>
</a>
</li>
<li class="popup-subcategories__item">
<button id="buttonShowPopupMoreCategories" class="popup-subcategories__button">
<span class="popup-subcategories__text">Ещё...</span>
</button>
</li>
</ul>
</div>
</li>
<li class="menu-category__item">
<button class="menu-category__button">
<svg class="menu-category__icon menu-category__icon--fill">
<use xlink:href="#cmd"></use>
</svg>
<span class="menu-category__text  menu-category__text--more ">Языки</span>
</button>
<div class="menu-category__popup-subcategory popup-subcategories">
<ul class="popup-subcategories__list">
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/python/">
<span class="popup-subcategories__text">Python</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/javascript/">
<span class="popup-subcategories__text">JavaScript</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/go/">
<span class="popup-subcategories__text">Golang</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/java/">
<span class="popup-subcategories__text">Java</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/cpp/">
<span class="popup-subcategories__text">C++</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/c-sharp/">
<span class="popup-subcategories__text">C#</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/php/">
<span class="popup-subcategories__text">PHP</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/css/">
<span class="popup-subcategories__text">CSS</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/sql/">
<span class="popup-subcategories__text">SQL</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/swift/">
<span class="popup-subcategories__text">Swift</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/c-language/">
<span class="popup-subcategories__text">Язык Си</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/asm/">
<span class="popup-subcategories__text">Язык ассемблера</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/r-language/">
<span class="popup-subcategories__text">Язык R</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/objective-c/">
<span class="popup-subcategories__text">Оbjective-С</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/perl/">
<span class="popup-subcategories__text">Perl</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/dot-net/">
<span class="popup-subcategories__text">.NET</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/django/">
<span class="popup-subcategories__text">Django</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/docker/">
<span class="popup-subcategories__text">Docker</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/mysql/">
<span class="popup-subcategories__text">MySQL</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/node-js/">
<span class="popup-subcategories__text">Node.js</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/react/">
<span class="popup-subcategories__text">React</span>
</a>
</li>
<li class="popup-subcategories__item">
<a class="popup-subcategories__button" href="/tag/webassembly/">
<span class="popup-subcategories__text">WebAssembly</span>
</a>
</li>
</ul>
</div>
</li>
</ul>
</nav>
</div>
</div>
<div class="aside-left__footer">
<div class="aside-left__footer-item">
<div class="aside-left__footer-navigation footer-navigation">
<ul class="footer-navigation__list">
<li class="footer-navigation__item">
<button id="buttonOpenDropdownFooterNavigation" data-dropdown-id="dropdownFooterNavigation" class="footer-navigation__button">
<span class="footer-navigation__text">Правила сайта</span>
<svg class="footer-navigation__icon footer-navigation__icon--stroke">
<use xlink:href="#arrow-down"></use>
</svg>
</button>
<div id="dropdownFooterNavigation" class="footer-navigation__dropdown">
<ul class="footer-navigation__list footer-navigation__list--column">
<li class="footer-navigation__item">
<a class="footer-navigation__button" href="/editorial-policy">
<span class="footer-navigation__text">Редполитика</span>
</a>
</li>
 <li class="footer-navigation__item">
<a class="footer-navigation__button" href="/terms.pdf">
<span class="footer-navigation__text">Пользовательское соглашение</span>
</a>
</li>
<li class="footer-navigation__item">
<a class="footer-navigation__button" href="/privacy.pdf">
<span class="footer-navigation__text">Политика конфиденциальности</span>
</a>
</li>
</ul>
</div>
</li>
</ul>
</div>
</div>
<div class="aside-left__footer-item">
<div class="aside-left__footer-navigation footer-navigation">
<ul class="footer-navigation__list">
<li class="footer-navigation__item">
<a class="footer-navigation__button" href="/ad/?utm_referrer=footer">
<span class="footer-navigation__text">Реклама</span>
</a>
<li class="footer-navigation__item">
<a class="footer-navigation__button" href="/company/tproger/#about">
<span class="footer-navigation__text">О нас</span>
</a>
</li>
</li>
</ul>
</div>
</div>
<div class="aside-left__footer-item">
<div class="aside-left__footer-navigation footer-navigation">
<ul class="footer-navigation__list">
<li class="footer-navigation__item">
<button id="buttonOpenDropdownSocialNetworkFooterNavigation" data-dropdown-id="dropdownSocialNetworkFooterNavigation" class="footer-navigation__button">
<span class="footer-navigation__text">Мы в соцсетях</span>
<svg class="footer-navigation__icon footer-navigation__icon--stroke">
<use xlink:href="#arrow-down"></use>
</svg>
</button>
<div id="dropdownSocialNetworkFooterNavigation" class="footer-navigation__dropdown">
<div class="footer-navigation__social-network-block social-network-block">
<div class="social-network-block__header">
<ul class="social-network-block__list-header">
<li class="social-network-block__item-list-header">
<a class="social-network-block__link-header" href="https://vk.com/tproger" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill">
<use xlink:href="#vk-colorless"></use>
</svg>
</a>
</li>
<li class="social-network-block__item-list-header">
<a class="social-network-block__link-header" href="https://t.me/joinchat/Ga8K4pMCLUo3ZDhi" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill">
<use xlink:href="#telegram-colorless"></use>
</svg>
</a>
</li>
<li class="social-network-block__item-list-header">
<a class="social-network-block__link-header" href="https://www.facebook.com/tproger/" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill">
<use xlink:href="#facebook-colorless"></use>
</svg>
</a>
</li>
<li class="social-network-block__item-list-header">
<a class="social-network-block__link-header" href="https://zen.yandex.ru/tproger" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill">
<use xlink:href="#yandex-zen-colorless"></use>
</svg>
</a>
</li>
<li class="social-network-block__item-list-header">
<a class="social-network-block__link-header" href="https://twitter.com/tproger" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill">
<use xlink:href="#twitter-colorless"></use>
</svg>
</a>
</li>
<li class="social-network-block__item-list-header">
<a class="social-network-block__link-header" href="/feed/" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill">
<use xlink:href="#rss-colorless"></use>
</svg>
</a>
</li>
</ul>
</div>
<div class="social-network-block__content">
<ul class="social-network-block__list-content">
<li class="social-network-block__item-list-content">
<a class="social-network-block__link-content" href="https://vk.com/tproger_web" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill social-network-block__icon--small">
<use xlink:href="#vk-colorless"></use>
</svg>
Веб-разработка
</a>
</li>
<li class="social-network-block__item-list-content">
<a class="social-network-block__link-content" href="https://t.me/joinchat/DY1TVpjJmvBlOGUy" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill social-network-block__icon--small">
<use xlink:href="#telegram-colorless"></use>
</svg>
Soft Skills
</a>
</li>
<li class="social-network-block__item-list-content">
<a class="social-network-block__link-content" href="https://t.me/joinchat/6BcZUcm1n7szNTBi" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill social-network-block__icon--small">
<use xlink:href="#telegram-colorless"></use>
</svg>
Python–разработка
</a>
</li>
<li class="social-network-block__item-list-content">
<a class="social-network-block__link-content" href="https://t.me/joinchat/F9DE01yR01hjYmMy" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill social-network-block__icon--small">
<use xlink:href="#telegram-colorless"></use>
</svg>
IT Юмор
</a>
</li>
<li class="social-network-block__item-list-content">
<a class="social-network-block__link-content" href="https://t.me/joinchat/T0cuJFoZNgBhMjJi" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill social-network-block__icon--small">
<use xlink:href="#telegram-colorless"></use>
</svg>
GameDev
</a>
</li>
<li class="social-network-block__item-list-content">
<a class="social-network-block__link-content" href="https://vk.com/tnull" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill social-network-block__icon--small">
<use xlink:href="#vk-colorless"></use>
</svg>
/dev/null
</a>
<li class="social-network-block__item-list-content">
<a class="social-network-block__link-content" href="https://t.me/joinchat/BqFSp5CPwFdhNjI6" target="_blank">
<svg class="social-network-block__icon social-network-block__icon--fill social-network-block__icon--small">
<use xlink:href="#telegram-colorless"></use>
</svg>
Новости
</a>
</li>
</ul>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
<div class="aside-left__footer-item">
<div class="aside-left__collaboration-message collaboration-message">
<span class="collaboration-message__text">Сотрудничество:</span>
<a class="collaboration-message__link" href="tel:+79165597110">+7 916 559-71-10</a>
<a class="collaboration-message__link" href="mailto:sales@tproger.ru">sales@tproger.ru</a>
</div>
</div>
<div class="aside-left__footer-item aside-left__footer-item--ctrl">
<span class="aside-left__info-message">Нашли опечатку? Выделите фрагмент и отправьте нажатием Ctrl+Enter.</span>
</div>
<button id="errors-popup-opener" class="aside-left__button-bugs-report button-bugs-report footer-navigation__button">
<svg class="button-bugs-report__icon">
<use xlink:href="#bug"></use>
</svg>
<span class="button-bugs-report__text">Нашли баг на сайте?</span>
</button>
<div class="aside-left__container-switch-theme">
<div class="tp-switch-theme">
<div class="tp-switch-theme__track">
<fieldset class="tp-switch-theme__fieldset">
<legend class="tp-switch-theme__legend">Цветовая схема</legend>
<div class="tp-switch-theme__container-radio">
<input class="tp-switch-theme__radio tp-switch-theme__icon--light" type="radio" name="color-theme" value="light" aria-label="Светлая">
<input class="tp-switch-theme__radio tp-switch-theme__icon--auto" checked type="radio" name="color-theme" value="auto" aria-label="Как в системе">
<input class="tp-switch-theme__radio tp-switch-theme__icon--dark" type="radio" name="color-theme" value="dark" aria-label="Тёмная">
</div>
<div class="tp-switch-theme__container-icons">
<svg class="tp-switch-theme__icon tp-switch-theme__icon--sun">
<use xlink:href="#sun"></use>
</svg>
<svg class="tp-switch-theme__icon tp-switch-theme__icon--letter-a">
<use xlink:href="#letter-a"></use>
</svg>
<svg class="tp-switch-theme__icon tp-switch-theme__icon--moon">
<use xlink:href="#moon"></use>
</svg>
</div>
<div class="tp-switch-theme__container-drop">
<div class="tp-switch-theme__drop"></div>
</div>
</fieldset>
</div>
</div>
</div>
<div class="aside-left__footer-item">
<div class="aside-left__collaboration-message collaboration-message">
 <a class="footer-navigation__button" href="https://tprg.ru/regru-footer">
<span class="footer-navigation__text">Используем серверы</span>
<svg class="footer-navigation__icon footer-navigation__icon--fill footer-navigation__icon--regru">
<use xlink:href="#logo-regru"></use>
</svg>
</a>
</div>
</div>
</div>
</div>
<div id="substrateAsideMenu" class="aside-left__substrate"></div>
</aside>
<div id="popupMoreCategories" class="menu-category__popup-more-categories popup-more-categories">
<div class="popup-more-categories__header">
<div class="popup-more-categories__container-title">
<h2 class="popup-more-categories__title">Все темы</h2>
</div>
<div class="popup-more-categories__container-control">
<button id="buttonHidePopupMoreCategories" class="popup-more-categories__close-button">
<svg class="popup-more-categories__close-button-icon popup-more-categories__close-button-icon--stroke">
<use xlink:href="#cancel"></use>
</svg>
</button>
</div>
</div>
<div class="popup-more-categories__main">
<div class="popup-more-categories__block">
<div class="popup-more-categories__container-subtitle">
<h3 class="popup-more-categories__subtitle">По брендам</h3>
</div>
<ul class="popup-more-categories__list">
<li class="popup-more-categories__item">
<a href="/tag/adobe" class="popup-more-categories__link">Adobe</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/amazon" class="popup-more-categories__link">Amazon</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/apple" class="popup-more-categories__link">Apple</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/cloudflare" class="popup-more-categories__link">Cloudflare</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/facebook" class="popup-more-categories__link">Facebook</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/github" class="popup-more-categories__link">GitHub</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/gitlab" class="popup-more-categories__link">GitLab</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/google" class="popup-more-categories__link">Google</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ibm" class="popup-more-categories__link">IBM</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/intel" class="popup-more-categories__link">Intel</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/jetbrains" class="popup-more-categories__link">JetBrains</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/microsoft" class="popup-more-categories__link">Microsoft</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/mit" class="popup-more-categories__link">MIT</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/mozilla" class="popup-more-categories__link">Mozilla</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/nvidia" class="popup-more-categories__link">NVIDIA</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/oracle" class="popup-more-categories__link">Oracle</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/samsung" class="popup-more-categories__link">Samsung</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/stack-overflow" class="popup-more-categories__link">Stack Overflow</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/telegram" class="popup-more-categories__link">Telegram</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/windows" class="popup-more-categories__link">Windows</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/vkontakte" class="popup-more-categories__link">ВКонтакте</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/rkn" class="popup-more-categories__link">Роскомнадзор</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/yandex" class="popup-more-categories__link">Яндекс</a>
</li>
</ul>
</div>
<div class="popup-more-categories__block">
<div class="popup-more-categories__container-subtitle">
 <h3 class="popup-more-categories__subtitle">По направлениям</h3>
</div>
<ul class="popup-more-categories__list">
<li class="popup-more-categories__item">
<a href="/tag/big-data" class="popup-more-categories__link">Big Data</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/data-science" class="popup-more-categories__link">Data Science</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/devops" class="popup-more-categories__link">DevOps</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/hardware" class="popup-more-categories__link">Hardware</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/hr" class="popup-more-categories__link">HR</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/bots" class="popup-more-categories__link">Боты</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/blockchain" class="popup-more-categories__link">Блокчейн</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/veb-design" class="popup-more-categories__link">Веб-дизайн</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/web" class="popup-more-categories__link">Веб-разработка</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/virtual-reality" class="popup-more-categories__link">Виртуальная реальность</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/interface-design-ux" class="popup-more-categories__link">Дизайн интерфейсов и UX</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/augmented-reality" class="popup-more-categories__link">Дополненная реальность</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/iot" class="popup-more-categories__link">Интернет вещей</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ai" class="popup-more-categories__link">Искусственный интеллект</a>
 </li>
<li class="popup-more-categories__item">
<a href="/tag/quantum-computing" class="popup-more-categories__link">Квантовые вычисления</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/computer-graphics" class="popup-more-categories__link">Компьютерная графика</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/computer-vision" class="popup-more-categories__link">Компьютерное зрение</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/cryptocurrency" class="popup-more-categories__link">Криптовалюты</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/crypto" class="popup-more-categories__link">Криптография</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/machine-learning" class="popup-more-categories__link">Машинное обучение</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/mobiledev" class="popup-more-categories__link">Мобильная разработка</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/neural-network" class="popup-more-categories__link">Нейронные сети</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/cloud" class="popup-more-categories__link">Облачные технологии</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/gamedev" class="popup-more-categories__link">Разработка игр</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/robots" class="popup-more-categories__link">Роботы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/sysadm" class="popup-more-categories__link">Системное администрирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/testing" class="popup-more-categories__link">Тестирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/project-management" class="popup-more-categories__link">Управление проектами</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/frontend" class="popup-more-categories__link">Фронтенд</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/math-and-probability" class="popup-more-categories__link">Математика и теория вероятностей</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/fintech" class="popup-more-categories__link">Финтех</a>
</li>
</ul>
</div>
<div class="popup-more-categories__block">
<div class="popup-more-categories__container-subtitle">
<h3 class="popup-more-categories__subtitle">По языкам и технологиям</h3>
</div>
<ul class="popup-more-categories__list">
<li class="popup-more-categories__item">
<a href="/tag/cpp" class="popup-more-categories__link">C++</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/c-sharp" class="popup-more-categories__link">C#</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/java" class="popup-more-categories__link">Java</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/javascript" class="popup-more-categories__link">JavaScript</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/css" class="popup-more-categories__link">CSS</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/html" class="popup-more-categories__link">HTML</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/golang" class="popup-more-categories__link">Golang</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/kotlin" class="popup-more-categories__link">Kotlin</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/php" class="popup-more-categories__link">PHP</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/python" class="popup-more-categories__link">Python</a>
</li>
<li class="popup-more-categories__item">
 <a href="/tag/ruby" class="popup-more-categories__link">Ruby</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ruby-on-rails" class="popup-more-categories__link">Ruby on Rails</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/rust" class="popup-more-categories__link">Rust</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/scala" class="popup-more-categories__link">Scala</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/sql" class="popup-more-categories__link">SQL</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/swift" class="popup-more-categories__link">Swift</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/typescript" class="popup-more-categories__link">TypeScript</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/c-language" class="popup-more-categories__link">Язык Си</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/asm" class="popup-more-categories__link">Язык ассемблера</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/r-language" class="popup-more-categories__link">Язык R</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/lua" class="popup-more-categories__link">Lua</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/objective-c" class="popup-more-categories__link">Objective-C</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/perl" class="popup-more-categories__link">Perl</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/dot-net" class="popup-more-categories__link">.NET</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/django" class="popup-more-categories__link">Django</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/docker" class="popup-more-categories__link">Docker</a>
</li>
 <li class="popup-more-categories__item">
<a href="/tag/mysql" class="popup-more-categories__link">MySQL</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/node-js" class="popup-more-categories__link">Node.js</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/react" class="popup-more-categories__link">React</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/webassembly" class="popup-more-categories__link">WebAssembly</a>
</li>
</ul>
</div>
<div class="popup-more-categories__block">
<ul class="popup-more-categories__list">
<li class="popup-more-categories__item">
<a href="/tag/1c-bitrix" class="popup-more-categories__link">1C-Bitrix</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/3d-printer" class="popup-more-categories__link">3D-принтер</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/3d-tehnologii" class="popup-more-categories__link">3D-технологии</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/5g" class="popup-more-categories__link">5g</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/action-script" class="popup-more-categories__link">Action Script</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/agile" class="popup-more-categories__link">Agile</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/amd" class="popup-more-categories__link">AMD</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/android" class="popup-more-categories__link">Android</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/android-12" class="popup-more-categories__link">Android 12</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/android-wear" class="popup-more-categories__link">Android Wear</a>
</li>
<li class="popup-more-categories__item">
 <a href="/tag/andromeda" class="popup-more-categories__link">Andromeda</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/angular" class="popup-more-categories__link">Angular</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/api" class="popup-more-categories__link">API</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/app-store" class="popup-more-categories__link">App Store</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/apple-pay" class="popup-more-categories__link">Apple Pay</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/arduino" class="popup-more-categories__link">Arduino</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/arm" class="popup-more-categories__link">ARM</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/asp-net" class="popup-more-categories__link">Asp.NET</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/avast" class="popup-more-categories__link">Avast</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/awesomo" class="popup-more-categories__link">Awesomo</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/basic" class="popup-more-categories__link">BASIC</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/bitcoin" class="popup-more-categories__link">Bitcoin</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/chrome-os" class="popup-more-categories__link">Chrome OS</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/chromebook" class="popup-more-categories__link">Chromebook</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/cisco-talos" class="popup-more-categories__link">Cisco Talos</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/cms" class="popup-more-categories__link">CMS</a>
</li>
 <li class="popup-more-categories__item">
<a href="/tag/deepmind" class="popup-more-categories__link">DeepMind</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/delivery-club" class="popup-more-categories__link">Delivery Club</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/dev" class="popup-more-categories__link">dev</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/discord" class="popup-more-categories__link">Discord</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/diy" class="popup-more-categories__link">DIY</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/epic-games" class="popup-more-categories__link">Epic Games</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ethereum" class="popup-more-categories__link">Ethereum</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/f8-2017" class="popup-more-categories__link">F8 2017</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/firefox" class="popup-more-categories__link">Firefox</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/flash" class="popup-more-categories__link">Flash</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/fuchsia" class="popup-more-categories__link">Fuchsia</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/game" class="popup-more-categories__link">Game</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/game2048" class="popup-more-categories__link">game2048</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/git" class="popup-more-categories__link">Git</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/google-analytics" class="popup-more-categories__link">Google Analytics</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/google-chrome" class="popup-more-categories__link">Google Chrome</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/google-io-2017" class="popup-more-categories__link">Google I/O 2017</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/google-pay" class="popup-more-categories__link">Google Pay</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/google-karty" class="popup-more-categories__link">Google Карты</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/gtc-2017" class="popup-more-categories__link">GTC 2017</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/gtk" class="popup-more-categories__link">GTK</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/haskell" class="popup-more-categories__link">Haskell</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/hololens" class="popup-more-categories__link">HoloLens</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ico" class="popup-more-categories__link">ICO</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ide" class="popup-more-categories__link">IDE</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ios" class="popup-more-categories__link">iOS</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/covid-19" class="popup-more-categories__link">IT во время чумы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/it-sleng" class="popup-more-categories__link">IT сленг</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/jquery" class="popup-more-categories__link">jQuery</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/json" class="popup-more-categories__link">JSON</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/jupyter-notebook" class="popup-more-categories__link">Jupyter Notebook</a>
</li>
 <li class="popup-more-categories__item">
<a href="/tag/kubernetes" class="popup-more-categories__link">Kubernetes</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ldap" class="popup-more-categories__link">LDAP</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/linux" class="popup-more-categories__link">Linux</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/macos" class="popup-more-categories__link">macOS</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/magento" class="popup-more-categories__link">Magento</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/build-2017" class="popup-more-categories__link">Microsoft Build 2017</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/microsoft-build-2018" class="popup-more-categories__link">Microsoft Build 2018</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ms-connect-2017" class="popup-more-categories__link">Microsoft Connect 2017</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/microsoft-edge" class="popup-more-categories__link">Microsoft Edge</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/microsoft-project-scorpio" class="popup-more-categories__link">Microsoft Project Scorpio</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/minecraft-na-unity3d" class="popup-more-categories__link">Minecraft на Unity3D</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ml-net" class="popup-more-categories__link">ML.NET</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/neuralink" class="popup-more-categories__link">Neuralink</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/nintendo-switch" class="popup-more-categories__link">Nintendo Switch</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/nosql" class="popup-more-categories__link">NoSQL</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/oculus" class="popup-more-categories__link">Oculus</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/open-source" class="popup-more-categories__link">Open Source</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/openai" class="popup-more-categories__link">OpenAI</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/opencart" class="popup-more-categories__link">OpenCart</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/opengl" class="popup-more-categories__link">OpenGL</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/openshift" class="popup-more-categories__link">Openshift</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/opera" class="popup-more-categories__link">Opera</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/pascal" class="popup-more-categories__link">Pascal</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/paypal" class="popup-more-categories__link">PayPal</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/playstation" class="popup-more-categories__link">PlayStation</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/pokemongo" class="popup-more-categories__link">Pokemon Go</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/powershell" class="popup-more-categories__link">PowerShell</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/product-development" class="popup-more-categories__link">Product Development</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/pycharm" class="popup-more-categories__link">PyCharm</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/qa" class="popup-more-categories__link">QA</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/raspberry-pi" class="popup-more-categories__link">Raspberry Pi</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/reactive-forms" class="popup-more-categories__link">Reactive Forms</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/reactjs" class="popup-more-categories__link">ReactJS</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/redis" class="popup-more-categories__link">Redis</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/redux" class="popup-more-categories__link">Redux</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/rpa" class="popup-more-categories__link">RPA</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/safari" class="popup-more-categories__link">Safari</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/seo" class="popup-more-categories__link">SEO</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/skype" class="popup-more-categories__link">Skype</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/slack" class="popup-more-categories__link">Slack</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/soft-skills" class="popup-more-categories__link">Soft Skills</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/sony" class="popup-more-categories__link">Sony</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/spotify" class="popup-more-categories__link">Spotify</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/surface" class="popup-more-categories__link">Surface</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/tesla" class="popup-more-categories__link">Tesla</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/tiktok" class="popup-more-categories__link">TikTok</a>
</li>
<li class="popup-more-categories__item">
 <a href="/tag/tor" class="popup-more-categories__link">Tor</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/tproger-changelog" class="popup-more-categories__link">Tproger Changelog</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/twitter" class="popup-more-categories__link">Twitter</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/unicode" class="popup-more-categories__link">Unicode</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/unity" class="popup-more-categories__link">Unity</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/unix" class="popup-more-categories__link">unix</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/vmware" class="popup-more-categories__link">VMware</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/vpn" class="popup-more-categories__link">VPN</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/wi-fi" class="popup-more-categories__link">Wi-Fi</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/windows-10" class="popup-more-categories__link">Windows 10</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/windows-11" class="popup-more-categories__link">Windows 11</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/windows-server" class="popup-more-categories__link">Windows Server</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/wordpress" class="popup-more-categories__link">WordPress</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/wwdc-2017" class="popup-more-categories__link">WWDC 2017</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/xamarin" class="popup-more-categories__link">Xamarin</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/xbox" class="popup-more-categories__link">XBox</a>
</li>
 <li class="popup-more-categories__item">
<a href="/tag/xcode" class="popup-more-categories__link">Xcode</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/xen" class="popup-more-categories__link">Xen</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/xiaomi" class="popup-more-categories__link">Xiaomi</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/youtube" class="popup-more-categories__link">YouTube</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/avtomatizirovanie" class="popup-more-categories__link">Автоматизирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/autopilot" class="popup-more-categories__link">Автопилот</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/avtorskoe-pravo" class="popup-more-categories__link">Авторское право</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/algorithms" class="popup-more-categories__link">Алгоритмы и структуры данных</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/alisa" class="popup-more-categories__link">Алиса</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/analiz-dannyh" class="popup-more-categories__link">Анализ данных</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/analytics" class="popup-more-categories__link">Аналитика</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/english-2" class="popup-more-categories__link">Английский</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/software-architecture" class="popup-more-categories__link">Архитектура ПО</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/asinhronnoe-programmirovanie" class="popup-more-categories__link">Асинхронное программирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/bagi-i-oshibki" class="popup-more-categories__link">Баги и ошибки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/db" class="popup-more-categories__link">Базы данных</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/security" class="popup-more-categories__link">Безопасность</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/safe-code" class="popup-more-categories__link">Безопасный код</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/autopilot-2" class="popup-more-categories__link">Беспилотники</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/beta" class="popup-more-categories__link">Бета</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/biznes-analitika" class="popup-more-categories__link">Бизнес-аналитика</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/biotechnology" class="popup-more-categories__link">Биотехнологии</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/blogs" class="popup-more-categories__link">Блоги</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/browsers" class="popup-more-categories__link">Браузеры</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/quick-start" class="popup-more-categories__link">Быстрый старт</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/backend" class="popup-more-categories__link">Бэкенд</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/vzlom" class="popup-more-categories__link">Взлом</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/visualization" class="popup-more-categories__link">Визуализация</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/highload" class="popup-more-categories__link">Высокие нагрузки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/god-v-poiske" class="popup-more-categories__link">Год в Поиске</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/brain-teasers" class="popup-more-categories__link">Головоломки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/guest-post" class="popup-more-categories__link">Гостевая публикация</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/data-centr" class="popup-more-categories__link">Дата-центр</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/dzhejlbrejk" class="popup-more-categories__link">Джейлбрейк</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/dizajn" class="popup-more-categories__link">Дизайн</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/dynamic-type-system" class="popup-more-categories__link">Динамическая типизация</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/for-motivation" class="popup-more-categories__link">Для мотивации</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/for-beginners" class="popup-more-categories__link">Для начинающих</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/for-advanced" class="popup-more-categories__link">Для продвинутых</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/for-amateurs" class="popup-more-categories__link">Для продолжающих</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/what-language-x-is-good-for" class="popup-more-categories__link">Для чего хорош язык X</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/drony" class="popup-more-categories__link">Дроны</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/expert-problems" class="popup-more-categories__link">Задачи повышенной сложности</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/middle-problems" class="popup-more-categories__link">Задачи умеренной сложности</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/frontend-testing-intro" class="popup-more-categories__link">Знакомство с фронтенд-тестированием</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/igra" class="popup-more-categories__link">Игра</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/games" class="popup-more-categories__link">Игры для программистов</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ilon-mask" class="popup-more-categories__link">Илон Маск</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/tools" class="popup-more-categories__link">Инструменты</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/command-line-tools" class="popup-more-categories__link">Инструменты командной строки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/linux-terminal-tools" class="popup-more-categories__link">Инструменты терминала Linux</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/interesting-projects" class="popup-more-categories__link">Интересные проекты</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/internet" class="popup-more-categories__link">Интернет</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/kiberbezopasnost" class="popup-more-categories__link">Информационная безопасность</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/it-history" class="popup-more-categories__link">История IT</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/success-story" class="popup-more-categories__link">История успеха</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/improve-interface" class="popup-more-categories__link">Как улучшить интерфейс</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/career" class="popup-more-categories__link">Карьера</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/code-style" class="popup-more-categories__link">Кодстайл</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/compilers" class="popup-more-categories__link">Компиляторы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/tproger-contest" class="popup-more-categories__link">Конкурс Tproger</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/conferences" class="popup-more-categories__link">Конференции</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/kosmos" class="popup-more-categories__link">Космос</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/good-hack" class="popup-more-categories__link">Красивый хак</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/best-practice" class="popup-more-categories__link">Лучшая практика</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/toplang2020" class="popup-more-categories__link">Лучший язык 2020</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/luchshij-jazyk-2021" class="popup-more-categories__link">Лучший язык 2021</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/magistratura" class="popup-more-categories__link">Магистратура</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/mining" class="popup-more-categories__link">Майнинг</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/marketing" class="popup-more-categories__link">Маркетинг</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/arrays-and-strings" class="popup-more-categories__link">Массивы и строки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/scalability-and-memory-limits" class="popup-more-categories__link">Масштабируемость и ограничения памяти</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/guest" class="popup-more-categories__link">Материалы от друзей Tproger</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/messendzher" class="popup-more-categories__link">Мессенджер</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/software-development" class="popup-more-categories__link">Методологии разработки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/microservices" class="popup-more-categories__link">Микросервисы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/multithreading" class="popup-more-categories__link">Многопоточность</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/music" class="popup-more-categories__link">Музыка</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/english" class="popup-more-categories__link">На английском языке</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/skills" class="popup-more-categories__link">Навыки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/hockey-ai-steering-behaviour" class="popup-more-categories__link">Написание ИИ для хоккея</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/nauka" class="popup-more-categories__link">Наука</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/nejrochip" class="popup-more-categories__link">Нейрочип</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/low-level-coding" class="popup-more-categories__link">Низкоуровневое программирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/new-year" class="popup-more-categories__link">Новый Год</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/obrazovanie" class="popup-more-categories__link">Образование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/courses" class="popup-more-categories__link">Обучающие курсы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/learn-programming" class="popup-more-categories__link">Обучение программированию</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/oop" class="popup-more-categories__link">Объектно-ориентированное программирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/oop-c-sharp" class="popup-more-categories__link">Объектно-ориентированное программирование с примерами на C#</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/competitive-programming" class="popup-more-categories__link">Олимпиадное программирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/onlajn-kursy" class="popup-more-categories__link">Онлайн-курсы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/operating-systems" class="popup-more-categories__link">Операционные системы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/poll" class="popup-more-categories__link">Опрос</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/optimization" class="popup-more-categories__link">Оптимизация</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/dev-organising" class="popup-more-categories__link">Организация разработки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/oruzhie" class="popup-more-categories__link">Оружие</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/programming-concepts" class="popup-more-categories__link">Основные принципы программирования</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/debugging" class="popup-more-categories__link">Отладка</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/oshibki-v-po" class="popup-more-categories__link">Ошибки в ПО</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/pavel-durov" class="popup-more-categories__link">Павел Дуров</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/parsing" class="popup-more-categories__link">Парсинг</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/partnered" class="popup-more-categories__link">Партнёрский материал</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/pashalki" class="popup-more-categories__link">Пасхалки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/design-patterns" class="popup-more-categories__link">Паттерны проектирования</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/relocation" class="popup-more-categories__link">Переезд</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/personalnye-dannye" class="popup-more-categories__link">Персональные данные</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/sandbox" class="popup-more-categories__link">песочница</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/plany-obuchenija" class="popup-more-categories__link">Планы обучения</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/bit-manipulation" class="popup-more-categories__link">Поразрядная обработка</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ugc" class="popup-more-categories__link">Пост пользователя</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/threads-and-locks" class="popup-more-categories__link">Потоки и блокировки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/web-design-guide-for-programmers" class="popup-more-categories__link">Пошаговый гайд по веб-дизайну</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/practice" class="popup-more-categories__link">Практика</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/premija-tjuringa" class="popup-more-categories__link">Премия Тьюринга</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/prilozhenie" class="popup-more-categories__link">Приложение</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/pro" class="popup-more-categories__link">про</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/programmirovanie-dlja-detej" class="popup-more-categories__link">Программирование для детей</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/performance" class="popup-more-categories__link">Производительность</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/processor" class="popup-more-categories__link">Процессор</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/job" class="popup-more-categories__link">Работа</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/encodings" class="popup-more-categories__link">Работа с кодировками</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/work-with-sound" class="popup-more-categories__link">Работа со звуком</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/recognition" class="popup-more-categories__link">Распознавание</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/reactive" class="popup-more-categories__link">Реактивное программирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/regexp" class="popup-more-categories__link">Регулярные выражения</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/recursion-and-dynamic-programming" class="popup-more-categories__link">Рекурсия и динамика</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/retro" class="popup-more-categories__link">Ретро</a>
 </li>
<li class="popup-more-categories__item">
<a href="/tag/refactoring" class="popup-more-categories__link">Рефакторинг</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/rossija" class="popup-more-categories__link">Россия</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/rost-prodazh" class="popup-more-categories__link">Рост продаж</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/s" class="popup-more-categories__link">С#</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/sber" class="popup-more-categories__link">Сбер</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/linked-lists" class="popup-more-categories__link">Связные списки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/server" class="popup-more-categories__link">Сервер</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/services" class="popup-more-categories__link">Сервисы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/network-protocols" class="popup-more-categories__link">Сетевые протоколы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/system-analysis" class="popup-more-categories__link">Системный анализ</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/job-interview" class="popup-more-categories__link">Собеседование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/advices" class="popup-more-categories__link">Советы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/simple-java-games" class="popup-more-categories__link">Создание простых игр на Java</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/sorevnovanija" class="popup-more-categories__link">Соревнования</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/sorting-and-searching" class="popup-more-categories__link">Сортировка и поиск</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/social-networks" class="popup-more-categories__link">Социальные сети</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/internship" class="popup-more-categories__link">Стажировка</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/startups" class="popup-more-categories__link">Стартапы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/statistics" class="popup-more-categories__link">Статистика</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/stacks-and-queues" class="popup-more-categories__link">Стеки и очереди</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/stoit-prochitat" class="popup-more-categories__link">Стоит прочитать</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/supercomputers" class="popup-more-categories__link">Суперкомпьютеры</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/tehpodderzhka" class="popup-more-categories__link">Техподдержка</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ugadajki" class="popup-more-categories__link">Угадайки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/uznajte-kto-vy" class="popup-more-categories__link">Узнайте кто вы</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/smart-home" class="popup-more-categories__link">Умный дом</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/utechka-dannyh" class="popup-more-categories__link">Утечка данных</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/ujazvimost" class="popup-more-categories__link">Уязвимость</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/films" class="popup-more-categories__link">Фильмы</a>
</li>
 <li class="popup-more-categories__item">
<a href="/tag/data-storage-formats" class="popup-more-categories__link">Форматы хранения данных</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/frameworks" class="popup-more-categories__link">Фреймворки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/functional-programming" class="popup-more-categories__link">Функциональное программирование</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/functional-sharp" class="popup-more-categories__link">Функциональный C#</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/hakery" class="popup-more-categories__link">Хакеры</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/hobby" class="popup-more-categories__link">Хобби</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/cifrovoj-pasport" class="popup-more-categories__link">Цифровой паспорт</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/meltdown-spectre" class="popup-more-categories__link">Чипокалипсис</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/design-patterns-simple-words" class="popup-more-categories__link">Шаблоны проектирования простым языком</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/cheatsheets" class="popup-more-categories__link">Шпаргалки</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/jelektromobil" class="popup-more-categories__link">Электромобиль</a>
</li>
<li class="popup-more-categories__item">
<a href="/tag/programming-languages" class="popup-more-categories__link">Языки программирования</a>
</li>
</ul>
</div>
</div>
</div>
<main class="main" id="content">
<div class="main__posts-wrapper">
<main class="column-center">
<article id="post-192138" class="single-post jobs post-192138 type-jobs status-publish hentry jobs_skills-ansible jobs_skills-docker jobs_skills-git jobs_skills-helm jobs_skills-k8s jobs_skills-linux jobs_skills-prometheus jobs_skills-zabbix jobs_category-devops">
<div class="single__header">
<h1 class="">DevOps Инженер</h1>
<div class="vacancy-meta vacancy-meta__salary">По итогам собеседования</div><div class="vacancy-meta"><span class="vacancy-meta__company"><a href="" class="vacancy-meta__company-link"><img width="20" height="20" class="vacancy-meta__company-image" src="https://tproger.ru/s3/uploads/2019/07/krok-logo-90x90.png" alt="КРОК" />КРОК</a>, </span><span class="vacancy-meta__locations">Удалённо</span>, <span class="vacancy-meta__experience is__lowercase">без опыта</span><span class="vacancy-meta__employment-type">, part- или full-time</span></div> <div class='post-actions' id='job-post-action-buttons'>
<button id="tproger-button" class="tp-button tp-button--primary tp-button--medium tp-button--direction-left vacancy-candidate-form-send-button__meta">
<span class="tp-button__text">Откликнуться</span>
</button>
<button id="job-meta-actions-quick-button" class="tp-button tp-button--secondary tp-button--medium tp-button--direction-left job-meta-actions-quick-button">
<svg class="tp-button__icon tp-button__icon--fill">
<use xlink:href="#rocket"></use>
</svg>
<span class="tp-button__text">Быстрый отклик</span>
</button><span style="display:none;" class="vacancy-candidate-form-resend-button__meta-block">Вы отправили отклик на эту вакансию. Хотите <a href="#" class="vacancy-candidate-form-resend-button__meta">отправить ещё один</a>?</span></div> </div>
<div class="single__content">
<p>В команду КРОК открыт набор на вакансию DevOps инженер.</p>
<h2>Задачи</h2>
<ul>
<li>Работать с командой разработки, которая пилит облако;</li>
<li>Разбираться в тонкостях деплоя, автоматизировать его;</li>
<li>Разливать тестовые и продуктивные среды на базе linux, k8s и стэка opensource-продуктов;</li>
<li>Тюнинг и оптимизация систем, обеспечение производительности и отказоустойчивости развернутых контуров.</li>
</ul>
<h2>Требования, необходимые навыки</h2>
<ul>
<li>Уверенные знания k8s;</li>
<li>Умение работать с docker, helm, git, ansible;</li>
<li>Опыт написания CI/CD-пайплайнов, в GitLab или Jeankins;</li>
<li>Опыт развертывания и настройки elk/efk;</li>
<li>Опыт работы с системами мониторинга (zabbix, prometheus);</li>
<li>Опыт работы с СУБД на linux (mysql, postgresql, mongodb и т.д.);</li>
<li>Уверенные знания linux на уровне администрирования;</li>
<li>Понимание принципов работы локальных сетей;</li>
<li>Но самое главное — желание и умение быстро разбираться в новом, учиться и обмениваться опытом с командой.</li>
</ul>
<h2>Условия работы</h2>
<ul>
<li>Заработная плата по результатам собеседования + премии по итогам работы;</li>
<li>Профессиональное обучение и сертификация за счёт компании;</li>
<li>ДМС с полным пакетом медицинских услуг;</li>
<li>Изучение английского языка в очном и дистанционном форматах с компенсацией от компании;</li>
<li>Абонемент в фитнес-центры и спортивные программы с компенсацией от компании, тренажёрный зал в офисе;</li>
<li>Бесплатные завтрак, обед и ужин в офисе;</li>
<li>Современный офис, парковка для всех сотрудников;</li>
<li>Возможен удаленный формат работы.</li>
</ul>
<div class="job-quick-response-form__block"><div class="cards-anchor"><div id="job-reply-quick"></div></div><div class="job-quick-response-form__title">Быстрый отклик</div><div class="job-quick-response-form__content"><div><div id="quick_response_candidate_form"><div class="job-quick-response-form-block"><div class="job-quick-response-form-input-block"><div class="job-quick-response-form__progress" style="display:none;">Идет отправка...</div><div class="job-quick-response-form-input__email-block"><input type="text" placeholder="E-mail" class="job-quick-response-form-email-input"><button class="job-quick-send-button"><svg class="job-quick-send-button__icon"><use xlink:href="#rocket"></use></svg></button></div><div class="job-quick-response-form-error-message"></div><div class="job-quick-form-candidate-agree__checbox-item">
<label for="quick-form-candidate-agree" class="tp-checkbox tp-checkbox--primary">
<input id="quick-form-candidate-agree" name="" class="tp-checkbox__input job-quick-response-form-agree-input" type="checkbox">
<div class="tp-checkbox__box">
<svg class="tp-checkbox__icon">
<use xlink:href="#check"></use>
</svg>
</div>
<div class="tp-checkbox__wrapper-label">
Соглашаюсь на передачу персональных данных согласно <a class="tp-link" href="https://tproger.ru/wp-content/uploads/custom/privacy.pdf" target="_blank">политике конфиденциальности</a> и <a class="tp-link" href="https://tproger.ru/wp-content/uploads/custom/terms.pdf" target="_blank">пользовательскому соглашению</a>
</div>
</label><span id="" name="" class="tp-form-error tp-form-error--show candidate-agree__error error job-quick-response-form-error-message_agree" style="display: none;">Подтвердите согласие</span></div></div></div><div class="job-quick-response-form__after" style="display:none;">Спасибо! С вами свяжутся. Если найдется время, заполните и <a href="#job-reply" onclick="document.getElementById('job-reply').scrollIntoView({block:'start',behavior:'smooth'}); return false;">большую форму отклика</a> тоже. Так у вас будет больше шансов.</div><div class="job-quick-response-form__issend" style="display:none;"> Вы уже отправляли быстрый отклик на эту вакансию. Уверены, что хотите <a class="job-quick-response-form-resend-button">отправить ещё один</a>? Если у вас есть пара минут, лучше заполните <a href="#job-reply">большую форму отклика</a>. Так у вас будет больше шансов. </div></div></div></div></div> </div>
</article>
<article id="job-reply" class="single__box vacancy-candidate-form"><div class="vacancy-candidate-form__loading"></div><div class="candidate-form__container-title"><h2 class="candidate-form__title">Заявка на личную беседу</h2></div><div class="entry-container"><div class="entry-content vacancy-candidate-form__content"><div class="candidate-form__lk-buttons">
<button id="login-profile-link" class="tp-button tp-button--tertiary tp-button--medium tp-button--direction-left lk-response-button login" href="#">
<span class="tp-button__text">Подставить данные из профиля</span>
</button></div><div class="candidate-form__container-fields">
<div class="candidate-form__field candidate-form-field"><div class="candidate-name__field">
<div class="tp-input tp-input--primary tp-input--medium">
<label for="candidate-name" class="tp-input__label">Как вас зовут?*</label>
<input id="candidate-name" class="tp-input__input candidate-name" type="text" placeholder="Имя, фамилия" autocomplete="name">
</div></div><div class="candidate-form__wrapper-error-form"><span id="" name="" class="tp-form-error tp-form-error--show candidate-name__error" style="display: none;"></span></div></div>
<div class="candidate-form__field candidate-form-field"><div class="candidate-contact__field">
<div class="tp-input tp-input--primary tp-input--medium">
<label for="candidate-contact" class="tp-input__label">Телефон/ссылка на мессенджер*</label>
<input id="candidate-contact" class="tp-input__input candidate-contact" type="text" placeholder="+7 921 123 4567 или @telegram" autocomplete="tel-national">
</div></div><div class="candidate-form__wrapper-error-form"><span id="" name="" class="tp-form-error tp-form-error--show candidate-contact__error" style="display: none;"></span></div></div>
</div><div class="candidate-form__container-fields candidate-form-fields__about">
<div class="candidate-form__field candidate-form-field"><div class="candidate-about__field">
<div class="tp-textarea tp-textarea--standart">
<label for="candidate-about" class="tp-textarea__label">Сопроводительное письмо*</label>
<textarea class="tp-textarea__textarea candidate-about" id="candidate-about" name="" placeholder="Желательно указать, где раньше учились или работали" rows="5" autocomplete="on"></textarea>
</div>
</div><div class="candidate-form__wrapper-error-form"><span id="" name="" class="tp-form-error tp-form-error--show candidate-about__error" style="display: none;"></span></div></div>
</div><div class="candidate-form__container-fields"><div class="candidate-form__field candidate-form-field">
<div class="tp-input tp-input--primary tp-input--medium">
<label for="candidate-email" class="tp-input__label">Ваш E-mail</label>
<input id="candidate-email" class="tp-input__input candidate-email" type="text" placeholder="" autocomplete="email">
</div></div><div class="candidate-form__field candidate-form-field">
<div class="tp-input tp-input--primary tp-input--medium">
<label for="candidate-resume" class="tp-input__label">Ссылка на формально резюме</label>
<input id="candidate-resume" class="tp-input__input candidate-resume" type="text" placeholder="" autocomplete="on">
</div></div></div><div class="candidate-form__container-checkbox">
<label for="candidate-savefields__label" class="tp-checkbox tp-checkbox--primary">
<input id="candidate-savefields__label" name="" class="tp-checkbox__input candidate-savefields" type="checkbox">
<div class="tp-checkbox__box">
<svg class="tp-checkbox__icon">
<use xlink:href="#check"></use>
</svg>
</div>
<div class="tp-checkbox__wrapper-label">
Сохранить данные в личном кабинете
</div>
</label>
</div>
<div class="candidate-form__container-checkbox candidate-agree__checbox-item">
<label for="candidate-agree" class="tp-checkbox tp-checkbox--primary">
<input id="candidate-agree" name="" class="tp-checkbox__input candidate-agree" type="checkbox">
<div class="tp-checkbox__box">
<svg class="tp-checkbox__icon">
<use xlink:href="#check"></use>
</svg>
 </div>
<div class="tp-checkbox__wrapper-label">
Я соглашаюсь на передачу персональных данных согласно
<a id="" class="tp-link tp-link--no-icon tp-link--direction-left" href="https://tproger.ru/wp-content/uploads/custom/privacy.pdf" target="_blank">
<span class="tp-link__text">политике конфиденциальности</span>
</a> и
<a id="" class="tp-link tp-link--no-icon tp-link--direction-left" href="https://tproger.ru/wp-content/uploads/custom/privacy.pdf" target="_blank">
<span class="tp-link__text">пользовательскому соглашению</span>
</a>
</div>
</label>
</div>
<div class="candidate-form__wrapper-error-form"><span id="" name="" class="tp-form-error tp-form-error--show candidate-agree__error" style="display: none;"></span></div><div class="candidate-form__footer">
<div class="candidate-form__container-submit-button">
<button id="submit-candidate-button" class="tp-button tp-button--primary tp-button--large tp-button--direction-left submit-candidate-button">
<span class="tp-button__text">Отправить заявку</span>
</button></div>
<div class="candidate-form__container-loading-item"><div class="loading-text" style="display:none;">Пожалуйста, подождите, отправляем данные<span class="loading-dots"></span></div></div>
</div></div><div class="entry-content vacancy-candidate-form-resend-button__block" style="display:none;"><p>Вы уже отправили заявку на личную беседу. Уверены, что хотите <a href="#" class="vacancy-candidate-form-resend-button">отправить ещё одну</a>?</p></div></div></article>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@graph":[{"@type":"JobPosting","title":"DevOps \u0418\u043d\u0436\u0435\u043d\u0435\u0440","description":"\u0412\u00a0\u043a\u043e\u043c\u0430\u043d\u0434\u0443 \u041a\u0420\u041e\u041a \u043e\u0442\u043a\u0440\u044b\u0442 \u043d\u0430\u0431\u043e\u0440 \u043d\u0430\u00a0\u0432\u0430\u043a\u0430\u043d\u0441\u0438\u044e DevOps \u0438\u043d\u0436\u0435\u043d\u0435\u0440.","datePosted":"2022-02-11","validThrough":"2022-03-13","employmentType":["FULL_TIME","PART_TIME","CONTRACTOR","TEMPORARY","INTERN","VOLUNTEER","PER_DIEM","OTHER"],"jobLocation":{"@type":"Place","address":[{"@type":"PostalAddress","streetAddress":"\u0423\u0434\u0430\u043b\u0451\u043d\u043d\u043e","addressLocality":"\u0423\u0434\u0430\u043b\u0451\u043d\u043d\u043e","addressRegion":"\u0423\u0434\u0430\u043b\u0451\u043d\u043d\u043e","postalCode":"\u0423\u0434\u0430\u043b\u0451\u043d\u043d\u043e","addressCountry":"\u0423\u0434\u0430\u043b\u0451\u043d\u043d\u043e"}]},"baseSalary":{"@type":"MonetaryAmount","currency":"RUB","value":{"@type":"QuantitativeValue","unitText":"MONTH","value":"\u041f\u043e \u0438\u0442\u043e\u0433\u0430\u043c \u0441\u043e\u0431\u0435\u0441\u0435\u0434\u043e\u0432\u0430\u043d\u0438\u044f"}},"hiringOrganization":{"@type":"Organization","name":"\u041a\u0420\u041e\u041a","sameAs":"","logo":"https:\/\/tproger.ru\/s3\/uploads\/2019\/07\/krok-logo-90x90.png"}},{"@type":"BreadcrumbList","itemListElement":{"@type":"ListItem","position":1,"item":{"@id":"jobs","name":"https:\/\/tproger.ru\/jobs\/"}}}]}</script> </main>
</div>
</main>
<aside id="asideRight" class="aside-right" data-container-loaded="no" data-loaded-count="0">
<div class="main__container-telegram-widget main__container-telegram-widget--desktop">
</div>
<div class="box widget-about-company"><a href=""><img width="90" height="90" src="https://tproger.ru/s3/uploads/2019/07/krok-logo-90x90.png" class="widget-img widget-company-logo" alt="КРОК" title="КРОК" srcset="https://tproger.ru/s3/uploads/2019/07/krok-logo.png 1226w, https://tproger.ru/s3/uploads/2019/07/krok-logo-150x150.png 150w, https://tproger.ru/s3/uploads/2019/07/krok-logo-280x280.png 280w, https://tproger.ru/s3/uploads/2019/07/krok-logo-670x670.png 670w, https://tproger.ru/s3/uploads/2019/07/krok-logo-90x90.png 90w, https://tproger.ru/s3/uploads/2019/07/krok-logo-50x50.png 50w, https://tproger.ru/s3/uploads/2019/07/krok-logo-970x970.png 970w, https://tproger.ru/s3/uploads/2019/07/krok-logo-720x720.png 720w, https://tproger.ru/s3/uploads/2019/07/krok-logo-1080x1080.png 1080w, https://tproger.ru/s3/uploads/2019/07/krok-logo-660x660.png 660w, https://tproger.ru/s3/uploads/2019/07/krok-logo-726x726.png 726w, https://tproger.ru/s3/uploads/2019/07/krok-logo-32x32.png 32w, https://tproger.ru/s3/uploads/2019/07/krok-logo-16x16.png 16w" data-id="0"></a><div class="widget-caption"><a class="widget-caption-a hoverable" href="">КРОК</a></div><div class="widget-text small"></div><div class="about-company-jobs"><div class="about-company-jobs-list">
<div class="about-company-jobs-item-last-jobs">
<div class="about-company-jobs-info-last-jobs-info">
<div class="about-company-jobs-title" title="UX/UI-дизайнер (Middle)"><a href="https://tproger.ru/jobs/ux-ui-dizajner-middle/">UX/UI-дизайнер (Middle)</a></div>
</div>
</div>
<div class="about-company-jobs-item-last-jobs">
<div class="about-company-jobs-info-last-jobs-info">
<div class="about-company-jobs-title" title="Сетевой инженер (Облачные сервисы)"><a href="https://tproger.ru/jobs/setevoj-inzhener-oblachnye-servisy/">Сетевой инженер (Облачные сервисы)</a></div>
</div>
</div>
<div class="about-company-jobs-item-last-jobs">
<div class="about-company-jobs-info-last-jobs-info">
<div class="about-company-jobs-title" title="Системный инженер в команду Облако КРОК"><a href="https://tproger.ru/jobs/sistemnyj-inzhener-v-komandu-oblako-krok/">Системный инженер в команду Облако КРОК</a></div>
</div>
</div></div></div>
<a id="" class="tp-link tp-link--no-icon tp-link--direction-left" href="#jobs&utm_source=tproger_ru_right_banner">
<span class="tp-link__text">Все вакансии компании</span>
</a></div><div id="right_event_job_widget-20" data-widget-type="sidebar" data-type="5" data-wtype="sidebar" data-btn-title="Все вакансии" data-btn-url="/jobs" data-utm="banner-right-vacancy&utm_medium=job" data-rbtn-title="" data-rbtn-url="" data-job class="box tproger-event-job-widget subscription-widget nopadding widget-sidebar-type" style="width:100%;"><div class="widget-list"><a href="https://tproger.ru/jobs/software-development-engineer-in-test-sdet/?utm_source=banner-right-vacancy&utm_medium=job" data-postID="190841"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><div class="widget-list-item__container-image"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;30px&quot; viewBox=&quot;0 0 30 30&quot;%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2022/01/square-black-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2022/01/square-black.png 2000w, https://tproger.ru/s3/uploads/2022/01/square-black-330x330.png 330w, https://tproger.ru/s3/uploads/2022/01/square-black-1940x1940.png 1940w, https://tproger.ru/s3/uploads/2022/01/square-black-150x150.png 150w, https://tproger.ru/s3/uploads/2022/01/square-black-840x840.png 840w, https://tproger.ru/s3/uploads/2022/01/square-black-970x970.png 970w, https://tproger.ru/s3/uploads/2022/01/square-black-1680x1680.png 1680w, https://tproger.ru/s3/uploads/2022/01/square-black-720x720.png 720w, https://tproger.ru/s3/uploads/2022/01/square-black-1080x1080.png 1080w, https://tproger.ru/s3/uploads/2022/01/square-black-660x660.png 660w, https://tproger.ru/s3/uploads/2022/01/square-black-726x726.png 726w, https://tproger.ru/s3/uploads/2022/01/square-black-90x90.png 90w, https://tproger.ru/s3/uploads/2022/01/square-black-50x50.png 50w, https://tproger.ru/s3/uploads/2022/01/square-black-32x32.png 32w, https://tproger.ru/s3/uploads/2022/01/square-black-16x16.png 16w" data-sizes="30px, 30w" decoding="async"></div></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Software Development Engineer in Test (SDET)</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">part- или full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/c-developer-s-vozmozhnostju-pereezda-v-pragu/?utm_source=banner-right-vacancy&utm_medium=job" data-postID="184752"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><div class="widget-list-item__container-image"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;30px&quot; viewBox=&quot;0 0 30 30&quot;%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-32x32.jpg" data-srcset="https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery.jpg 1080w, https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-274x330.jpg 274w, https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-670x808.jpg 670w, https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-970x1170.jpg 970w, https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-880x1062.jpg 880w, https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-720x869.jpg 720w, https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-660x796.jpg 660w, https://tproger.ru/s3/uploads/2021/07/Screenshot_20210713-162426_Gallery-726x876.jpg 726w" data-sizes="30px, 30w" decoding="async"></div></div><div class="widget-list-item-right"><div class="widget-list-item-caption">C++ Developer (с возможностью переезда в Прагу)</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">part- или full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/chief-technology-officer-cto-blockchain/?utm_source=banner-right-vacancy&utm_medium=job" data-postID="189211"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><div class="widget-list-item__container-image"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;30px&quot; viewBox=&quot;0 0 30 30&quot;%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/12/logo_M-v-p-bvm-1-p-2-150x150.png" data-srcset="https://tproger.ru/s3/uploads/2021/12/logo_M-v-p-bvm-1-p-2.png 1080w, https://tproger.ru/s3/uploads/2021/12/logo_M-v-p-bvm-1-p-2-330x330.png 330w, https://tproger.ru/s3/uploads/2021/12/logo_M-v-p-bvm-1-p-2-150x150.png 150w, https://tproger.ru/s3/uploads/2021/12/logo_M-v-p-bvm-1-p-2-670x670.png 670w" data-sizes="30px, 30w" decoding="async"></div></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Chief Technology Officer (CTO) | Blockchain</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">part- или full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/timlid-linux-devops-v-gruppe-soprovozhdenija-it-infrastruktur/?utm_source=banner-right-vacancy&utm_medium=job" data-postID="192137"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><div class="widget-list-item__container-image"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;30px&quot; viewBox=&quot;0 0 30 30&quot;%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2019/07/krok-logo-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2019/07/krok-logo.png 1226w, https://tproger.ru/s3/uploads/2019/07/krok-logo-150x150.png 150w, https://tproger.ru/s3/uploads/2019/07/krok-logo-280x280.png 280w, https://tproger.ru/s3/uploads/2019/07/krok-logo-670x670.png 670w, https://tproger.ru/s3/uploads/2019/07/krok-logo-90x90.png 90w, https://tproger.ru/s3/uploads/2019/07/krok-logo-50x50.png 50w, https://tproger.ru/s3/uploads/2019/07/krok-logo-970x970.png 970w, https://tproger.ru/s3/uploads/2019/07/krok-logo-720x720.png 720w, https://tproger.ru/s3/uploads/2019/07/krok-logo-1080x1080.png 1080w, https://tproger.ru/s3/uploads/2019/07/krok-logo-660x660.png 660w, https://tproger.ru/s3/uploads/2019/07/krok-logo-726x726.png 726w, https://tproger.ru/s3/uploads/2019/07/krok-logo-32x32.png 32w, https://tproger.ru/s3/uploads/2019/07/krok-logo-16x16.png 16w" data-sizes="30px, 30w" decoding="async"></div></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Тимлид Linux / DevOps в Группе сопровождения ИТ-инфраструктур</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">part- или full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/vedushhij-razrabotchik-java/?utm_source=banner-right-vacancy&utm_medium=job" data-postID="188069"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><div class="widget-list-item__container-image"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;30px&quot; viewBox=&quot;0 0 30 30&quot;%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/11/Group-66-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/11/Group-66.png 1026w, https://tproger.ru/s3/uploads/2021/11/Group-66-330x330.png 330w, https://tproger.ru/s3/uploads/2021/11/Group-66-150x150.png 150w, https://tproger.ru/s3/uploads/2021/11/Group-66-670x670.png 670w, https://tproger.ru/s3/uploads/2021/11/Group-66-970x970.png 970w, https://tproger.ru/s3/uploads/2021/11/Group-66-880x880.png 880w, https://tproger.ru/s3/uploads/2021/11/Group-66-720x720.png 720w, https://tproger.ru/s3/uploads/2021/11/Group-66-660x660.png 660w, https://tproger.ru/s3/uploads/2021/11/Group-66-726x726.png 726w, https://tproger.ru/s3/uploads/2021/11/Group-66-90x90.png 90w, https://tproger.ru/s3/uploads/2021/11/Group-66-50x50.png 50w, https://tproger.ru/s3/uploads/2021/11/Group-66-32x32.png 32w, https://tproger.ru/s3/uploads/2021/11/Group-66-16x16.png 16w" data-sizes="30px, 30w" decoding="async"></div></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Ведущий разработчик Java</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">part- или full-time</span></div></div></div></a><div class="widget-list-footer"><a href="/jobs?utm_source=banner-right-vacancy" class="show-more-widget hoverable">Все вакансии<span class="icon-right-open vertical-middle"></span></a></div></div></div> </aside>
</div>
</div>
<footer>
<script>
window.ym=window.ym||function(){(ym.a=ym.a||[]).push(arguments)};ym.l=1*new Date();
ym(27485085, "init", {clickmap: true, trackLinks: true, accurateTrackBounce: true, webvisor: false});
</script>
<script type="text/javascript" src="https://proxy.tproger.ru/yandex-metrika.js" async></script>
<noscript><div><img src="https://mc.yandex.ru/watch/27485085" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://tproger.ru/",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://tproger.ru/search/?searchid=2415386&text={search_term_string}&web=0",
    "query-input": "required name=search_term_string"
  }
}
</script>
<script>var OneSignal = window.OneSignal || [];</script>
<script type="text/javascript" src="https://proxy.tproger.ru/vk-openapi.js" onload="window.setupVK && window.setupVK()" defer></script>
<script type="text/javascript" src="https://proxy.tproger.ru/onesignal-sdk.js" onload="window.setupOneSignal && window.setupOneSignal()" async="async"></script>
<script type="module" src="/wp-content/themes/gecko/system/assets/js/instant-page.x78180.js"></script><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><script>var widgetsNonce='99aa66ac18';</script> <script>
                    !function(){if('PerformanceLongTaskTiming' in window){var g=window.__tti={e:[]};
                    g.o=new PerformanceObserver(function(l){g.e=g.e.concat(l.getEntries())});
                    g.o.observe({entryTypes:['longtask']})}}();
                    </script> <script type='text/javascript' id='post-views-counter-frontend-js-extra'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"ajax","requestURL":"https:\/\/tproger.ru\/wp-content\/plugins\/tproger-post-views-counter\/includes\/ajax.php","postID":"192138","nonce":"d7b8996ad0"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/c0cba.x78180.js"></script>
<div id="errors-popup">
<div class="errors-popup__cover"></div>
<div class="errors-popup__modal">
<div class="errors-popup__close">
<button class="errors-popup__close-button">
<svg class="errors-popup__icon errors-popup__icon--close">
<title>Крестик</title>
<use xlink:href="#cancel"></use>
</svg>
</button>
</div>
<div class="errors-popup__header">
 <svg class="errors-popup__icon errors-popup__icon--bug">
<title>Баг</title>
<use xlink:href="#bug"></use>cancel
</svg>
<span class="errors-popup__title">Сообщить об ошибке</span>
</div>
<div class="errors-popup__setting">
<div class="errors-popup__wrapper-textarea">
<div class="tp-textarea tp-textarea--small">
<label for="" class="tp-textarea__label">Как нам повторить баг?</label>
<textarea class="tp-textarea__textarea errors-popup__textarea" id="" name="arrange" placeholder="Максимально опишите окружение происходящего: ОС, браузер и т.д." rows="3"></textarea>
</div> </div>
<div class="errors-popup__wrapper-textarea">
<div class="tp-textarea tp-textarea--small">
<label for="" class="tp-textarea__label">Опишите баг</label>
<textarea class="tp-textarea__textarea errors-popup__textarea" id="" name="actual" placeholder="Если есть возможность, сделайте скриншоты или запишите видео. Залейте и пришлите ссылку." rows="3"></textarea>
</div> </div>
<div class="errors-popup__wrapper-textarea">
<div class="tp-textarea tp-textarea--small">
<label for="" class="tp-textarea__label">Ожидание</label>
<textarea class="tp-textarea__textarea errors-popup__textarea" id="" name="assert" placeholder="Расскажите, как, по-вашему, это должно было работать." rows="3"></textarea>
</div> </div>
</div>
<button id="" class="tp-button tp-button--primary tp-button--medium tp-button--direction-left errors-popup__submit-button hoverable">
<span class="tp-button__text">Отправить</span>
</button> </div>
</div>
</footer>
<div class="sharing-lock"></div>
<div class="sharing-menu">
<div class="sharing-close icon-close"></div>
<a title="Копировать ссылку на пост" class="icon-link sharing-menu-item" href="javascript:void(0);" onClick="copyLinkToClipboard('https://tproger.ru/jobs/devops-inzhener-2/');">Копировать ссылку</a>
<a title="Поделиться во ВКонтакте" class="icon-vkontakte sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://vk.com/share.php?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fdevops-inzhener-2%2F&title=DevOps+%D0%98%D0%BD%D0%B6%D0%B5%D0%BD%D0%B5%D1%80');">ВКонтакте</a>
<a title="Поделиться на Facebook" class="icon-facebook sharing-menu-item" href="javascript:void(0);" onClick="social_share('http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftproger.ru%2Fjobs%2Fdevops-inzhener-2%2F&t=DevOps+%D0%98%D0%BD%D0%B6%D0%B5%D0%BD%D0%B5%D1%80');">Facebook</a>
<a title="Поделиться в Twitter" class="icon-twitter sharing-menu-item" href="javascript:void(0);" onClick="social_share('http://twitter.com/intent/tweet?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fdevops-inzhener-2%2F&text=DevOps Инженер');">Twitter</a>
<a title="Сохранить в Pocket" class="icon-pocket small sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://getpocket.com/edit?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fdevops-inzhener-2%2F');">Pocket</a>
<a title="Отправить в Telegram" class="icon-telegram sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://telegram.me/share/url?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fdevops-inzhener-2%2F&text=DevOps Инженер');">Telegram</a>
</div>
</body>
</html>
