
<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#  profile: http://ogp.me/ns/profile# fb: http://ogp.me/ns/fb#" lang="ru-RU">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="preload" as="image" href="https://tproger.ru/s3/uploads/2021/12/Background1-880x308.png" imagesrcset="https://tproger.ru/s3/uploads/2021/12/Background1-330x116.png 330w, https://tproger.ru/s3/uploads/2021/12/Background1-670x235.png 670w, https://tproger.ru/s3/uploads/2021/12/Background1-970x340.png 970w, https://tproger.ru/s3/uploads/2021/12/Background1-880x308.png 880w, https://tproger.ru/s3/uploads/2021/12/Background1-1760x617.png 1760w, https://tproger.ru/s3/uploads/2021/12/Background1-720x252.png 720w, https://tproger.ru/s3/uploads/2021/12/Background1-1080x378.png 1080w, https://tproger.ru/s3/uploads/2021/12/Background1-660x231.png 660w, https://tproger.ru/s3/uploads/2021/12/Background1-726x254.png 726w, https://tproger.ru/s3/uploads/2021/12/Background1.png 1941w" imagesizes="(min-width: 1320px) 880px, (min-width: 977px) 620px, (min-width: 481px) calc(100vw - 40px), 100vw">
<link rel="preload" href="/wp-content/fonts/Roboto-Regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" as="image" href="/wp-content/themes/bliss/assets/img/logo.svg">
<link rel="preconnect" href="https://mc.yandex.ru">
<link rel="preconnect" href="https://mc.yandex.ru" crossorigin>
<link rel="preconnect" href="https://vk.com">
<link rel="preconnect" href="https://cdn.onesignal.com">
<link rel="preconnect" href="https://onesignal.com" crossorigin>
<link rel="preconnect" href="https://tproger.ru" crossorigin>
<link rel="preconnect" href="https://sentry.tproger.ru" crossorigin>
<link rel="dns-prefetch" href="https://track.tproger.ru">
<script defer src="https://tproger.ru/wp-content/themes/bliss/assets/js/sentry.es6.min.x96615.js" onload="Sentry.init({ dsn: 'https://63f279b4a66348b9ade9e95f8bcb2e0e@sentry.tproger.ru/5302604', environment: 'tproger.ru', release: '0304e0612c6fd3c6e69f9487bd073baec4acad6e', tracesSampleRate: 0, beforeSend(event) { return ((window.ses = window.ses ? window.ses + 1 : 1) > 16) ? null : event }, }); window.setAnalyticsSentryTags && setAnalyticsSentryTags()"></script>

<title>Senior Frontend Developer &mdash; вакансия на Tproger</title>
<link rel="canonical" href="https://tproger.ru/jobs/senior-frontend-developer-2/" />
<meta property="og:locale" content="ru_RU" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Senior Frontend Developer" />
<meta property="og:description" content="Требования, необходимые навыки Опыт разработки на JavaScript / TypeScript на менее 3-х лет; Умение спроектировать подсистему продукта и аргументировать свое решение; Отличное знание React + Redux, jQuery, Razor templates; Понимание…" />
<meta property="og:url" content="https://tproger.ru/jobs/senior-frontend-developer-2/" />
<meta property="og:site_name" content="Tproger" />
<meta property="article:publisher" content="https://www.facebook.com/tproger/" />
<meta property="article:modified_time" content="2021-12-01T15:10:07+00:00" />
<meta property="og:image" content="https://tproger.ru/s3/uploads/2021/12/Background1.png" />
<meta property="og:image:width" content="1941" />
<meta property="og:image:height" content="680" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@tproger" />

<link rel='dns-prefetch' href='//tproger.ru' />
<link rel="alternate" type="application/rss+xml" title="Tproger &raquo; Лента" href="https://tproger.ru/feed/" />
<script defer src="https://tproger.ru/wp-content/cache/minify/d8742.x96615.js"></script>
<script type='text/javascript' id='jobs.single.script-js-extra'>
/* <![CDATA[ */
var vkApiData = {"id":"6743776","redirect_uri":"https:\/\/tproger.ru\/vk-auth\/"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/3e4c6.x96615.js"></script>
<script async src="https://tproger.ru/wp-content/cache/minify/98da1.x96615.js"></script>
<link rel="https://api.w.org/" href="https://tproger.ru/wp-json/" /><link rel='shortlink' href='https://tproger.ru/?p=187373' />
<link rel="icon" href="/favicon.ico?v=2">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="192x192" href="/android-chrome-192x192.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#2aa5a0">
<meta name="apple-mobile-web-app-title" content="Tproger">
<meta name="application-name" content="Tproger">
<meta name="theme-color" content="#2aa5a0">
</head>
<body class="jobs-template-default single single-jobs postid-187373 dark">
<style id="fake-style">
					@font-face {
		font-family: 'Roboto';
		src:
			local('Roboto Medium'),
			local('Roboto-Medium'),
			url('/wp-content/fonts/Roboto-Medium.woff2') format('woff2'),
			url('/wp-content/fonts/Roboto-Medium.woff') format('woff'),
			url('/wp-content/fonts/Roboto-Medium.ttf') format('truetype');
		font-weight: 500;
		font-style: normal;
		font-display: swap;
	}
	body {
		margin: 0;
	}
	.dark {
		background: #2b2a29;
	} 				#fake-post {
					display: block;
					position: fixed;
					top: 52px;
					padding-top: 0px;
					width: 100%;
					height: 100%;
					z-index: 0;
					background: #fff;
				}
				#fake-header {
					margin: 15px 15px 0;
					font-size: 26px;
					font-family: Roboto, sans-serif;
					font-weight: 500;
					line-height: 1.3;
					color: #333;
					
					 
				}
				#fake-scroll {
					display: none;
				}

				@media (max-width: 480px) {
					#fake-post {
						top: 52px;
					}
				}
				@media (min-width: 481px) {
					#fake-post {
						top: 53px;
						left: 20px;
						width: calc(100% - 40px);
						height: 100%;
						border-radius: 4px 4px 0 0;
						padding-top: 0;
					}
					#fake-header {
						padding: 15px 20px 66px 20px;
						margin: 0;
						font-size: 30px;
						 
					}
					#fake-scroll {
						display: block;
						position: relative;
						top: 101vh;
						width: 1px;
						height: 1px;
					}
				}
				@media (min-width: 768px) {
					#fake-header {
						padding: 35px 50px 66px 50px;
						font-size:30px;
						 
					}
				}
				@media (min-width: 977px) {
					#fake-post {
						top: 83px;
						left: calc((100% - 940px) / 2);
						width: 620px;
					}
				}
				@media (min-width: 1320px) {
					#fake-post {
						left: calc((100% - 1270px) / 2);
						width: 880px;
					}
					#fake-header {
						padding: 50px 105px 66px 105px;
						font-size: 34px;
						 
					}
				}
			</style>
<div id="fake-post">
<h1 id="fake-header">Senior Frontend Developer</h1>
</div>
<div id="fake-scroll"></div>
<link rel="stylesheet" href="https://tproger.ru/wp-content/cache/minify/17782.x96615.css" media="all" />
<div id="page" style="display: none;" class="site">
<div id="tproger-login-s">
<div class="pre-modal-cover"></div>
<div class="pre-modal-container box">
<div id="auth-modal-close" class="close-post icon-close" on:click={openAuthWindow}></div>
<div class="auth-window-header">
<h3>Авторизуйтесь</h3>
<div class="auth-window-header__text">Это не займет больше 5 секунд</div>
</div>
<div class="modal-buttons">
<div class="social__top">
<span class="btn-social btn-social__vk icon-vkontakte colored">
<span>Войти с VK</span>
</span>
<span class="btn-social btn-social__google icon-google colored">
<span>Войти с Google</span>
</span>
</div>
<div class="social__bottom">
<span class="btn-social btn-social__github icon-github-circled-alt2 colored">
<span>GitHub</span>
</span>
<span class="btn-social btn-social__facebook icon-facebook colored">
<span>Facebook</span>
</span>
<span class="btn-social btn-social__yandex icon-yandex colored">
<span>Yandex</span>
</span>
<span class="btn-social btn-social__twitter icon-twitter colored">
<span>Twitter</span>
</span>
</div>
<div class="telegram-auth-button">
<div class="telegram-auth-button__inner"></div>
<script async src="https://telegram.org/js/telegram-widget.js?15" data-telegram-login="tproger_official_bot" data-size="large" data-userpic="false" data-radius="8" data-onauth="window.onTelegramAuth(user)" data-request-access="write"></script>
</div>
</div>
<div class="agreement__container"><label for="user-login-checkbox" class="agreement__container-label"><input type="checkbox" id="user-login-checkbox" name="user-login-checkbox" value="false"> <label for="user-login-checkbox"><span></span></label>
<div class="agreement__text">
<div class="highlight"><span>Я соглашаюсь с</span> <a href="/wp-content/uploads/custom/terms.pdf" target="_blank">правилами пользования сайтом</a></div>
<div class="highlight"><span>и даю</span> <a href="/wp-content/uploads/custom/privacy.pdf" target="_blank">согласие на обработку персональных данных</a></div>
</div>
</label></div>
<div class="warning__container" style="display:none">
<div class="text-warning">Пожалуйста, согласитесь с правилами пользования</div>
</div>
</div>
</div> <header id="masthead" role="banner" class="">
<div id="header-container">
<div id="reading-progress"></div>
<nav id="header" role="navigation" class="windowed">
<div class="header-toogle">
<div id="main-menu-toggle" class="header-item">
<input id="main-menu-toggle-input" type="checkbox" />
<div id="menu-cover"></div>
<span class="main-menu-toggle-span"></span>
<span class="main-menu-toggle-span"></span>
<span class="main-menu-toggle-span"></span>
<ul id="main-menu" class="show-on-idle"><li id="menu-item-179398" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/company/" title="Компании" class="main-menu-a"><i class="icon-company menu-icons"></i>Компании</a></li><li id="menu-item-144836" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/editor/?utm_source=sidebar" title="Написать пост" class="main-menu-a"><i class="icon-edit menu-icons"></i>Написать пост</a></li><li id="menu-item-116286" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/jobs/?utm_source=tproger_ru_main_menu" title="Вакансии" class="main-menu-a"><i class="icon-menu-job menu-icons"></i>Вакансии</a></li><li id="menu-item-85895" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a title="События и курсы, на которых можно поднять свой уровень" href="/events/" title="События и курсы" class="main-menu-a"><i class="icon-menu-time menu-icons"></i>События и курсы</a></li><li id="menu-item-163320" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/category/interactive/" title="Игры" class="main-menu-a"><i class="icon-games menu-icons"></i>Игры</a></li><li id="menu-item-116238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Рубрики" class="main-menu-a"><i class="icon-menu-heading menu-icons"></i>Рубрики<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116246" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/curriculum/" title="Планы обучения" class="main-menu-a"><i class="icon- menu-icons"></i>Планы обучения</a></li> <li id="menu-item-12274" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Задачи с IT-собеседований" href="https://tproger.ru/problems/" title="Задачки" class="main-menu-a"><i class="icon- menu-icons"></i>Задачки</a></li> <li id="menu-item-73978" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Тесты и викторины" href="https://tproger.ru/quiz/" title="Тесты и викторины" class="main-menu-a"><i class="icon- menu-icons"></i>Тесты и викторины</a></li> <li id="menu-item-116243" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/books/" title="Книги" class="main-menu-a"><i class="icon- menu-icons"></i>Книги</a></li> <li id="menu-item-116240" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/video/" title="Видео" class="main-menu-a"><i class="icon- menu-icons"></i>Видео</a></li> <li id="menu-item-116244" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/explain/" title="Коротко о главном" class="main-menu-a"><i class="icon- menu-icons"></i>Коротко о главном</a></li> <li id="menu-item-21201" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Ответы экспертов на вопросы читателей" href="https://tproger.ru/experts/" title="Советы экспертов" class="main-menu-a"><i class="icon- menu-icons"></i>Советы экспертов</a></li> <li id="menu-item-116249" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/articles/" title="Статьи" class="main-menu-a"><i class="icon- menu-icons"></i>Статьи</a></li> <li id="menu-item-116245" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/translations/" title="Переводы" class="main-menu-a"><i class="icon- menu-icons"></i>Переводы</a></li> <li id="menu-item-116247" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/digest/" title="Подборки" class="main-menu-a"><i class="icon- menu-icons"></i>Подборки</a></li> <li id="menu-item-116239" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/devnull/" title="Юмор" class="main-menu-a"><i class="icon- menu-icons"></i>Юмор</a></li> <li id="menu-item-116241" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/interview/" title="Интервью" class="main-menu-a"><i class="icon- menu-icons"></i>Интервью</a></li>
</ul>
</li><li id="menu-item-116254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Темы" class="main-menu-a"><i class="icon-menu-topics menu-icons"></i>Темы<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116253" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/for-beginners/" title="Для начинающих" class="main-menu-a"><i class="icon- menu-icons"></i>Для начинающих</a></li> <li id="menu-item-116257" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/algorithms/" title="Алгоритмы" class="main-menu-a"><i class="icon- menu-icons"></i>Алгоритмы</a></li> <li id="menu-item-116258" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/design-patterns/" title="Паттерны проектирования" class="main-menu-a"><i class="icon- menu-icons"></i>Паттерны проектирования</a></li> <li id="menu-item-116260" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/software-development/" title="Методологии разработки" class="main-menu-a"><i class="icon- menu-icons"></i>Методологии разработки</a></li> <li id="menu-item-116255" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/web/" title="Веб-разработка" class="main-menu-a"><i class="icon- menu-icons"></i>Веб-разработка</a></li> <li id="menu-item-116256" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/gamedev/" title="Разработка игр" class="main-menu-a"><i class="icon- menu-icons"></i>Разработка игр</a></li> <li id="menu-item-116262" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/mobiledev/" title="Мобильная разработка" class="main-menu-a"><i class="icon- menu-icons"></i>Мобильная разработка</a></li> <li id="menu-item-116259" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/machine-learning/" title="Машинное обучение" class="main-menu-a"><i class="icon- menu-icons"></i>Машинное обучение</a></li> <li id="menu-item-116264" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/neural-network/" title="Нейронные сети" class="main-menu-a"><i class="icon- menu-icons"></i>Нейронные сети</a></li> <li id="menu-item-116263" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/ai/" title="Искусственный интеллект" class="main-menu-a"><i class="icon- menu-icons"></i>Искусственный интеллект</a></li> <li id="menu-item-116266" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/data-science/" title="Data Science" class="main-menu-a"><i class="icon- menu-icons"></i>Data Science</a></li> <li id="menu-item-116265" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/interface-design-ux/" title="Дизайн интерфейсов и UX" class="main-menu-a"><i class="icon- menu-icons"></i>Дизайн интерфейсов и UX</a></li> <li id="menu-item-116261" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/sysadm/" title="Системное администрирование" class="main-menu-a"><i class="icon- menu-icons"></i>Системное администрирование</a></li> <li id="menu-item-116294" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item divider navigation__dropdown-item"><a href="/" title="&#8212;" class="main-menu-a"><i class="icon- menu-icons"></i>&#8212;</a></li> <li id="menu-item-116291" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="#tagsModal" title="Все темы" class="main-menu-a"><i class="icon- menu-icons"></i>Все темы</a></li>
</ul>
</li><li id="menu-item-116269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Языки" class="main-menu-a"><i class="icon-menu-terminal menu-icons"></i>Языки<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116272" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/python/" title="Python" class="main-menu-a"><i class="icon- menu-icons"></i>Python</a></li> <li id="menu-item-116270" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/javascript/" title="JavaScript" class="main-menu-a"><i class="icon- menu-icons"></i>JavaScript</a></li> <li id="menu-item-116275" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/go/" title="Golang" class="main-menu-a"><i class="icon- menu-icons"></i>Golang</a></li> <li id="menu-item-116276" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/java/" title="Java" class="main-menu-a"><i class="icon- menu-icons"></i>Java</a></li> <li id="menu-item-116273" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/cpp/" title="C++" class="main-menu-a"><i class="icon- menu-icons"></i>C++</a></li> <li id="menu-item-116274" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/c-sharp/" title="C#" class="main-menu-a"><i class="icon- menu-icons"></i>C#</a></li> <li id="menu-item-116277" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/php/" title="PHP" class="main-menu-a"><i class="icon- menu-icons"></i>PHP</a></li> <li id="menu-item-116278" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/css/" title="CSS" class="main-menu-a"><i class="icon- menu-icons"></i>CSS</a></li> <li id="menu-item-116279" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/sql/" title="SQL" class="main-menu-a"><i class="icon- menu-icons"></i>SQL</a></li> <li id="menu-item-136633" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/swift/" title="Swift" class="main-menu-a"><i class="icon- menu-icons"></i>Swift</a></li> <li id="menu-item-136634" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/c-language/" title="Язык Си" class="main-menu-a"><i class="icon- menu-icons"></i>Язык Си</a></li> <li id="menu-item-136635" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/asm/" title="Язык ассемблера" class="main-menu-a"><i class="icon- menu-icons"></i>Язык ассемблера</a></li> <li id="menu-item-136636" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/r-language/" title="Язык R" class="main-menu-a"><i class="icon- menu-icons"></i>Язык R</a></li> <li id="menu-item-136637" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/objective-c/" title="Оbjective-С" class="main-menu-a"><i class="icon- menu-icons"></i>Оbjective-С</a></li> <li id="menu-item-136638" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/perl/" title="Perl" class="main-menu-a"><i class="icon- menu-icons"></i>Perl</a></li> <li id="menu-item-136639" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/dot-net/" title=".NET" class="main-menu-a"><i class="icon- menu-icons"></i>.NET</a></li> <li id="menu-item-136640" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/django/" title="Django" class="main-menu-a"><i class="icon- menu-icons"></i>Django</a></li> <li id="menu-item-136641" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/docker/" title="Docker" class="main-menu-a"><i class="icon- menu-icons"></i>Docker</a></li> <li id="menu-item-136642" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/mysql/" title="MySQL" class="main-menu-a"><i class="icon- menu-icons"></i>MySQL</a></li> <li id="menu-item-136643" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/node-js/" title="Node.js" class="main-menu-a"><i class="icon- menu-icons"></i>Node.js</a></li> <li id="menu-item-136644" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/react/" title="React" class="main-menu-a"><i class="icon- menu-icons"></i>React</a></li> <li id="menu-item-136645" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/webassembly/" title="WebAssembly" class="main-menu-a"><i class="icon- menu-icons"></i>WebAssembly</a></li>
</ul>
</li>
<li class="hide-on-desktop dropdown menu-item">
<a href="/ad/" class="main-menu-a main-menu__advertising">Реклама на tproger.ru</a>
</li>
<li class="hide-on-desktop last-main-menu menu-item">
<span class="main-menu-a">Контакты для сотрудничества:</span>
 <span class="main-menu-a">Телефон:&nbsp;<a href="tel:+7 916 559-71-10">+7 916 559-71-10</a></span>
<span class="main-menu-a">E-mail:&nbsp;<a href="mailto:sales@tproger.ru">sales@tproger.ru</a></span>
</li>
</ul> </div>
<a href="/search/" class="search-button header-item header-clickable icon-search" title="Поиск по сайту"></a>
</div>
<div id="header-logo">
<a id="main-logo" class="header-item header-clickable" href="https://tproger.ru"> <img src="/wp-content/themes/bliss/assets/img/logo.svg" alt="Логотип Tproger" width="30" height="30">
<span id="logo-text" class="hide-on-mobile hide-on-narrow">Tproger</span>
</a> </div>
<div class="header-right">

<div id="place-button" class="place-button__container">
<a href="/editor/?utm_source=desktop-header-button" class="place-button__editor" alt="Написать пост">
<i class="icon-edit"></i>
<div class="place-button__text">
Написать пост
</div>
</a>
<div class="place-button__separator"></div>
<span class="place-button__group" tabindex="0">
<i class="icon-angle-down"></i>
</span>
<ul class="place-button__popup">
<a href="/jobs/add/?utm_source=post_button" class="place-button__vacancy place-button__container" alt="Разместить вакансию">
<i class="icon-menu-job"></i>
<div class="place-button__text">
Разместить вакансию
</div>
</a>
</ul>
</div>
<a href="/search/" class="search-button header-item header-clickable icon-search" title="Поиск по сайту"></a>
<a id="notification-button" class="notifications__header header-item header-clickable">
<i class="icon-notification"></i>
<span class="notifications__header--count" style="display:none">0</span>
</a>
<a id="tproger-login-button" class="header-item hoverable">
<img alt="Иконка юзера" src="/wp-content/themes/bliss/assets/img/icon-user.svg">
<span class="hide-on-mobile">Войти</span>
</a>
</div>
</nav>
<div class="search">
<div class="search__container">
<form method="get" action="/search" class="search__form">
<input name="searchid" type="hidden" value="2415386">
<input name="text" maxlength="128" class="search__input" placeholder="Поиск по сайту">
<input name="web" type="hidden" value="0">
<button class="search__submit icon-search hoverable" type="submit"></button>
</form>
<div class="search__header">Популярные темы</div>
<div class="search__popular">
<a class="search__popular_link" href="/tag/python/">Python</a><a class="search__popular_link" href="/tag/cpp/">С++</a><a class="search__popular_link" href="/tag/javascript/">JavaScript</a><a class="search__popular_link" href="/tag/web/">Web-разработка</a><a class="search__popular_link" href="/problems/">Задачи с разбором</a><a class="search__popular_link" href="/tag/gamedev/">Разработка игр</a><a class="search__popular_link" href="/quiz/">Тесты и викторины</a><a class="search__popular_link" href="/tag/for-beginners/">Для начинающих</a> </div>
</div>
</div>
</div>
<div class="header-searchbox" id="searchbox" style="display: none;">
<form method="get" action="/search">
<div class="header-searchbox-input-wrapper">
<input name="searchid" type="hidden" value="2415386">
<input name="text" maxlength="128" class="header-searchbox-input" placeholder="Что ищем?">
<input name="web" type="hidden" value="0">
<span class="header-searchbox-input-cancel icon-close"></span>
</div>
</form>
</div>
</header>


<div id="main" class="windowed">
<div id="primary" class="row right_side">
<div id="content" role="main">
<article id="post-187373" class="box single post-187373 jobs type-jobs status-publish has-post-thumbnail hentry jobs_skills-javascript jobs_skills-jquery jobs_skills-reactjs jobs_skills-spa jobs_skills-typescript jobs_category-frontend">
<div class="post-title">
<h1 class="entry-title">Senior Frontend Developer</h1>
<div class="vacancy-meta vacancy-meta__salary">От 250&thinsp;000&nbsp;₽</div><div class="vacancy-meta"><span class="vacancy-meta__company"><a href="https://tproger.ru/company/abbyy/" class="vacancy-meta__company-link"><img width="20" height="20" class="vacancy-meta__company-image" src="https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-90x90.png" alt="ABBYY" />ABBYY</a>, </span><span class="vacancy-meta__locations">Москва, можно удалённо</span>, <span class="vacancy-meta__experience is__lowercase">опыт от 3 лет</span><span class="vacancy-meta__employment-type">, full-time</span></div> <div class='post-actions' id='job-post-action-buttons'><button class="tproger-button post-action vacancy-candidate-form-send-button__meta">Откликнуться</button><a href="#" class="job-meta-actions-quick-button" class="btn bluth tproger post-action post-action-no-border"><i class="icon-rocket icon-in-btn"></i><span>Быстрый отклик</span></a><span style="display:none;" class="vacancy-candidate-form-resend-button__meta-block">Вы отправили отклик на эту вакансию. Хотите <a href="#" class="vacancy-candidate-form-resend-button__meta">отправить ещё один</a>?</span></div> </div>
<div class="entry-image" style="background-color: #D498C5">
<img src="https://tproger.ru/s3/uploads/2021/12/Background1-880x308.png" srcset="https://tproger.ru/s3/uploads/2021/12/Background1-330x116.png 330w, https://tproger.ru/s3/uploads/2021/12/Background1-670x235.png 670w, https://tproger.ru/s3/uploads/2021/12/Background1-970x340.png 970w, https://tproger.ru/s3/uploads/2021/12/Background1-880x308.png 880w, https://tproger.ru/s3/uploads/2021/12/Background1-1760x617.png 1760w, https://tproger.ru/s3/uploads/2021/12/Background1-720x252.png 720w, https://tproger.ru/s3/uploads/2021/12/Background1-1080x378.png 1080w, https://tproger.ru/s3/uploads/2021/12/Background1-660x231.png 660w, https://tproger.ru/s3/uploads/2021/12/Background1-726x254.png 726w, https://tproger.ru/s3/uploads/2021/12/Background1.png 1941w" sizes="(min-width: 1320px) 880px, (min-width: 977px) 620px, (min-width: 481px) calc(100vw - 40px), 100vw" alt="Обложка: Senior Frontend Developer" itemprop="image url" class="wp-post-image skip-lazy" decoding="async"> </div>
<div class="entry-container">
<div class="entry-content single-job-content-container">
<h2>Требования, необходимые навыки</h2>
<ul>
<li>Опыт разработки на JavaScript / TypeScript на менее 3-х лет;</li>
<li>Умение спроектировать подсистему продукта и аргументировать свое решение;</li>
<li>Отличное знание React + Redux, jQuery, Razor templates;</li>
<li>Понимание принципов работы SPA.</li>
</ul>
<h3>Будет плюсом</h3>
<ul>
<li>Опыт работы с Knockout и Angular ;</li>
<li>Знание .NET Core, .NET Framework, C# 7+;</li>
<li>Знание ASP .NET Core, ASP. NET, Azure functions;</li>
<li>Опыт работы с Mongo;</li>
<li>Опыт разработки и масштабирования; высоконагруженных веб-сервисов;</li>
<li>Опыт формирования архитектуры облачных решений.</li>
</ul>
<h2>Задачи</h2>
<ul>
<li>Разработка (новые фичи в рамках продукта + поддержка и доработка существующих);</li>
<li>Улучшение существующих решений для поддержания отказоустойчивости и предотвращения инцидентов;</li>
<li>Участие в выборе подходящих технологий для развития решения;</li>
<li>Взаимодействие с product-менеджерами и инженерами из соседних команд.</li>
</ul>
<h2>Условия работы</h2>
<ul>
<li>ДМС со стоматологией, полис выезжающих за рубеж;</li>
<li>Возможность работать удаленно;</li>
<li>Обучение: внешнее и внутреннее, сертификации, английский язык, Linkedin Learning;</li>
<li>Своя парковка на территории технопарка;</li>
<li>Гибкое начало дня;</li>
<li>Премии по результатам работы;</li>
<li>Активности: беговой клуб, спортивные команды, йога;</li>
<li>Тимбилдинги и просто уютные командные посиделки;</li>
<li>Оформление по ТК, белая заработная плата.</li>
</ul>
<div id="article-end-beacon"></div>
<div class="job-quick-response-form__block"><div class="cards-anchor"><div id="job-reply-quick"></div></div><div class="job-quick-response-form__title">Быстрый отклик</div><div class="job-quick-response-form__content"><div><div id="quick_response_candidate_form"><div class="job-quick-response-form-block"><div class="job-quick-response-form-input-block"><div class="job-quick-response-form__progress" style="display:none;">Идет отправка...</div><div class="job-quick-response-form-input__email-block"><input type="text" placeholder="E-mail" class="job-quick-response-form-email-input"><div class="icon-right job-quick-send-button"></div></div><div class="job-quick-response-form-error-message"></div><div class="checkbox-item candidate-agree__checbox-item job-quick-form-candidate-agree__checbox-item"><input type="checkbox" class="job-quick-response-form-agree-input" id="quick-form-candidate-agree" />
<label for="quick-form-candidate-agree" class="candidate-agree__label"><span></span>Я соглашаюсь на передачу персональных данных согласно <a href="https://tproger.ru/wp-content/uploads/custom/privacy.pdf" target="_blank">политике конфиденциальности</a> и <a href="https://tproger.ru/wp-content/uploads/custom/terms.pdf" target="_blank">пользовательскому соглашению</a>
</label>
<span class="candidate-agree__error error job-quick-response-form-error-message_agree" style="display: none;"></span>
</div></div></div><div class="job-quick-response-form__after" style="display:none;">Спасибо! С вами свяжутся. Если найдется время, заполните и <a href="#job-reply" onclick="document.getElementById('job-reply').scrollIntoView({block:'start',behavior:'smooth'}); return false;">большую форму отклика</a> тоже. Так у вас будет больше шансов.</div><div class="job-quick-response-form__issend" style="display:none;"> Вы уже отправляли быстрый отклик на эту вакансию. Уверены, что хотите <a class="job-quick-response-form-resend-button">отправить ещё один</a>? Если у вас есть пара минут, лучше заполните <a href="#job-reply">большую форму отклика</a>. Так у вас будет больше шансов. </div></div></div></div></div> </div>
</div>
</article>
<article id="job-reply" class="box vacancy-candidate-form"><div class="vacancy-candidate-form__loading"></div><div class="post-title"><h2 class="entry-title vacancy-full-form-title">Заявка на личную беседу</h2></div><div class="entry-container"><div class="entry-content vacancy-candidate-form__content"><div class="candidate-form-fields__lk-buttons"><button href="#" class="lk-response-button login tproger-button outlined" id="login-profile-link">Подставить данные из профиля</button></div><div class="candidate-form-fields">
<div class="candidate-form-field"><div class="candidate-name__field"><label>Как вас зовут?*</label><input type="text" autocomplete="name" class="candidate-name" /></div><span class="candidate-name__error error" style="display: none;"></span></div>
<div class="candidate-form-field"><div class="candidate-email__field"><label>Ваш E-mail* </label><input type="text" autocomplete="email" class="candidate-email" /></div><span class="candidate-email__error error" style="display: none;"></span></div>
</div><div class="candidate-form-fields candidate-form-fields__about">
<div class="candidate-form-field"><div class="candidate-about__field">
<label>Сопроводительное письмо*</label>
<textarea class="candidate-about" rows="9" placeholder="Желательно указать, где ранее учились и работали, почему ушли с последнего места работы, что знаете и умеете, какими технологиями владеете, чем увлекаетесь и любые другие сведения, который могут быть полезны" autocomplete="on"></textarea>
</div><span class="candidate-about__error error" style="display: none;"></span></div>
</div><div class="candidate-form-fields"><div class="candidate-form-field"><p><label>Телефон или ссылка на мессенджер</label> <input type="text" autocomplete="tel-national" class="candidate-contact" /></p></div><div class="candidate-form-field"><p><label>Ссылка на формальное резюме</label><input type="text" class="candidate-resume" autocomplete="on" /></p></div></div><div class="candidate-form-fields__submit">
<div class="candidate-form-field"><button class="tproger-button submit-candidate-button">Отправить заявку</button></div>
<div class="candidate-form-field"><div class="loading-text" style="display:none;">Пожалуйста, подождите, отправляем данные<span class="loading-dots"></span></div></div>
</div><div class="checkbox-item"><input id="candidate-savefields__label" type="checkbox" class="candidate-savefields" title="Сохранить данные в личном кабинете" /><label class="candidate-savefields__label" for="candidate-savefields__label"><span></span> Сохранить данные в личном кабинете </label></div><div class="checkbox-item candidate-agree__checbox-item"><input type="checkbox" class="candidate-agree" id="candidate-agree" />
<label for="candidate-agree" class="candidate-agree__label"><span></span>Я соглашаюсь на передачу персональных данных согласно <a href="https://tproger.ru/wp-content/uploads/custom/privacy.pdf" target="_blank">политике конфиденциальности</a> и <a href="https://tproger.ru/wp-content/uploads/custom/terms.pdf" target="_blank">пользовательскому соглашению</a>
</label>
<span class="candidate-agree__error error" style="display: none;"></span>
 </div></div><div class="entry-content vacancy-candidate-form-resend-button__block" style="display:none;"><p>Вы уже отправили заявку на личную беседу. Уверены, что хотите <a href="#" class="vacancy-candidate-form-resend-button">отправить ещё одну</a>?</p></div></div></article>
</div>
<aside id="side-bar" data-container-loaded="no" data-container-loaded-callback="sideBarInit" data-container-loaded-max-seconds="10" class="widget-area">
<div id="sidebar__inner">
<div class="box widget-about-company"><a href="https://tproger.ru/company/abbyy/"><img width="90" height="90" src="https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-90x90.png" class="widget-img widget-company-logo" alt="ABBYY" title="ABBYY" sizes="70px" srcset="https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo.png 300w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-150x150.png 150w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-90x90.png 90w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-50x50.png 50w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-32x32.png 32w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-16x16.png 16w" data-id="184620"></a><div class="widget-caption"><a class="widget-caption-a hoverable" href="https://tproger.ru/company/abbyy/">ABBYY</a></div><div class="widget-text small"></div><div class="about-company-jobs"><div class="about-company-jobs-list"><hr>
<div class="about-company-jobs-item-last-jobs">
<div class="about-company-jobs-info-last-jobs-info">
<div class="about-company-jobs-title" title="Senior Frontend Developer"><a href="https://tproger.ru/jobs/senior-frontend-developer-2/">Senior Frontend Developer</a></div>
</div>
</div><hr>
<div class="about-company-jobs-item-last-jobs">
<div class="about-company-jobs-info-last-jobs-info">
<div class="about-company-jobs-title" title="Software Developer (С++)"><a href="https://tproger.ru/jobs/software-developer-s/">Software Developer (С++)</a></div>
</div>
</div><hr>
<div class="about-company-jobs-item-last-jobs">
<div class="about-company-jobs-info-last-jobs-info">
<div class="about-company-jobs-title" title="Team Lead (C++ / ML)"><a href="https://tproger.ru/jobs/team-lead-c-ml/">Team Lead (C++ / ML)</a></div>
</div>
</div></div></div><a href="https://tproger.ru/company/abbyy/#jobs&utm_source=tproger_ru_right_banner" class="widget-button-bottom subscribe-button-widget-end">Все вакансии компании</a></div> <div id="right_event_job_widget-20" data-type="5" data-wtype="sidebar" data-btn-title="Все вакансии" data-btn-url="/jobs" data-utm="banner-right-vacancy&utm_medium=job" data-rbtn-title="" data-rbtn-url="" data-job class="box tproger-event-job-widget subscription-widget nopadding widget-sidebar-type" style="width:100%;"><div class="widget-list"><a href="https://tproger.ru/jobs/frontend-developer-2/?utm_source=banner-right-vacancy&utm_medium=job"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1.png 521w, https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1-330x330.png 330w, https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1-150x150.png 150w, https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1-90x90.png 90w, https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1-50x50.png 50w, https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1-32x32.png 32w, https://tproger.ru/s3/uploads/2021/11/ec3e5f97-5576-4713-b252-a6120dbc7745-1-16x16.png 16w" data-sizes="30px" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Frontend Developer</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/software-developer-s/?utm_source=banner-right-vacancy&utm_medium=job"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo.png 300w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-150x150.png 150w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-90x90.png 90w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-50x50.png 50w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-32x32.png 32w, https://tproger.ru/s3/uploads/2021/10/ABBYY-Logo-16x16.png 16w" data-sizes="30px" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Software Developer (С++)</div><div class="widget-list-item-caption__salary">От 250&thinsp;000&nbsp;₽</div><div class="widget-list-description"><span class="meta-text-description__locations">Москва, можно удалённо</span>, <span class="meta-text-description__employment-type">part- или full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/frontend-developer-react-js/?utm_source=banner-right-vacancy&utm_medium=job"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/11/3072025-copy-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/11/3072025-copy.png 200w, https://tproger.ru/s3/uploads/2021/11/3072025-copy-150x150.png 150w, https://tproger.ru/s3/uploads/2021/11/3072025-copy-90x90.png 90w, https://tproger.ru/s3/uploads/2021/11/3072025-copy-50x50.png 50w, https://tproger.ru/s3/uploads/2021/11/3072025-copy-32x32.png 32w, https://tproger.ru/s3/uploads/2021/11/3072025-copy-16x16.png 16w" data-sizes="30px" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Frontend developer (React.js)</div><div class="widget-list-item-caption__salary">От 100&thinsp;000 до 200&thinsp;000&nbsp;₽</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">part- или full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/frontend-razrabotchik-vue/?utm_source=banner-right-vacancy&utm_medium=job"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2019/09/sm_lab-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2019/09/sm_lab.png 1080w, https://tproger.ru/s3/uploads/2019/09/sm_lab-150x150.png 150w, https://tproger.ru/s3/uploads/2019/09/sm_lab-280x280.png 280w, https://tproger.ru/s3/uploads/2019/09/sm_lab-670x670.png 670w, https://tproger.ru/s3/uploads/2019/09/sm_lab-90x90.png 90w, https://tproger.ru/s3/uploads/2019/09/sm_lab-50x50.png 50w, https://tproger.ru/s3/uploads/2019/09/sm_lab-970x970.png 970w, https://tproger.ru/s3/uploads/2019/09/sm_lab-720x720.png 720w, https://tproger.ru/s3/uploads/2019/09/sm_lab-660x660.png 660w, https://tproger.ru/s3/uploads/2019/09/sm_lab-726x726.png 726w, https://tproger.ru/s3/uploads/2019/09/sm_lab-32x32.png 32w, https://tproger.ru/s3/uploads/2019/09/sm_lab-16x16.png 16w" data-sizes="30px" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Frontend-разработчик (Vue)</div><div class="widget-list-description"><span class="meta-text-description__locations">Санкт-Петербург, Москва, Краснодар, можно удалённо</span>, <span class="meta-text-description__employment-type">от 40 часов в неделю</span></div></div></div></a><a href="https://tproger.ru/jobs/senior-frontend-engineer/?utm_source=banner-right-vacancy&utm_medium=job"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square.png 1024w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-330x330.png 330w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-150x150.png 150w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-670x670.png 670w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-970x970.png 970w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-880x880.png 880w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-720x720.png 720w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-660x660.png 660w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-726x726.png 726w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-90x90.png 90w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-50x50.png 50w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-32x32.png 32w, https://tproger.ru/s3/uploads/2021/09/cubejs_logo_square-16x16.png 16w" data-sizes="30px" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Senior Frontend Engineer</div><div class="widget-list-item-caption__salary">От 3000&nbsp;$</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">full-time</span></div></div></div></a><div class="widget-list-footer"><a href="/jobs?utm_source=banner-right-vacancy" class="show-more-widget hoverable">Все вакансии<span class="icon-right-open vertical-middle"></span></a></div></div></div><div id="bl_html-33" class="box side widget bl_html"> <div class="widget-body"><p style="font-size: 16px; margin-bottom: 0; line-height: 1.55;">Разместим вакансию вашей компании:<br>
<a href="mailto:sales@tproger.ru">sales@tproger.ru</a>,
<a href="tel:+79165597110">+7 916 559-71-10</a></p>
<a class="widget-button-bottom" href="/ad/jobs/?utm_referrer=sidebar#offer">Узнать подробнее</a></div>
</div> </div>
</aside>
</div>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@graph":[{"@type":"JobPosting","title":"Senior Frontend Developer","description":"\u0422\u0440\u0435\u0431\u043e\u0432\u0430\u043d\u0438\u044f, \u043d\u0435\u043e\u0431\u0445\u043e\u0434\u0438\u043c\u044b\u0435 \u043d\u0430\u0432\u044b\u043a\u0438 \u041e\u043f\u044b\u0442 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u043d\u0430 JavaScript \/ TypeScript \u043d\u0430 \u043c\u0435\u043d\u0435\u0435 3-\u0445 \u043b\u0435\u0442; \u0423\u043c\u0435\u043d\u0438\u0435 \u0441\u043f\u0440\u043e\u0435\u043a\u0442\u0438\u0440\u043e\u0432\u0430\u0442\u044c \u043f\u043e\u0434\u0441\u0438\u0441\u0442\u0435\u043c\u0443 \u043f\u0440\u043e\u0434\u0443\u043a\u0442\u0430 \u0438 \u0430\u0440\u0433\u0443\u043c\u0435\u043d\u0442\u0438\u0440\u043e\u0432\u0430\u0442\u044c \u0441\u0432\u043e\u0435 \u0440\u0435\u0448\u0435\u043d\u0438\u0435; \u041e\u0442\u043b\u0438\u0447\u043d\u043e\u0435 \u0437\u043d\u0430\u043d\u0438\u0435 React + Redux, jQuery, Razor templates; \u041f\u043e\u043d\u0438\u043c\u0430\u043d\u0438\u0435\u2026","datePosted":"2021-12-01","validThrough":"2021-12-31","employmentType":"FULL_TIME","jobLocation":{"@type":"Place","address":[{"@type":"PostalAddress","streetAddress":"\u041c\u043e\u0441\u043a\u0432\u0430","addressLocality":"\u041c\u043e\u0441\u043a\u0432\u0430","addressRegion":"\u041c\u043e\u0441\u043a\u0432\u0430","postalCode":"\u041c\u043e\u0441\u043a\u0432\u0430","addressCountry":"\u041c\u043e\u0441\u043a\u0432\u0430"}]},"baseSalary":{"@type":"MonetaryAmount","currency":"RUB","value":{"@type":"QuantitativeValue","unitText":"MONTH","value":250000}},"hiringOrganization":{"@type":"Organization","name":"ABBYY","sameAs":"https:\/\/tproger.ru\/company\/abbyy\/","logo":"https:\/\/tproger.ru\/s3\/uploads\/2021\/10\/ABBYY-Logo-90x90.png"}},{"@type":"BreadcrumbList","itemListElement":{"@type":"ListItem","position":1,"item":{"@id":"jobs","name":"https:\/\/tproger.ru\/jobs\/"}}}]}</script> </div>
<div id="errors-popup">
<div class="errors-popup__cover"></div>
<div class="errors-popup__modal">
<div class="errors-popup__close">
<span class="errors-popup__close-button icon-close"></span>
</div>
<div class="errors-popup__title icon-info">Сообщить об ошибке</div>
<div class="errors-popup__setting">
<b class="errors-popup__heading">Как нам повторить баг?</b>
<textarea class="errors-popup__textarea" name="arrange" placeholder="Максимально опишите окружение происходящего: ОС, браузер и т.д."></textarea>
<b class="errors-popup__heading">Опишите баг</b>
<textarea class="errors-popup__textarea" name="actual" placeholder="Расскажите, что именно происходит. Если есть возможность, сделайте скриншоты или запишите видео. Залейте их куда-нибудь и пришлите ссылку."></textarea>
<b class="errors-popup__heading">Ожидание</b>
<textarea class="errors-popup__textarea" name="assert" placeholder="Расскажите, как, по-вашему, это должно было работать."></textarea>
</div>
<div class="errors-popup__submit-button hoverable">Отправить</div>
</div>
</div>
<div id="cookie-notice-wrapper" style="display:none">
<div id="cookie-notice"><span class="cookie-notice-text">Обычное дело: мы используем cookie.</span> <a href="/about/cookie/" target="_blank" class="cookie-notice-about">Здесь&nbsp;можно&nbsp;узнать,&nbsp;зачем</a></div>
<div class="btn bluth tproger cookie-notice-close">Хорошо</div>
</div>
<footer id="footer" class="show-on-idle">
<div id="footer-body" class="windowed">
<div class="textwidget custom-html-widget">
<div><span class='footer-header'>Типичный программист</span> <div id="subscribe-wrapper">
<a href="javascript:void(0)" id="subscribe-link"><i class="icon-bell"></i> Включить
уведомления</a>
</div>
<div id="errors-popup-opener">
<span class="errors-popup-opener__text"><i class="icon-info"></i> Нашли баг на сайте?</span>
</div>
<a href="/company/tproger/#about" class="footer-a">О&nbsp;проекте</a>
<a href="/ad/?utm_referrer=footer" class="footer-a">Реклама</a>
</div>
<div class="footer-dark-a-wrapper"><a href="https://tproger.ru/terms.pdf" class="footer-dark-a">Пользовательское&nbsp;соглашение</a><a href="https://tproger.ru/privacy.pdf" class="footer-dark-a">Политика&nbsp;конфиденциальности</a>
</div>
<div class="footer-dark-a-wrapper footer-with-logo"><a href="https://tprg.ru/regru-footer" class="footer-dark-a" data-wpel-link="external" target="_blank" rel="nofollow noopener noreferrer">Используем&nbsp;серверы&nbsp;
<img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;57px&quot; viewBox=&quot;0 0 57 28&quot;%3E%3C/svg%3E" class="footer-sponsor-img lazy" width="57" height="28" alt="Логотип REG.RU" data-src="https://tproger.ru/s3/uploads/custom/regru-logo.svg" decoding="async"></a>
</div>
</div>
<div class="textwidget custom-html-widget">
<span class="footer-header">Наши аккаунты</span>
<span class="social-footer" itemscope itemtype="http://schema.org/Organization">
<meta itemprop="logo" content="https://cdn.tproger.ru/android-chrome-32x32.png">
<meta itemprop="url" content="https://tproger.ru">
<meta itemprop="name" content="Tproger">
<link itemprop="url" href="https://tproger.ru/">
<a class="social-footer-a footer-dark-icon-a icon-vkontakte" itemprop="sameAs" target="_blank" rel="nofollow noopener noreferrer" href="https://tprg.ru/51rP"></a>
<a class="social-footer-a footer-dark-icon-a icon-facebook" itemprop="sameAs" target="_blank" rel="nofollow noopener noreferrer" href="https://tprg.ru/WAil"></a>
<a class="social-footer-a footer-dark-icon-a icon-twitter" itemprop="sameAs" target="_blank" rel="nofollow noopener noreferrer" href="https://tprg.ru/pt0n"></a>
<a class="social-footer-a footer-dark-icon-a icon-telegram" itemprop="sameAs" target="_blank" rel="nofollow noopener noreferrer" href="https://tprg.ru/LaYn"></a>
<a class="social-footer-a footer-dark-icon-a icon-yazen" itemprop="sameAs" target="_blank" rel="nofollow noopener noreferrer" href="https://tprg.ru/5WAl"></a>
<a class="social-footer-a footer-dark-icon-a icon-rss" target="_blank" rel="nofollow noopener noreferrer" href="https://tproger.ru/feed/"></a>
</span>
<div class="footer-dark-a-wrapper">
<div class="channel_link"><a href="https://tprg.ru/6ZHe" target="_blank" rel="nofollow noopener noreferrer" class="footer-dark-a">
<i class="icon-telegram"></i> Веб-разработка</a></div>
 <div class="channel_link"><a href="https://tprg.ru/PUT3" target="_blank" rel="nofollow noopener noreferrer" class="footer-dark-a">
<i class="icon-telegram"></i> Python-разработка</a></div>
</div>
<span id="mistape-widget-message">
Нашли опечатку? Выделите фрагмент и отправьте нажатием Ctrl+Enter.
</span>
</div>
<div class="textwidget custom-html-widget">
<div class="footer-contacts"><span class="footer-header">Контакты для сотрудничества</span>
<span>Телефон: <a class="footer-a" href="tel:+79165597110">+7 916 559-71-10</a></span>
<span>E-mail: <a class="footer-a" href="mailto:sales@tproger.ru">sales@tproger.ru</a></span>
</div>
</div>
</div>
<div id="wrapfabtest">
<div class="adBanner"></div>
</div>
</footer>
</div>
<script>
window.ym=window.ym||function(){(ym.a=ym.a||[]).push(arguments)};ym.l=1*new Date();
ym(27485085, "init", {clickmap: true, trackLinks: true, accurateTrackBounce: true, webvisor: false});
</script>
<script type="text/javascript" src="https://proxy.tproger.ru/yandex-metrika.js" async></script>
<noscript><div><img src="https://mc.yandex.ru/watch/27485085" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://tproger.ru/",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://tproger.ru/search/?searchid=2415386&text={search_term_string}&web=0",
    "query-input": "required name=search_term_string"
  }
}
</script>
<div style="display:none;" class="tproger-elevator-block" id="tproger-elevator">
<div id="tproger-arrow" class="elevator-arrow icon-up-open"></div>
</div>
<script>var OneSignal = window.OneSignal || [];</script>
<script type="text/javascript" src="https://proxy.tproger.ru/vk-openapi.js" onload="window.setupVK && window.setupVK()" defer></script>
<script type="text/javascript" src="https://proxy.tproger.ru/onesignal-sdk.js" onload="window.setupOneSignal && window.setupOneSignal()" async="async"></script>
<script type="module" src="/wp-content/themes/bliss/assets/js/instant-page.x96615.js"></script><script>
	window.ta=window.ta||function(){(ta.q=ta.q||[]).push([new Date,...arguments])};
	ta('pageview', 3, { pageReferrer: document.referrer });	</script><script>var widgetsNonce='096e4fdfbb';</script> <script>
	  		!function(){if('PerformanceLongTaskTiming' in window){var g=window.__tti={e:[]};
	  		g.o=new PerformanceObserver(function(l){g.e=g.e.concat(l.getEntries())});
	  		g.o.observe({entryTypes:['longtask']})}}();
	  		</script> <div id="tagsModal" style="display:none">
<div class="closebt-container close-tagsModal">
<img class="closebt lazy" alt="Закрыть" data-src="/wp-content/themes/bliss/assets/img/close-modal.svg" decoding="async"> </div>
<div class="modal-container widget_tag_cloud">
<div class="modal-tag-cloud tagcloud">
<div class="tag-category" data-tag="brands"><h3>По брендам</h3><a class="tag-a" href='/tag/adobe/'>Adobe</a><a class="tag-a" href='/tag/amazon/'>Amazon</a><a class="tag-a" href='/tag/apple/'>Apple</a><a class="tag-a" href='/tag/cloudflare/'>Cloudflare</a><a class="tag-a" href='/tag/facebook/'>Facebook</a><a class="tag-a" href='/tag/github/'>GitHub</a><a class="tag-a" href='/tag/gitlab/'>GitLab</a><a class="tag-a" href='/tag/google/'>Google</a><a class="tag-a" href='/tag/ibm/'>IBM</a><a class="tag-a" href='/tag/intel/'>Intel</a><a class="tag-a" href='/tag/jetbrains/'>JetBrains</a><a class="tag-a" href='/tag/microsoft/'>Microsoft</a><a class="tag-a" href='/tag/mit/'>MIT</a><a class="tag-a" href='/tag/mozilla/'>Mozilla</a><a class="tag-a" href='/tag/nvidia/'>NVIDIA</a><a class="tag-a" href='/tag/oracle/'>Oracle</a><a class="tag-a" href='/tag/samsung/'>Samsung</a><a class="tag-a" href='/tag/stack-overflow/'>Stack Overflow</a><a class="tag-a" href='/tag/telegram/'>Telegram</a><a class="tag-a" href='/tag/windows/'>Windows</a><a class="tag-a" href='/tag/vkontakte/'>ВКонтакте</a><a class="tag-a" href='/tag/rkn/'>Роскомнадзор</a><a class="tag-a" href='/tag/yandex/'>Яндекс</a></div><div class="tag-category" data-tag="fields"><h3>По направлениям</h3><a class="tag-a" href='/tag/big-data/'>Big Data</a><a class="tag-a" href='/tag/data-science/'>Data Science</a><a class="tag-a" href='/tag/devops/'>DevOps</a><a class="tag-a" href='/tag/hardware/'>Hardware</a><a class="tag-a" href='/tag/hr/'>HR</a><a class="tag-a" href='/tag/bots/'>Боты</a><a class="tag-a" href='/tag/blockchain/'>Блокчейн</a><a class="tag-a" href='/tag/veb-design/'>Веб-дизайн</a><a class="tag-a" href='/tag/web/'>Веб-разработка</a><a class="tag-a" href='/tag/virtual-reality/'>Виртуальная реальность</a><a class="tag-a" href='/tag/interface-design-ux/'>Дизайн интерфейсов и UX</a><a class="tag-a" href='/tag/augmented-reality/'>Дополненная реальность</a><a class="tag-a" href='/tag/iot/'>Интернет вещей</a><a class="tag-a" href='/tag/ai/'>Искусственный интеллект</a><a class="tag-a" href='/tag/quantum-computing/'>Квантовые вычисления</a><a class="tag-a" href='/tag/computer-graphics/'>Компьютерная графика</a><a class="tag-a" href='/tag/computer-vision/'>Компьютерное зрение</a><a class="tag-a" href='/tag/cryptocurrency/'>Криптовалюты</a><a class="tag-a" href='/tag/crypto/'>Криптография</a><a class="tag-a" href='/tag/machine-learning/'>Машинное обучение</a><a class="tag-a" href='/tag/mobiledev/'>Мобильная разработка</a><a class="tag-a" href='/tag/neural-network/'>Нейронные сети</a><a class="tag-a" href='/tag/cloud/'>Облачные технологии</a><a class="tag-a" href='/tag/gamedev/'>Разработка игр</a><a class="tag-a" href='/tag/robots/'>Роботы</a><a class="tag-a" href='/tag/sysadm/'>Системное администрирование</a><a class="tag-a" href='/tag/testing/'>Тестирование</a><a class="tag-a" href='/tag/project-management/'>Управление проектами</a><a class="tag-a" href='/tag/frontend/'>Фронтенд</a><a class="tag-a" href='/tag/math-and-probability/'>Математика и теория вероятностей</a><a class="tag-a" href='/tag/fintech/'>Финтех</a></div><div class="tag-category" data-tag="languages"><h3>По языкам и технологиям</h3><a class="tag-a" href='/tag/cpp/'>C++</a><a class="tag-a" href='/tag/c-sharp/'>C#</a><a class="tag-a" href='/tag/java/'>Java</a><a class="tag-a" href='/tag/javascript/'>JavaScript</a><a class="tag-a" href='/tag/css/'>CSS</a><a class="tag-a" href='/tag/html/'>HTML</a><a class="tag-a" href='/tag/golang/'>Golang</a><a class="tag-a" href='/tag/kotlin/'>Kotlin</a><a class="tag-a" href='/tag/php/'>PHP</a><a class="tag-a" href='/tag/python/'>Python</a><a class="tag-a" href='/tag/ruby/'>Ruby</a><a class="tag-a" href='/tag/ruby-on-rails/'>Ruby on Rails</a><a class="tag-a" href='/tag/rust/'>Rust</a><a class="tag-a" href='/tag/scala/'>Scala</a><a class="tag-a" href='/tag/sql/'>SQL</a><a class="tag-a" href='/tag/swift/'>Swift</a><a class="tag-a" href='/tag/typescript/'>TypeScript</a><a class="tag-a" href='/tag/c-language/'>Язык Си</a><a class="tag-a" href='/tag/asm/'>Язык ассемблера</a><a class="tag-a" href='/tag/r-language/'>Язык R</a><a class="tag-a" href='/tag/lua/'>Lua</a><a class="tag-a" href='/tag/objective-c/'>Objective-C</a><a class="tag-a" href='/tag/perl/'>Perl</a><a class="tag-a" href='/tag/dot-net/'>.NET</a><a class="tag-a" href='/tag/django/'>Django</a><a class="tag-a" href='/tag/docker/'>Docker</a><a class="tag-a" href='/tag/mysql/'>MySQL</a><a class="tag-a" href='/tag/node-js/'>Node.js</a><a class="tag-a" href='/tag/react/'>React</a><a class="tag-a" href='/tag/webassembly/'>WebAssembly</a></div><div class="tag-category" data-tag="others"><a class="tag-a" href='/tag/1c-bitrix/'>1C-Bitrix</a><a class="tag-a" href='/tag/3d-printer/'>3D-принтер</a><a class="tag-a" href='/tag/5g/'>5g</a><a class="tag-a" href='/tag/agile/'>Agile</a><a class="tag-a" href='/tag/amd/'>AMD</a><a class="tag-a" href='/tag/android/'>Android</a><a class="tag-a" href='/tag/api/'>API</a><a class="tag-a" href='/tag/app-store/'>App Store</a><a class="tag-a" href='/tag/arduino/'>Arduino</a><a class="tag-a" href='/tag/arm/'>ARM</a><a class="tag-a" href='/tag/asp-net/'>Asp.NET</a><a class="tag-a" href='/tag/bitcoin/'>Bitcoin</a><a class="tag-a" href='/tag/deepmind/'>DeepMind</a><a class="tag-a" href='/tag/diy/'>DIY</a><a class="tag-a" href='/tag/ethereum/'>Ethereum</a><a class="tag-a" href='/tag/f8-2017/'>F8 2017</a><a class="tag-a" href='/tag/firefox/'>Firefox</a><a class="tag-a" href='/tag/fuchsia/'>Fuchsia</a><a class="tag-a" href='/tag/git/'>Git</a><a class="tag-a" href='/tag/google-chrome/'>Google Chrome</a><a class="tag-a" href='/tag/google-io-2017/'>Google I/O 2017</a><a class="tag-a" href='/tag/gtc-2017/'>GTC 2017</a><a class="tag-a" href='/tag/hololens/'>HoloLens</a><a class="tag-a" href='/tag/ide/'>IDE</a><a class="tag-a" href='/tag/ios/'>iOS</a><a class="tag-a" href='/tag/covid-19/'>IT во время чумы</a><a class="tag-a" href='/tag/json/'>JSON</a><a class="tag-a" href='/tag/linux/'>Linux</a><a class="tag-a" href='/tag/macos/'>macOS</a><a class="tag-a" href='/tag/build-2017/'>Microsoft Build 2017</a><a class="tag-a" href='/tag/nosql/'>NoSQL</a><a class="tag-a" href='/tag/open-source/'>Open Source</a><a class="tag-a" href='/tag/openai/'>OpenAI</a><a class="tag-a" href='/tag/opera/'>Opera</a><a class="tag-a" href='/tag/playstation/'>PlayStation</a><a class="tag-a" href='/tag/product-development/'>Product Development</a><a class="tag-a" href='/tag/qa/'>QA</a><a class="tag-a" href='/tag/raspberry-pi/'>Raspberry Pi</a><a class="tag-a" href='/tag/reactjs/'>ReactJS</a><a class="tag-a" href='/tag/redux/'>Redux</a><a class="tag-a" href='/tag/seo/'>SEO</a><a class="tag-a" href='/tag/slack/'>Slack</a><a class="tag-a" href='/tag/soft-skills/'>Soft Skills</a><a class="tag-a" href='/tag/tesla/'>Tesla</a><a class="tag-a" href='/tag/tproger-changelog/'>Tproger Changelog</a><a class="tag-a" href='/tag/twitter/'>Twitter</a><a class="tag-a" href='/tag/unity/'>Unity</a><a class="tag-a" href='/tag/unix/'>unix</a><a class="tag-a" href='/tag/vpn/'>VPN</a><a class="tag-a" href='/tag/wi-fi/'>Wi-Fi</a><a class="tag-a" href='/tag/windows-10/'>Windows 10</a><a class="tag-a" href='/tag/windows-11/'>Windows 11</a><a class="tag-a" href='/tag/wordpress/'>WordPress</a><a class="tag-a" href='/tag/xbox/'>XBox</a><a class="tag-a" href='/tag/youtube/'>YouTube</a><a class="tag-a" href='/tag/avtomatizirovanie/'>Автоматизирование</a><a class="tag-a" href='/tag/autopilot/'>Автопилот</a><a class="tag-a" href='/tag/algorithms/'>Алгоритмы и структуры данных</a><a class="tag-a" href='/tag/alisa/'>Алиса</a><a class="tag-a" href='/tag/analiz-dannyh/'>Анализ данных</a><a class="tag-a" href='/tag/analytics/'>Аналитика</a><a class="tag-a" href='/tag/software-architecture/'>Архитектура ПО</a><a class="tag-a" href='/tag/asinhronnoe-programmirovanie/'>Асинхронное программирование</a><a class="tag-a" href='/tag/bagi-i-oshibki/'>Баги и ошибки</a><a class="tag-a" href='/tag/db/'>Базы данных</a><a class="tag-a" href='/tag/security/'>Безопасность</a><a class="tag-a" href='/tag/safe-code/'>Безопасный код</a><a class="tag-a" href='/tag/autopilot-2/'>Беспилотники</a><a class="tag-a" href='/tag/beta/'>Бета</a><a class="tag-a" href='/tag/biznes-analitika/'>Бизнес-аналитика</a><a class="tag-a" href='/tag/biotechnology/'>Биотехнологии</a><a class="tag-a" href='/tag/browsers/'>Браузеры</a><a class="tag-a" href='/tag/quick-start/'>Быстрый старт</a><a class="tag-a" href='/tag/backend/'>Бэкенд</a><a class="tag-a" href='/tag/vzlom/'>Взлом</a><a class="tag-a" href='/tag/visualization/'>Визуализация</a><a class="tag-a" href='/tag/highload/'>Высокие нагрузки</a><a class="tag-a" href='/tag/brain-teasers/'>Головоломки</a><a class="tag-a" href='/tag/guest-post/'>Гостевая публикация</a><a class="tag-a" href='/tag/for-motivation/'>Для мотивации</a><a class="tag-a" href='/tag/for-beginners/'>Для начинающих</a><a class="tag-a" href='/tag/for-advanced/'>Для продвинутых</a><a class="tag-a" href='/tag/for-amateurs/'>Для продолжающих</a><a class="tag-a" href='/tag/expert-problems/'>Задачи повышенной сложности</a><a class="tag-a" href='/tag/middle-problems/'>Задачи умеренной сложности</a><a class="tag-a" href='/tag/igra/'>Игра</a><a class="tag-a" href='/tag/games/'>Игры для программистов</a><a class="tag-a" href='/tag/ilon-mask/'>Илон Маск</a><a class="tag-a" href='/tag/tools/'>Инструменты</a><a class="tag-a" href='/tag/command-line-tools/'>Инструменты командной строки</a><a class="tag-a" href='/tag/interesting-projects/'>Интересные проекты</a><a class="tag-a" href='/tag/internet/'>Интернет</a><a class="tag-a" href='/tag/kiberbezopasnost/'>Информационная безопасность</a><a class="tag-a" href='/tag/it-history/'>История IT</a><a class="tag-a" href='/tag/success-story/'>История успеха</a><a class="tag-a" href='/tag/career/'>Карьера</a><a class="tag-a" href='/tag/code-style/'>Кодстайл</a><a class="tag-a" href='/tag/compilers/'>Компиляторы</a><a class="tag-a" href='/tag/tproger-contest/'>Конкурс Tproger</a><a class="tag-a" href='/tag/conferences/'>Конференции</a><a class="tag-a" href='/tag/good-hack/'>Красивый хак</a><a class="tag-a" href='/tag/best-practice/'>Лучшая практика</a><a class="tag-a" href='/tag/toplang2020/'>Лучший язык 2020</a><a class="tag-a" href='/tag/mining/'>Майнинг</a><a class="tag-a" href='/tag/marketing/'>Маркетинг</a><a class="tag-a" href='/tag/arrays-and-strings/'>Массивы и строки</a><a class="tag-a" href='/tag/scalability-and-memory-limits/'>Масштабируемость и ограничения памяти</a><a class="tag-a" href='/tag/guest/'>Материалы от друзей Tproger</a><a class="tag-a" href='/tag/messendzher/'>Мессенджер</a><a class="tag-a" href='/tag/software-development/'>Методологии разработки</a><a class="tag-a" href='/tag/microservices/'>Микросервисы</a><a class="tag-a" href='/tag/multithreading/'>Многопоточность</a><a class="tag-a" href='/tag/music/'>Музыка</a><a class="tag-a" href='/tag/english/'>На английском языке</a><a class="tag-a" href='/tag/skills/'>Навыки</a><a class="tag-a" href='/tag/low-level-coding/'>Низкоуровневое программирование</a><a class="tag-a" href='/tag/new-year/'>Новый Год</a><a class="tag-a" href='/tag/obrazovanie/'>Образование</a><a class="tag-a" href='/tag/courses/'>Обучающие курсы</a><a class="tag-a" href='/tag/learn-programming/'>Обучение программированию</a><a class="tag-a" href='/tag/oop/'>Объектно-ориентированное программирование</a><a class="tag-a" href='/tag/competitive-programming/'>Олимпиадное программирование</a><a class="tag-a" href='/tag/operating-systems/'>Операционные системы</a><a class="tag-a" href='/tag/poll/'>Опрос</a><a class="tag-a" href='/tag/optimization/'>Оптимизация</a><a class="tag-a" href='/tag/dev-organising/'>Организация разработки</a><a class="tag-a" href='/tag/programming-concepts/'>Основные принципы программирования</a><a class="tag-a" href='/tag/debugging/'>Отладка</a><a class="tag-a" href='/tag/pavel-durov/'>Павел Дуров</a><a class="tag-a" href='/tag/parsing/'>Парсинг</a><a class="tag-a" href='/tag/partnered/'>Партнёрский материал</a><a class="tag-a" href='/tag/design-patterns/'>Паттерны проектирования</a><a class="tag-a" href='/tag/personalnye-dannye/'>Персональные данные</a><a class="tag-a" href='/tag/plany-obuchenija/'>Планы обучения</a><a class="tag-a" href='/tag/ugc/'>Пост пользователя</a><a class="tag-a" href='/tag/prilozhenie/'>Приложение</a><a class="tag-a" href='/tag/performance/'>Производительность</a><a class="tag-a" href='/tag/processor/'>Процессор</a><a class="tag-a" href='/tag/job/'>Работа</a><a class="tag-a" href='/tag/recognition/'>Распознавание</a><a class="tag-a" href='/tag/reactive/'>Реактивное программирование</a><a class="tag-a" href='/tag/retro/'>Ретро</a><a class="tag-a" href='/tag/rossija/'>Россия</a><a class="tag-a" href='/tag/server/'>Сервер</a><a class="tag-a" href='/tag/services/'>Сервисы</a><a class="tag-a" href='/tag/network-protocols/'>Сетевые протоколы</a><a class="tag-a" href='/tag/job-interview/'>Собеседование</a><a class="tag-a" href='/tag/advices/'>Советы</a><a class="tag-a" href='/tag/social-networks/'>Социальные сети</a><a class="tag-a" href='/tag/startups/'>Стартапы</a><a class="tag-a" href='/tag/statistics/'>Статистика</a><a class="tag-a" href='/tag/stoit-prochitat/'>Стоит прочитать</a><a class="tag-a" href='/tag/supercomputers/'>Суперкомпьютеры</a><a class="tag-a" href='/tag/ugadajki/'>Угадайки</a><a class="tag-a" href='/tag/utechka-dannyh/'>Утечка данных</a><a class="tag-a" href='/tag/ujazvimost/'>Уязвимость</a><a class="tag-a" href='/tag/data-storage-formats/'>Форматы хранения данных</a><a class="tag-a" href='/tag/frameworks/'>Фреймворки</a><a class="tag-a" href='/tag/functional-programming/'>Функциональное программирование</a><a class="tag-a" href='/tag/hakery/'>Хакеры</a><a class="tag-a" href='/tag/hobby/'>Хобби</a><a class="tag-a" href='/tag/meltdown-spectre/'>Чипокалипсис</a><a class="tag-a" href='/tag/cheatsheets/'>Шпаргалки</a><a class="tag-a" href='/tag/programming-languages/'>Языки программирования</a></div> </div>
</div>
</div>
<script defer src="https://tproger.ru/wp-content/cache/minify/adc36.x96615.js"></script>
<script type='text/javascript' id='tproger-elevator-js-extra'>
/* <![CDATA[ */
var tprogerElevator = {"pluginsUrl":"https:\/\/tproger.ru\/wp-content\/plugins"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/f86eb.x96615.js"></script>
<script type='text/javascript' id='post-views-counter-frontend-js-extra'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"ajax","requestURL":"https:\/\/tproger.ru\/wp-content\/plugins\/tproger-post-views-counter\/includes\/ajax.php","postID":"187373","nonce":"c7e1480454"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/c0cba.x96615.js"></script>
<script>
				function showPage() {
					window.requestAnimationFrame(() => {
						const page = document.getElementById('page')
						if (page && page.style.display !== '') {
							page.style.display = null
						}
						document.querySelectorAll('#fake-post, #fake-scroll, #fake-style').forEach(element => element.remove())
					})
				}
				setTimeout(showPage, 3000) // in case of error
									document.fonts.ready.then(showPage)
							</script> <script>
			const blu = {'site_url': 'https://tproger.ru', 'ajaxurl': 'https://tproger.ru/wp-admin/admin-ajax.php'};
		</script>
<div class="sharing-lock"></div>
<div class="sharing-menu">
<div class="sharing-close icon-close"></div>
<a title="Копировать ссылку на пост" class="icon-link sharing-menu-item" href="javascript:void(0);" onClick="copyLinkToClipboard('https://tproger.ru/jobs/senior-frontend-developer-2/');">Копировать ссылку</a>
<a title="Поделиться во ВКонтакте" class="icon-vkontakte sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://vk.com/share.php?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fsenior-frontend-developer-2%2F&title=Senior+Frontend+Developer');">ВКонтакте</a>
<a title="Поделиться на Facebook" class="icon-facebook sharing-menu-item" href="javascript:void(0);" onClick="social_share('http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftproger.ru%2Fjobs%2Fsenior-frontend-developer-2%2F&t=Senior+Frontend+Developer');">Facebook</a>
<a title="Поделиться в Twitter" class="icon-twitter sharing-menu-item" href="javascript:void(0);" onClick="social_share('http://twitter.com/intent/tweet?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fsenior-frontend-developer-2%2F&text=Senior Frontend Developer');">Twitter</a>
<a title="Сохранить в Pocket" class="icon-pocket small sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://getpocket.com/edit?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fsenior-frontend-developer-2%2F');">Pocket</a>
<a title="Отправить в Telegram" class="icon-telegram sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://telegram.me/share/url?url=https%3A%2F%2Ftproger.ru%2Fjobs%2Fsenior-frontend-developer-2%2F&text=Senior Frontend Developer');">Telegram</a>
</div>
</body>
</html>
