<!DOCTYPE html>
<!--[if IE 8]>
<html id="ie8" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#  profile: http://ogp.me/ns/profile# fb: http://ogp.me/ns/fb#" lang="ru-RU">
<![endif]-->
<!--[if !(IE 8) ]><!-->
<html prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#  profile: http://ogp.me/ns/profile# fb: http://ogp.me/ns/fb#" lang="ru-RU">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="preload" as="script" href="https://proxy.tproger.ru/sentry.tracing.5.27.4.js">
<link rel="preload" href="/wp-content/themes/bliss/assets/font/fontello.woff2?13931151" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/wp-content/fonts/Roboto-Regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/wp-content/fonts/Roboto-Bold.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/wp-content/fonts/Roboto-Italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" as="script" href="https://proxy.tproger.ru/yandex-metrika.js">
<link rel="preload" as="script" href="https://proxy.tproger.ru/google-analytics.js">
<link rel="preload" as="script" href="https://proxy.tproger.ru/vk-openapi.js">
<link rel="preload" as="script" href="https://proxy.tproger.ru/onesignal-sdk.js">
<link rel="preconnect" href="https://mc.yandex.ru">
<link rel="preconnect" href="https://mc.yandex.ru" crossorigin>
<link rel="preconnect" href="https://vk.com">
<link rel="preconnect" href="https://cdn.onesignal.com" crossorigin>
<link rel="preconnect" href="https://onesignal.com" crossorigin>
<link rel="preconnect" href="https://www.google-analytics.com">
<link rel="preconnect" href="https://stats.g.doubleclick.net">
<link rel="preconnect" href="https://tproger.ru" crossorigin><link rel="preconnect" href="https://comments.tproger.ru" crossorigin>
<script defer src="https://proxy.tproger.ru/sentry.tracing.5.27.4.js" onload="Sentry.init({ dsn: 'https://63f279b4a66348b9ade9e95f8bcb2e0e@sentry.tproger.ru/5302604', environment: 'tproger.ru', release: '4871dac7be2bd0e599e9a026946e9f4ba5938f49', integrations: [new Sentry.Integrations.BrowserTracing()], tracesSampleRate: 0.05, beforeSend(event) { return ((window.ses = window.ses ? window.ses + 1 : 1) > 16) ? null : event }, }); window.setAnalyticsSentryTags && setAnalyticsSentryTags()"></script>

<title>Spotify допустил крупную утечку данных пользователей</title>
<meta name="description" content="В общей сложности, от действий злоумышленников пострадали около 350 тыс пользователей. Музыкальный сервис же отчитался о решении проблемы." />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://tproger.ru/news/spotify-dopustil-krupnuju-utechku-dannyh-polzovatelej/" />
<meta property="og:locale" content="ru_RU" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Spotify допустил крупную утечку данных пользователей" />
<meta property="og:description" content="В общей сложности, от действий злоумышленников пострадали около 350 тыс пользователей. Музыкальный сервис же отчитался о решении проблемы." />
<meta property="og:url" content="https://tproger.ru/news/spotify-dopustil-krupnuju-utechku-dannyh-polzovatelej/" />
<meta property="og:site_name" content="Tproger" />
<meta property="article:publisher" content="https://www.facebook.com/tproger/" />
<meta property="article:published_time" content="2020-11-25T07:39:23+00:00" />
<meta property="article:modified_time" content="2020-11-25T07:39:26+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@tproger" />
<meta name="twitter:site" content="@tproger" />

<link rel="amphtml" href="https://tproger.ru/news/spotify-dopustil-krupnuju-utechku-dannyh-polzovatelej/amp/" /><link rel='dns-prefetch' href='//s3.tproger.ru' />
<link rel="alternate" type="application/rss+xml" title="Tproger &raquo; Лента" href="https://tproger.ru/feed/" />
<link rel="stylesheet" href="https://tproger.ru/wp-content/cache/minify/5439d.x75398.css" media="all" />
<script defer src="https://tproger.ru/wp-content/cache/minify/4af1b.x75398.js"></script>
<script async src="https://tproger.ru/wp-content/cache/minify/3f2c6.x75398.js"></script>
<link rel="https://api.w.org/" href="https://tproger.ru/wp-json/" /><link rel="alternate" type="application/json" href="https://tproger.ru/wp-json/wp/v2/posts/138080" /><link rel='shortlink' href='https://tproger.ru/?p=138080' />
<link rel="icon" href="/favicon.ico?v=2">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="192x192" href="/android-chrome-192x192.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#2aa5a0">
<meta name="apple-mobile-web-app-title" content="Tproger">
<meta name="application-name" content="Tproger">
<meta name="theme-color" content="#2aa5a0">
</head>
<body class="post-template-default single single-post postid-138080 single-format-standard dark">
<div id="page" class="site">
<div id="top-post-widget-container" class="t-widget-container tproger-widget subscription-widget" style='display:none;' data-ad data-type="4">
<a href="#" class="t-widget-main-a" target="_blank" rel="noopener"> </a>
<div class='t-widget-box-container' style='display:none'>
<div class="t-widget" style="">
<div class="top-post-widget-text" style='display:none'><strong>Хотите ещё больше веб-разработки?</strong><br>В канале Веб-страница только об этом и пишем.</div>
<a style='display:none' class="btn bluth tproger btn- top-post-widget-button" href="" target="_blank" rel="noopener">Узнать подробнее</a>
</div>
</div>
</div>
<header id="masthead" role="banner" class="">
<div class="top-duft-punk">
<div id="header-container">
<div id="reading-progress"></div>
<nav id="header" role="navigation" class="windowed">
<div class="header-toogle">
<div id="main-menu-toggle" class="header-item">
<div id="menu-cover"></div>
<input id="main-menu-toggle-input" type="checkbox" />
<span class="main-menu-toggle-span"></span>
<span class="main-menu-toggle-span"></span>
<span class="main-menu-toggle-span"></span>
<ul id="main-menu" style="display:none;"><li id="menu-item-116231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Лента" class="main-menu-a"><i class="icon-menu-hot menu-icons"></i>Лента<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116232" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/" title="Сначала новое" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Сначала новое</a></li> <li id="menu-item-116233" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/hot/" title="Набирает популярность" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Набирает популярность</a></li> <li id="menu-item-116235" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/week/" title="Лучшее за неделю" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Лучшее за неделю</a></li> <li id="menu-item-116236" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/month/" title="Лучшее за месяц" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Лучшее за месяц</a></li> <li id="menu-item-116237" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/ever/" title="Лучшее за всё время" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Лучшее за всё время</a></li>
</ul>
</li><li id="menu-item-116286" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/jobs/?utm_source=tproger_ru_main_menu" title="Вакансии" class="main-menu-a"><i class="icon-menu-job menu-icons"></i>Вакансии</a></li><li id="menu-item-136632" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item divider navigation__dropdown-item"><a href="/" title="&#8212;" class="main-menu-a"><i class="icon-menu- menu-icons"></i>&#8212;</a></li><li id="menu-item-85895" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a title="События и курсы, на которых можно поднять свой уровень" href="/events/" title="События и курсы" class="main-menu-a"><i class="icon-menu-time menu-icons"></i>События и курсы</a></li><li id="menu-item-116238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Рубрики" class="main-menu-a"><i class="icon-menu-heading menu-icons"></i>Рубрики<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116246" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/curriculum/" title="Планы обучения" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Планы обучения</a></li> <li id="menu-item-12274" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Задачи с IT-собеседований" href="https://tproger.ru/category/problems/" title="Задачки" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Задачки</a></li> <li id="menu-item-73978" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Тесты и викторины" href="https://tproger.ru/category/quiz/" title="Тесты и викторины" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Тесты и викторины</a></li> <li id="menu-item-116243" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/books/" title="Книги" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Книги</a></li> <li id="menu-item-116240" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/video/" title="Видео" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Видео</a></li> <li id="menu-item-116244" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/explain/" title="Коротко о главном" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Коротко о главном</a></li> <li id="menu-item-21201" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Ответы экспертов на вопросы читателей" href="https://tproger.ru/category/experts/" title="Советы экспертов" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Советы экспертов</a></li> <li id="menu-item-116249" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/articles/" title="Статьи" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Статьи</a></li> <li id="menu-item-116245" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/translations/" title="Переводы" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Переводы</a></li> <li id="menu-item-116247" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/digest/" title="Подборки" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Подборки</a></li> <li id="menu-item-116239" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/devnull/" title="Юмор" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Юмор</a></li> <li id="menu-item-116241" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/category/interview/" title="Интервью" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Интервью</a></li>
</ul>
</li><li id="menu-item-116254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Темы" class="main-menu-a"><i class="icon-menu-topics menu-icons"></i>Темы<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116253" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/for-beginners/" title="Для начинающих" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Для начинающих</a></li> <li id="menu-item-116257" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/algorithms/" title="Алгоритмы" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Алгоритмы</a></li> <li id="menu-item-116258" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/design-patterns/" title="Паттерны проектирования" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Паттерны проектирования</a></li> <li id="menu-item-116260" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/software-development/" title="Методологии разработки" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Методологии разработки</a></li> <li id="menu-item-116255" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/web/" title="Веб-разработка" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Веб-разработка</a></li> <li id="menu-item-116256" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/gamedev/" title="Разработка игр" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Разработка игр</a></li> <li id="menu-item-116262" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/mobiledev/" title="Мобильная разработка" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Мобильная разработка</a></li> <li id="menu-item-116259" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/machine-learning/" title="Машинное обучение" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Машинное обучение</a></li> <li id="menu-item-116264" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/neural-network/" title="Нейронные сети" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Нейронные сети</a></li> <li id="menu-item-116263" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/ai/" title="Искусственный интеллект" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Искусственный интеллект</a></li> <li id="menu-item-116266" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/data-science/" title="Data Science" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Data Science</a></li> <li id="menu-item-116265" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/interface-design-ux/" title="Дизайн интерфейсов и UX" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Дизайн интерфейсов и UX</a></li> <li id="menu-item-116261" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/sysadm/" title="Системное администрирование" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Системное администрирование</a></li> <li id="menu-item-116294" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item divider navigation__dropdown-item"><a href="/" title="&#8212;" class="main-menu-a"><i class="icon-menu- menu-icons"></i>&#8212;</a></li> <li id="menu-item-116291" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="#tagsModal" title="Все темы" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Все темы</a></li>
</ul>
</li><li id="menu-item-116269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Языки" class="main-menu-a"><i class="icon-menu-terminal menu-icons"></i>Языки<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116272" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/python/" title="Python" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Python</a></li> <li id="menu-item-116270" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/javascript/" title="JavaScript" class="main-menu-a"><i class="icon-menu- menu-icons"></i>JavaScript</a></li> <li id="menu-item-116275" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/go/" title="Golang" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Golang</a></li> <li id="menu-item-116276" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/java/" title="Java" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Java</a></li> <li id="menu-item-116273" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/cpp/" title="C++" class="main-menu-a"><i class="icon-menu- menu-icons"></i>C++</a></li> <li id="menu-item-116274" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/c-sharp/" title="C#" class="main-menu-a"><i class="icon-menu- menu-icons"></i>C#</a></li> <li id="menu-item-116277" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/php/" title="PHP" class="main-menu-a"><i class="icon-menu- menu-icons"></i>PHP</a></li> <li id="menu-item-116278" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/css/" title="CSS" class="main-menu-a"><i class="icon-menu- menu-icons"></i>CSS</a></li> <li id="menu-item-116279" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/sql/" title="SQL" class="main-menu-a"><i class="icon-menu- menu-icons"></i>SQL</a></li> <li id="menu-item-136633" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/swift/" title="Swift" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Swift</a></li> <li id="menu-item-136634" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/c-language/" title="Язык Си" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Язык Си</a></li> <li id="menu-item-136635" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/asm/" title="Язык ассемблера" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Язык ассемблера</a></li> <li id="menu-item-136636" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/r-language/" title="Язык R" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Язык R</a></li> <li id="menu-item-136637" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/objective-c/" title="Оbjective-С" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Оbjective-С</a></li> <li id="menu-item-136638" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/perl/" title="Perl" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Perl</a></li> <li id="menu-item-136639" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/dot-net/" title=".NET" class="main-menu-a"><i class="icon-menu- menu-icons"></i>.NET</a></li> <li id="menu-item-136640" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/django/" title="Django" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Django</a></li> <li id="menu-item-136641" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/docker/" title="Docker" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Docker</a></li> <li id="menu-item-136642" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/mysql/" title="MySQL" class="main-menu-a"><i class="icon-menu- menu-icons"></i>MySQL</a></li> <li id="menu-item-136643" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/node-js/" title="Node.js" class="main-menu-a"><i class="icon-menu- menu-icons"></i>Node.js</a></li> <li id="menu-item-136644" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/react/" title="React" class="main-menu-a"><i class="icon-menu- menu-icons"></i>React</a></li> <li id="menu-item-136645" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/webassembly/" title="WebAssembly" class="main-menu-a"><i class="icon-menu- menu-icons"></i>WebAssembly</a></li>
</ul>
</li>
<li class="hide-on-desktop menu-item">
<a href="/about/publish-me/?utm_source=tproger_ru_mobile_menu" class="main-menu-a">Выпустить свой материал</a>
</li>
<li id="menu-item-135028" class="menu-item menu-item-type-custom menu-item-object-custom current-menu-item current_page_item tag-menu-item divider navigation-wp-dropdown-item">
</li>
<li class="hide-on-desktop dropdown menu-item">
<a href="/ad/" class="main-menu-a">Реклама на tproger.ru</a>
</li>
<li class="hide-on-desktop last-main-menu menu-item">
<span class="main-menu-a">Контакты для сотрудничества:</span>
<span class="main-menu-a">Телефон:&nbsp;<a href="tel:+7 916 559-71-10">+7 916 559-71-10</a></span>
<span class="main-menu-a">E-mail:&nbsp;<a href="mailto:sales@tproger.ru">sales@tproger.ru</a></span>
</li>
</ul> </div>
</div>
<div id="header-logo">
<a id="main-logo" class="header-item header-clickable" href="https://tproger.ru"> <img src="/wp-content/themes/bliss/assets/img/logo.svg" alt='Логотип Tproger'>
<span id="logo-text" class="hide-on-mobile hide-on-narrow">Tproger</span>
</a> </div>
<div class="header-right">
<a id="search_icon" href="/search/" class="header-item header-clickable">
<img src="/wp-content/themes/bliss/assets/img/icon-search.svg" alt="Поиск">
</a>
<a id="tproger-login-button" class="header-item hoverable"></a>
</div>
</nav>
<div id="tproger-login"></div>
</div>
</div>
<div class="header-searchbox" id="searchbox" style="display: none;">
<form method="get" action="/search">
<div class="header-searchbox-input-wrapper">
<input name="text" maxlength="128" class="header-searchbox-input" placeholder="Что ищем?">
<input name="searchid" type="hidden" value="2415386">
<input name="web" type="hidden" value="0">
<span class="header-searchbox-input-cancel icon-cancel"></span>
</div>
</form>
</div>
</header>


<div id="main" class="windowed"><div id="above-content-container" data-loaded="no"><a id="above-content-link" href="https://tprg.ru/Cnua" rel="nofollow" onclick="ga('send', 'event', 'buttons', 'click', 'above-content-call-to-action__news');"><div id="above-content-button" class="box"><i id="above-content-image" class="colored icon-telegram"></i>Читать новости в Telegram</div></a></div> <div id="tproger_ads_widget-4" style="display:none;" class='tproger-widget float-widget-container subscription-widget' data-ad data-type="2">
<div class="float-widget">
<a class="float-widget-a" href="" target="_blank" rel="noopener">
<div class="float-widget-blocks">
<div class="box float-widget-text">Tproger.ru</div>
<div class="float-widget-btn float-widget-positive-btn"></div>
<div class="float-widget-btn float-widget-negative-btn">Закрыть</div>
</div>
<div class="float-widget-close-btn" id="float-widget-close-btn" style="display:none;">✕</div>
<img class="no-lazy-img float-widget-img lazy" src="">
</a>
</div>
</div>
<div id="primary" class="row right_side">
<div id="content" role="main">
<article id="post-138080" class="box single post-138080 post type-post status-publish format-standard hentry category-news tag-spotify tag-utechka-dannyh" itemscope itemtype="http://schema.org/NewsArticle">
<div class="sticky-header">
<div class="sticky-header-container content-windowed">
<div class="sticky-sharing sharing">
<a title="Поделиться во ВКонтакте" class="colored icon-vkontakte" href="javascript:void(0);" onClick="social_share('https://vk.com/share.php?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&title=Spotify+%D0%B4%D0%BE%D0%BF%D1%83%D1%81%D1%82%D0%B8%D0%BB+%D0%BA%D1%80%D1%83%D0%BF%D0%BD%D1%83%D1%8E+%D1%83%D1%82%D0%B5%D1%87%D0%BA%D1%83+%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85+%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D1%82%D0%B5%D0%BB%D0%B5%D0%B9');"></a>
<a title="Поделиться на Facebook" class="colored icon-facebook" href="javascript:void(0);" onClick="social_share('http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&t=Spotify+%D0%B4%D0%BE%D0%BF%D1%83%D1%81%D1%82%D0%B8%D0%BB+%D0%BA%D1%80%D1%83%D0%BF%D0%BD%D1%83%D1%8E+%D1%83%D1%82%D0%B5%D1%87%D0%BA%D1%83+%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85+%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D1%82%D0%B5%D0%BB%D0%B5%D0%B9');"></a>
<a title="Поделиться в Twitter" class="colored icon-twitter" href="javascript:void(0);" onClick="social_share('http://twitter.com/intent/tweet?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&text=Spotify допустил крупную утечку данных пользователей');"></a>
<a title="Сохранить в Pocket" class="colored icon-pocket small" href="javascript:void(0);" onClick="social_share('https://getpocket.com/edit?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F');"></a>
<a title="Отправить в Telegram" class="colored icon-telegram" href="javascript:void(0);" onClick="social_share('https://telegram.me/share/url?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&text=Spotify допустил крупную утечку данных пользователей');"></a>
</div>
<div class="sticky-caption">Spotify допустил крупную утечку данных пользователей</div>
<div class="sticky-icons" data-container-loaded="no">
<div class="meta-content post-tool-block">
<div class="tproger-comment-count" data-loaded="no" data-post="138080"></div>
<div class="tproger-bookmark" data-loaded="no" data-post="138080"></div>
</div>
<div id="close-post" class="close-post icon-close"></div>
</div>
</div>
<div class="sidebar-pusher"></div> </div>
<div class="post-title">
<h1 class="entry-title" itemprop="headline">Spotify допустил крупную утечку данных пользователей</h1>
<div class="post-meta">
<ul>
<li>
<span itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a itemprop="item" href="https://tproger.ru/category/news/" title="Все посты категории «Новости»"><span itemprop="name">Новости</span></a><meta itemprop="position" content="1" /></span></span>, <time class="entry-date timeago" datetime="2020-11-25T10:39:23+03:00" itemprop="datePublished" content="2020-11-25T10:39:23+03:00">25 ноября в 10:39</time>
</li><li><span itemprop="author" itemscope itemtype="http://schema.org/Person"><a itemprop="name" content="Булат Яббаров" href="/author/bulat.y/" data-wpel-link="internal" rel="follow">Булат Яббаров</a></span></li> <li data-role="post_views">
<div class="post-views post-138080 entry-meta">
<span class="post-views-icon icon-eye"></span>
<span id="post-views-count" class="post-views-count">1</span>
</div>
</li> <link rel="preload" as="fetch" href="/wp-content/themes/bliss/fast-ajax.php?action=get-post-views&post-id=138080" crossorigin="anonymous">
</ul>
</div>
<div class="announcement">Огромную базу, объёмом 72 ГБ, обнаружили специалисты vpnMentor Ноам Ротем и Ран Локар. В ней содержались данные около 350 тыс пользователей сервиса. При этом помимо связки логин/пароль, в базе также можно было найти адреса электронной почты и места проживания людей, использующих Spotify.</div> </div>
<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject" style="display:none;">
<img src="https://tproger.ru/og.png" itemprop="image url">
</div>
<div class="entry-container noimg" data-io-article-url="https://tproger.ru/news/spotify-dopustil-krupnuju-utechku-dannyh-polzovatelej/">
<meta itemprop="description" content="Огромную базу, объёмом 72 ГБ, обнаружили специалисты vpnMentor Ноам Ротем и Ран Локар. В ней содержались данные около 350 тыс пользователей сервиса. При этом помимо связки логин/пароль, в базе также можно было найти адреса электронной почты и места проживания людей, использующих Spotify." />
<meta itemprop="wordCount" content="87" />
<meta itemprop="dateModified" content="2020-11-25T10:39:26+03:00" />
<span itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="image" content="https://cdn.tproger.ru/android-chrome-32x32.png">
<meta itemprop="width" content="32">
<meta itemprop="height" content="32">
<link itemprop="url" href="https://cdn.tproger.ru/android-chrome-32x32.png">
</span>
<meta itemprop="name" content="Tproger">
<meta itemprop="address" content="Москва, Деловой Центр «Калибр»">
<meta itemprop="telephone" content="+7 916 559-71-10">
</span>
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://tproger.ru/news/spotify-dopustil-krupnuju-utechku-dannyh-polzovatelej/" content="Spotify допустил крупную утечку данных пользователей" />
<div class="entry-content" itemprop="articleBody">
<div class="post-tool-actions-sizer">
<div class="post-tool-actions" data-container-loaded="no">
<div class="tproger-comment-count" data-loaded="no" data-post="138080"></div>
<div class="tproger-bookmark" data-loaded="no" data-post="138080"></div>
<div class="end-sharing sharing">
<a title="Поделиться во ВКонтакте" class="colored icon-vkontakte" href="javascript:void(0);" onClick="social_share(`https://vk.com/share.php?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&amp;title=Spotify+%D0%B4%D0%BE%D0%BF%D1%83%D1%81%D1%82%D0%B8%D0%BB+%D0%BA%D1%80%D1%83%D0%BF%D0%BD%D1%83%D1%8E+%D1%83%D1%82%D0%B5%D1%87%D0%BA%D1%83+%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85+%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D1%82%D0%B5%D0%BB%D0%B5%D0%B9`)" data-wpel-link="internal" rel="follow">
</a>
<a title="Поделиться на Facebook" class="colored icon-facebook" href="javascript:void(0);" onClick="social_share(`http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&amp;t=Spotify+%D0%B4%D0%BE%D0%BF%D1%83%D1%81%D1%82%D0%B8%D0%BB+%D0%BA%D1%80%D1%83%D0%BF%D0%BD%D1%83%D1%8E+%D1%83%D1%82%D0%B5%D1%87%D0%BA%D1%83+%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85+%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D1%82%D0%B5%D0%BB%D0%B5%D0%B9`)" data-wpel-link="internal" rel="follow">
</a>
<a title="Поделиться в Twitter" class="colored icon-twitter" href="javascript:void(0);" onClick="social_share(`http://twitter.com/intent/tweet?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&amp;text=Spotify допустил крупную утечку данных пользователей`)" data-wpel-link="internal" rel="follow">
</a>
<a title="Сохранить в Pocket" class="colored icon-pocket small" href="javascript:void(0);" onClick="social_share(`https://getpocket.com/edit?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F`)" data-wpel-link="internal" rel="follow">
</a>
<a title="Отправить в Telegram" class="colored icon-telegram" href="javascript:void(0);" onClick="social_share(`https://telegram.me/share/url?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&amp;text=Spotify допустил крупную утечку данных пользователей`)" data-wpel-link="internal" rel="follow">
</a>
</div>
</div>
</div>
<p>Исследователи предполагают, что утекшие данные использовались для проведения различных атак. В том числе и тех, которые основываются на подстановке учётных данных при авторизации в сторонних сервисах.</p>
<p>При этом Ротем и Локар в кратчайшие сроки сообщили Spotify о найденной базе. Музыкальный сервис отреагировал незамедлительно: для защиты пользовательских данных, компания запустила процесс сброса паролей для тех аккаунтов, которые оказались «слиты».</p>
<p>Стоит отметить, что утечка хоть и носит достаточно масштабный характер, на фоне общей пользовательской базы Spotify в 299 млн человек, 350 тыс &#8212; это всего лишь 0,1%.</p>
<div id="article-end-beacon"></div>
<p class="origin">Источник: <a href="”https://www.zdnet.com/article/spotify-launches-rolling-reset-on-customer-accounts-linked-to-data-leak/”" data-wpel-link="internal" rel="follow">ZDNet</a></p>
<footer class="entry-meta">
<div class="footer-left">
<ul>
<li>
<a class="tag-a" href="https://tproger.ru/tag/spotify/" rel="tag" itemprop="about" itemscope itemtype="https://schema.org/Thing"><span itemprop="name">Spotify</span></a><a class="tag-a" href="https://tproger.ru/tag/utechka-dannyh/" rel="tag" itemprop="about" itemscope itemtype="https://schema.org/Thing"><span itemprop="name">Утечка данных</span></a> </li>
</ul>
</div>
<div class="end-sharing sharing">
<a title="Поделиться во ВКонтакте" class="colored icon-vkontakte" href="javascript:void(0);" onClick="social_share('https://vk.com/share.php?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&title=Spotify+%D0%B4%D0%BE%D0%BF%D1%83%D1%81%D1%82%D0%B8%D0%BB+%D0%BA%D1%80%D1%83%D0%BF%D0%BD%D1%83%D1%8E+%D1%83%D1%82%D0%B5%D1%87%D0%BA%D1%83+%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85+%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D1%82%D0%B5%D0%BB%D0%B5%D0%B9');"></a>
<a title="Поделиться на Facebook" class="colored icon-facebook" href="javascript:void(0);" onClick="social_share('http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&t=Spotify+%D0%B4%D0%BE%D0%BF%D1%83%D1%81%D1%82%D0%B8%D0%BB+%D0%BA%D1%80%D1%83%D0%BF%D0%BD%D1%83%D1%8E+%D1%83%D1%82%D0%B5%D1%87%D0%BA%D1%83+%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85+%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D1%82%D0%B5%D0%BB%D0%B5%D0%B9');"></a>
<a title="Поделиться в Twitter" class="colored icon-twitter" href="javascript:void(0);" onClick="social_share('http://twitter.com/intent/tweet?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&text=Spotify допустил крупную утечку данных пользователей');"></a>
<a title="Сохранить в Pocket" class="colored icon-pocket small" href="javascript:void(0);" onClick="social_share('https://getpocket.com/edit?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F');"></a>
<a title="Отправить в Telegram" class="colored icon-telegram" href="javascript:void(0);" onClick="social_share('https://telegram.me/share/url?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fspotify-dopustil-krupnuju-utechku-dannyh-polzovatelej%2F&text=Spotify допустил крупную утечку данных пользователей');"></a>
</div> <div class="tproger-mark" data-post="138080"></div>
</footer>
</div>
</div>
<span class="vcard" style="display: none;">
<span class="fn">
<a href="https://tproger.ru/author/bulat-y/" class="author">Булат Яббаров</a>
</span>
</span>
</article>
<div id="after-post-widget-container" class="h-widget-container tproger-widget subscription-widget" data-ad style="display:none;" data-type="3">
<a href="#" class="fix-widget-main-a after-post-widget-a" target="_blank" rel="noopener"> </a>
<div class="box h-widget" style="display:none;">
<img class="no-lazy-img after-post-widget-img lazy" src="">
<div class="after-post-widget-text"></div>
<a class="btn bluth tproger btn- after-post-widget-button" href="" target="_blank" rel="noopener">Узнать подробнее</a>
</div>
<div class="adsLinkBlockFixBaner" style="display:none">
<a href="/ad/?utm_referrer=after-post-widget-container" targer="_blank" class="adsLinkFixBaner" rel="noopener">Реклама на tproger.ru</a>
</div>
</div>
<div id="tproger-comment-widget">
<div id="comments"></div>
</div>
</div>
<aside id="side-bar" data-container-loaded="no" data-container-loaded-callback="sideBarInit" data-container-loaded-max-seconds="10" class="widget-area">
<div id="sidebar__inner"> <div id="tproger_ads_widget-3" style="display: none;" class='fix-widget-container tproger-widget subscription-widget' data-loaded="no" data-ad data-type="1">
<a href="#" target="_blank" class="fix-widget-main-a" style="color: unset;" rel="noopener"></a>
<div class="fix-widget-content">
<img src="" class="no-lazy-img fix-widget-img lazy">
<p class="fix-widget-text"></p>
<a href="#" target="_blank" class="widget-button-bottom fix-widget-button" rel="noopener">Узнать подробнее</a>
</div>
<div class="fix-widget-close-btn icon-close hoverable"></div>
<div class="adsLinkBlockFixBaner">
<a href="/ad/" targer="_blank" class="adsLinkFixBaner" rel="noopener">Реклама на tproger.ru</a>
</div>
</div>
<div class="box widget_tag_cloud" data-role="widget_get_new_quote">
<div class="citation">
<div class="citation-quote citation-quote-left"><i class="icon-quote-left"></i></div>
<div class="citation-widget">
<p data-role="widget_quote_text" data-loaded="no">Загрузка...</p>
</div>
<div class="citation-quote citation-quote-right"><i class="icon-quote-right"></i></div>
<div class="quote_refresh_block icon-arrows-ccw"></div>
</div>
</div><div id="right_event_job_widget-6" data-type="2" data-wtype="sidebar" data-btn-title="Все вакансии" data-btn-url="/jobs/" data-utm="tproger_ru_right_banner&utm_medium=post&utm_term=Spotify&utm_term=Утечка данных" data-rbtn-title="" data-rbtn-url="" data-job class="box tproger-event-job-widget subscription-widget nopadding widget-sidebar-type" style="width:100%;"><div class="widget-list"><a href="https://tproger.ru/jobs/partnered-editor-tproger/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Spotify&utm_term=Утечка данных"><div class="widget-list-item hoverable"><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="50" height="50" data-src="https://s3.tproger.ru/uploads/2017/04/tp_circle_big-80x80.png" data-srcset="https://s3.tproger.ru/uploads/2017/04/tp_circle_big-80x80.png, https://s3.tproger.ru/uploads/2017/04/tp_circle_big-150x150.png 1.5x, https://s3.tproger.ru/uploads/2017/04/tp_circle_big-300x300.png 2x"></div><div class="widget-list-item-right"><div class="widget-list-item-caption"><i class="colored icon-flash"></i>Пишущий редактор партнёрских материалов в сфере IT</div><div class="widget-list-description">Москва, от 40&thinsp;000 до 70&thinsp;000&nbsp;₽</div></div></div></a><a href="https://tproger.ru/jobs/php-dev-coders/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Spotify&utm_term=Утечка данных"><div class="widget-list-item hoverable"><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="50" height="50" data-src="https://s3.tproger.ru/uploads/2020/11/the_coders_logo-10_tilda2930233-50x50.jpg" data-srcset="https://s3.tproger.ru/uploads/2020/11/the_coders_logo-10_tilda2930233-50x50.jpg, https://s3.tproger.ru/uploads/2020/11/the_coders_logo-10_tilda2930233-150x150.jpg 1.5x, https://s3.tproger.ru/uploads/2020/11/the_coders_logo-10_tilda2930233-280x280.jpg 2x"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">PHP-разработчик</div><div class="widget-list-description">Оренбург, можно удалённо, до 100&thinsp;000&nbsp;₽</div></div></div></a><a href="https://tproger.ru/jobs/middle-ios-dev-laoshi/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Spotify&utm_term=Утечка данных"><div class="widget-list-item hoverable"><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="50" height="50" data-src="https://s3.tproger.ru/uploads/2020/10/Novyj-logo-copy_tilda2744802-50x50.png" data-srcset="https://s3.tproger.ru/uploads/2020/10/Novyj-logo-copy_tilda2744802-50x50.png, https://s3.tproger.ru/uploads/2020/10/Novyj-logo-copy_tilda2744802-150x150.png 1.5x, https://s3.tproger.ru/uploads/2020/10/Novyj-logo-copy_tilda2744802-280x280.png 2x"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">iOS Developer (Middle)</div><div class="widget-list-description">Удалённо, от 120&thinsp;000 до 200&thinsp;000&nbsp;₽</div></div></div></a><a href="https://tproger.ru/jobs/csharp-middle-money-rock/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Spotify&utm_term=Утечка данных"><div class="widget-list-item hoverable"><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="50" height="50" data-src="https://s3.tproger.ru/uploads/2020/11/Logo_MoneyRock_PNG-50x50.png" data-srcset="https://s3.tproger.ru/uploads/2020/11/Logo_MoneyRock_PNG-50x50.png, https://s3.tproger.ru/uploads/2020/11/Logo_MoneyRock_PNG-150x150.png 1.5x, https://s3.tproger.ru/uploads/2020/11/Logo_MoneyRock_PNG-280x280.png 2x"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Middle/Senior Разработчик С#</div><div class="widget-list-description">Удалённо, от 90&thinsp;000 до 200&thinsp;000&nbsp;₽</div></div></div></a><div class="widget-list-footer"><a href="/jobs/?utm_source=tproger_ru_right_banner" class="show-more hoverable">Все вакансии<span class="icon-right-open vertical-middle"></span></a></div></div></div> <div id="tproger_ads_widget-5" style="display: none;" class='fix-widget-container tproger-widget subscription-widget' data-loaded="no" data-ad data-type="1">
<a href="#" target="_blank" class="fix-widget-main-a" style="color: unset;" rel="noopener"></a>
<div class="fix-widget-content">
<img src="" class="no-lazy-img fix-widget-img lazy">
<p class="fix-widget-text"></p>
<a href="#" target="_blank" class="widget-button-bottom fix-widget-button" rel="noopener">Узнать подробнее</a>
</div>
<div class="fix-widget-close-btn icon-close hoverable"></div>
<div class="adsLinkBlockFixBaner">
<a href="/ad/" targer="_blank" class="adsLinkFixBaner" rel="noopener">Реклама на tproger.ru</a>
</div>
</div>
</div> </aside>
</div>
</div>
<div id="cookie-notice-wrapper" style='display:none'>
<div id="cookie-notice"><span class="cookie-notice-text">Обычное дело: мы используем cookie.</span> <a href="/about/cookie/" target="_blank" class="cookie-notice-about">Здесь&nbsp;можно&nbsp;узнать,&nbsp;зачем</a></div>
<div class="btn bluth tproger cookie-notice-close">Хорошо</div>
</div>
<footer id="footer">
<div id="footer-body" class="windowed">
<div id="custom_html-2" class="widget_text span4 widget_custom_html"><div class="textwidget custom-html-widget"><div><a href="/about/" class="footer-a">О&nbsp;проекте</a>
<a href="/ad/?utm_referrer=footer" class="footer-a">Реклама</a>
</div><div class="footer-dark-a-wrapper"><a href="https://tproger.ru/wp-content/uploads/custom/terms.pdf" class="footer-dark-a">Пользовательское&nbsp;соглашение</a><a href="https://tproger.ru/wp-content/uploads/custom/privacy.pdf" class="footer-dark-a">Политика&nbsp;конфиденциальности</a></div>
<div class="footer-dark-a-wrapper footer-with-logo"><a href="https://tprg.ru/regru-footer" class="footer-dark-a" data-wpel-link="external" target="_blank" rel="nofollow noopener noreferrer">Используем&nbsp;серверы&nbsp;<img alt="Логотип REG.RU" data-src="https://s3.tproger.ru/uploads/custom/regru-logo.svg" class=" lazy"></a></div></div></div><div id="custom_html-4" class="widget_text span4 widget_custom_html"><div class="textwidget custom-html-widget"><span class="social-footer" itemscope itemtype="http://schema.org/Organization">
<meta itemprop="logo" content="https://cdn.tproger.ru/android-chrome-32x32.png">
<meta itemprop="url" content="https://tproger.ru">
<meta itemprop="name" content="Tproger">
<link itemprop="url" href="https://tproger.ru/">
<a class="social-footer-a icon-vkontakte" itemprop="sameAs" href="https://vk.com/tproger"></a>
<a class="social-footer-a icon-facebook" itemprop="sameAs" href="https://www.facebook.com/tproger/"></a>
<a class="social-footer-a icon-twitter" itemprop="sameAs" href="https://twitter.com/tproger"></a>
<a class="social-footer-a icon-telegram" itemprop="sameAs" href="tg://resolve?domain=tproger_official"></a>
<a class="social-footer-a icon-yazen" itemprop="sameAs" href="https://zen.yandex.ru/tproger"></a>
<a class="social-footer-a icon-rss" href="https://tproger.ru/feed/"></a>
</span>
<div id="subscribe-wrapper" style="display: none">
<a href="javascript:void(0)" id="subscribe-link"><i class="icon-bell"></i> Включить уведомления</a>
</div>
<span id="mistape-widget-message">
Нашли опечатку? Выделите фрагмент и отправьте нажатием Ctrl+Enter.
</span></div></div><div id="custom_html-5" class="widget_text span4 widget_custom_html"><div class="textwidget custom-html-widget"><div class="footer-contacts"><span>Контакты для сотрудничества:</span>
<span>Телефон: <a href="tel:+79165597110">+7 916 559-71-10</a></span>
<span>E-mail: <a href="mailto:sales@tproger.ru">sales@tproger.ru</a></span>
</div></div></div> </div>
<div id="wrapfabtest">
<div class="adBanner"></div>
</div>
</footer>
</div>
<script>
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
ga('create', 'UA-78195897-1', 'auto');
ga('require', 'GTM-WW6L2L8');
ga('send', 'pageview');
</script>
<script type="text/javascript" src="https://proxy.tproger.ru/google-analytics.js" async></script>
<script>
window.ym=window.ym||function(){(ym.a=ym.a||[]).push(arguments)};ym.l=1*new Date();
ym(27485085, "init", {clickmap: false, trackLinks: true, accurateTrackBounce: true, webvisor:false});
</script>
<script type="text/javascript" src="https://proxy.tproger.ru/yandex-metrika.js" async></script>
<noscript><div><img src="https://mc.yandex.ru/watch/27485085" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://tproger.ru/",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://tproger.ru/search/?text={search_term_string}&searchid=2415386&web=0",
    "query-input": "required name=search_term_string"
  }
}
</script>
<div style="display:none;" class="tproger-elevator-block" id="tproger-elevator">
<div id="tproger-arrow" class="elevator-arrow icon-up-open"></div>
</div>
<script>var OneSignal = window.OneSignal || [];</script>
<script type="text/javascript" src="https://proxy.tproger.ru/vk-openapi.js" onload="window.setupVK && window.setupVK()" async="async"></script>
<script type="text/javascript" src="https://proxy.tproger.ru/onesignal-sdk.js" onload="window.setupOneSignal && window.setupOneSignal()" async="async"></script>
<script type="module" src="/wp-content/themes/bliss/assets/js/instant-page.x75398.js"></script><script>
	window.ta=window.ta||function(){(ta.q=ta.q||[]).push([new Date,...arguments])};
	ta('pageview.post', 3, { postId: 138080, pageReferrer: document.referrer });	</script><script>var widgetsNonce='eb2605e5d6';</script> <script>
				!function(){if('PerformanceLongTaskTiming' in window){var g=window.__tti={e:[]};
				g.o=new PerformanceObserver(function(l){g.e=g.e.concat(l.getEntries())});
				g.o.observe({entryTypes:['longtask']})}}();
				</script> <div id="tagsModal" style="display:none">
<div class="closebt-container close-tagsModal">
<img class="closebt lazy" alt="Закрыть" data-src="/wp-content/themes/bliss/assets/img/close-modal.svg"> </div>
<div class="modal-container widget_tag_cloud">
<div class="modal-tag-cloud tagcloud">
<div class="tag-category" data-tag="brands"><h3>По брендам</h3><a class="tag-a" href='/tag/adobe/'>Adobe</a><a class="tag-a" href='/tag/amazon/'>Amazon</a><a class="tag-a" href='/tag/apple/'>Apple</a><a class="tag-a" href='/tag/cloudflare/'>Cloudflare</a><a class="tag-a" href='/tag/facebook/'>Facebook</a><a class="tag-a" href='/tag/github/'>GitHub</a><a class="tag-a" href='/tag/gitlab/'>GitLab</a><a class="tag-a" href='/tag/google/'>Google</a><a class="tag-a" href='/tag/ibm/'>IBM</a><a class="tag-a" href='/tag/intel/'>Intel</a><a class="tag-a" href='/tag/jetbrains/'>JetBrains</a><a class="tag-a" href='/tag/microsoft/'>Microsoft</a><a class="tag-a" href='/tag/mit/'>MIT</a><a class="tag-a" href='/tag/mozilla/'>Mozilla</a><a class="tag-a" href='/tag/nvidia/'>NVIDIA</a><a class="tag-a" href='/tag/oracle/'>Oracle</a><a class="tag-a" href='/tag/samsung/'>Samsung</a><a class="tag-a" href='/tag/stack-overflow/'>Stack Overflow</a><a class="tag-a" href='/tag/telegram/'>Telegram</a><a class="tag-a" href='/tag/windows/'>Windows</a><a class="tag-a" href='/tag/vkontakte/'>ВКонтакте</a><a class="tag-a" href='/tag/rkn/'>Роскомнадзор</a><a class="tag-a" href='/tag/yandex/'>Яндекс</a></div><div class="tag-category" data-tag="fields"><h3>По направлениям</h3><a class="tag-a" href='/tag/big-data/'>Big Data</a><a class="tag-a" href='/tag/data-science/'>Data Science</a><a class="tag-a" href='/tag/devops/'>DevOps</a><a class="tag-a" href='/tag/hardware/'>Hardware</a><a class="tag-a" href='/tag/hr/'>HR</a><a class="tag-a" href='/tag/bots/'>Боты</a><a class="tag-a" href='/tag/blockchain/'>Блокчейн</a><a class="tag-a" href='/tag/veb-design/'>Веб-дизайн</a><a class="tag-a" href='/tag/web/'>Веб-разработка</a><a class="tag-a" href='/tag/virtual-reality/'>Виртуальная реальность</a><a class="tag-a" href='/tag/interface-design-ux/'>Дизайн интерфейсов и UX</a><a class="tag-a" href='/tag/augmented-reality/'>Дополненная реальность</a><a class="tag-a" href='/tag/iot/'>Интернет вещей</a><a class="tag-a" href='/tag/ai/'>Искусственный интеллект</a><a class="tag-a" href='/tag/quantum-computing/'>Квантовые вычисления</a><a class="tag-a" href='/tag/computer-graphics/'>Компьютерная графика</a><a class="tag-a" href='/tag/computer-vision/'>Компьютерное зрение</a><a class="tag-a" href='/tag/cryptocurrency/'>Криптовалюты</a><a class="tag-a" href='/tag/crypto/'>Криптография</a><a class="tag-a" href='/tag/machine-learning/'>Машинное обучение</a><a class="tag-a" href='/tag/mobiledev/'>Мобильная разработка</a><a class="tag-a" href='/tag/neural-network/'>Нейронные сети</a><a class="tag-a" href='/tag/cloud/'>Облачные технологии</a><a class="tag-a" href='/tag/gamedev/'>Разработка игр</a><a class="tag-a" href='/tag/robots/'>Роботы</a><a class="tag-a" href='/tag/sysadm/'>Системное администрирование</a><a class="tag-a" href='/tag/testing/'>Тестирование</a><a class="tag-a" href='/tag/project-management/'>Управление проектами</a><a class="tag-a" href='/tag/frontend/'>Фронтенд</a><a class="tag-a" href='/tag/math-and-probability/'>Математика и теория вероятностей</a><a class="tag-a" href='/tag/fintech/'>Финтех</a></div><div class="tag-category" data-tag="languages"><h3>По языкам и технологиям</h3><a class="tag-a" href='/tag/cpp/'>C++</a><a class="tag-a" href='/tag/c-sharp/'>C#</a><a class="tag-a" href='/tag/java/'>Java</a><a class="tag-a" href='/tag/javascript/'>JavaScript</a><a class="tag-a" href='/tag/css/'>CSS</a><a class="tag-a" href='/tag/html/'>HTML</a><a class="tag-a" href='/tag/golang/'>Golang</a><a class="tag-a" href='/tag/kotlin/'>Kotlin</a><a class="tag-a" href='/tag/php/'>PHP</a><a class="tag-a" href='/tag/python/'>Python</a><a class="tag-a" href='/tag/ruby/'>Ruby</a><a class="tag-a" href='/tag/ruby-on-rails/'>Ruby on Rails</a><a class="tag-a" href='/tag/rust/'>Rust</a><a class="tag-a" href='/tag/scala/'>Scala</a><a class="tag-a" href='/tag/sql/'>SQL</a><a class="tag-a" href='/tag/swift/'>Swift</a><a class="tag-a" href='/tag/typescript/'>TypeScript</a><a class="tag-a" href='/tag/c-language/'>Язык Си</a><a class="tag-a" href='/tag/asm/'>Язык ассемблера</a><a class="tag-a" href='/tag/r-language/'>Язык R</a><a class="tag-a" href='/tag/lua/'>Lua</a><a class="tag-a" href='/tag/objective-c/'>Objective-C</a><a class="tag-a" href='/tag/perl/'>Perl</a><a class="tag-a" href='/tag/dot-net/'>.NET</a><a class="tag-a" href='/tag/django/'>Django</a><a class="tag-a" href='/tag/docker/'>Docker</a><a class="tag-a" href='/tag/mysql/'>MySQL</a><a class="tag-a" href='/tag/node-js/'>Node.js</a><a class="tag-a" href='/tag/react/'>React</a><a class="tag-a" href='/tag/webassembly/'>WebAssembly</a></div><div class="tag-category" data-tag="others"><a class="tag-a" href='/tag/3d-printer/'>3D-принтер</a><a class="tag-a" href='/tag/agile/'>Agile</a><a class="tag-a" href='/tag/android/'>Android</a><a class="tag-a" href='/tag/api/'>API</a><a class="tag-a" href='/tag/arduino/'>Arduino</a><a class="tag-a" href='/tag/asp-net/'>Asp.NET</a><a class="tag-a" href='/tag/bitcoin/'>Bitcoin</a><a class="tag-a" href='/tag/deepmind/'>DeepMind</a><a class="tag-a" href='/tag/diy/'>DIY</a><a class="tag-a" href='/tag/ethereum/'>Ethereum</a><a class="tag-a" href='/tag/f8-2017/'>F8 2017</a><a class="tag-a" href='/tag/firefox/'>Firefox</a><a class="tag-a" href='/tag/git/'>Git</a><a class="tag-a" href='/tag/google-chrome/'>Google Chrome</a><a class="tag-a" href='/tag/google-io-2017/'>Google I/O 2017</a><a class="tag-a" href='/tag/gtc-2017/'>GTC 2017</a><a class="tag-a" href='/tag/ide/'>IDE</a><a class="tag-a" href='/tag/ios/'>iOS</a><a class="tag-a" href='/tag/covid-19/'>IT во время чумы</a><a class="tag-a" href='/tag/linux/'>Linux</a><a class="tag-a" href='/tag/macos/'>macOS</a><a class="tag-a" href='/tag/build-2017/'>Microsoft Build 2017</a><a class="tag-a" href='/tag/open-source/'>Open Source</a><a class="tag-a" href='/tag/opera/'>Opera</a><a class="tag-a" href='/tag/product-development/'>Product Development</a><a class="tag-a" href='/tag/qa/'>QA</a><a class="tag-a" href='/tag/raspberry-pi/'>Raspberry Pi</a><a class="tag-a" href='/tag/reactjs/'>ReactJS</a><a class="tag-a" href='/tag/seo/'>SEO</a><a class="tag-a" href='/tag/soft-skills/'>Soft Skills</a><a class="tag-a" href='/tag/unity/'>Unity</a><a class="tag-a" href='/tag/vpn/'>VPN</a><a class="tag-a" href='/tag/wi-fi/'>Wi-Fi</a><a class="tag-a" href='/tag/windows-10/'>Windows 10</a><a class="tag-a" href='/tag/wordpress/'>WordPress</a><a class="tag-a" href='/tag/autopilot/'>Автопилот</a><a class="tag-a" href='/tag/algorithms/'>Алгоритмы</a><a class="tag-a" href='/tag/algos-and-data-structs/'>Алгоритмы и структуры данных</a><a class="tag-a" href='/tag/alisa/'>Алиса</a><a class="tag-a" href='/tag/analiz-dannyh/'>Анализ данных</a><a class="tag-a" href='/tag/software-architecture/'>Архитектура ПО</a><a class="tag-a" href='/tag/db/'>Базы данных</a><a class="tag-a" href='/tag/security/'>Безопасность</a><a class="tag-a" href='/tag/safe-code/'>Безопасный код</a><a class="tag-a" href='/tag/autopilot-2/'>Беспилотники</a><a class="tag-a" href='/tag/biotechnology/'>Биотехнологии</a><a class="tag-a" href='/tag/browsers/'>Браузеры</a><a class="tag-a" href='/tag/quick-start/'>Быстрый старт</a><a class="tag-a" href='/tag/visualization/'>Визуализация</a><a class="tag-a" href='/tag/brain-teasers/'>Головоломки</a><a class="tag-a" href='/tag/for-motivation/'>Для мотивации</a><a class="tag-a" href='/tag/for-beginners/'>Для начинающих</a><a class="tag-a" href='/tag/for-advanced/'>Для продвинутых</a><a class="tag-a" href='/tag/for-amateurs/'>Для продолжающих</a><a class="tag-a" href='/tag/expert-problems/'>Задачи повышенной сложности</a><a class="tag-a" href='/tag/middle-problems/'>Задачи умеренной сложности</a><a class="tag-a" href='/tag/games/'>Игры для программистов</a><a class="tag-a" href='/tag/tools/'>Инструменты</a><a class="tag-a" href='/tag/command-line-tools/'>Инструменты командной строки</a><a class="tag-a" href='/tag/interesting-projects/'>Интересные проекты</a><a class="tag-a" href='/tag/internet/'>Интернет</a><a class="tag-a" href='/tag/it-history/'>История IT</a><a class="tag-a" href='/tag/success-story/'>История успеха</a><a class="tag-a" href='/tag/career/'>Карьера</a><a class="tag-a" href='/tag/code-style/'>Кодстайл</a><a class="tag-a" href='/tag/compilers/'>Компиляторы</a><a class="tag-a" href='/tag/conferences/'>Конференции</a><a class="tag-a" href='/tag/good-hack/'>Красивый хак</a><a class="tag-a" href='/tag/best-practice/'>Лучшая практика</a><a class="tag-a" href='/tag/mining/'>Майнинг</a><a class="tag-a" href='/tag/arrays-and-strings/'>Массивы и строки</a><a class="tag-a" href='/tag/guest/'>Материалы от друзей Tproger</a><a class="tag-a" href='/tag/software-development/'>Методологии разработки</a><a class="tag-a" href='/tag/microservices/'>Микросервисы</a><a class="tag-a" href='/tag/multithreading/'>Многопоточность</a><a class="tag-a" href='/tag/music/'>Музыка</a><a class="tag-a" href='/tag/english/'>На английском языке</a><a class="tag-a" href='/tag/skills/'>Навыки</a><a class="tag-a" href='/tag/low-level-coding/'>Низкоуровневое программирование</a><a class="tag-a" href='/tag/obrazovanie/'>Образование</a><a class="tag-a" href='/tag/courses/'>Обучающие курсы</a><a class="tag-a" href='/tag/learn-programming/'>Обучение программированию</a><a class="tag-a" href='/tag/oop/'>Объектно-ориентированное программирование</a><a class="tag-a" href='/tag/competitive-programming/'>Олимпиадное программирование</a><a class="tag-a" href='/tag/operating-systems/'>Операционные системы</a><a class="tag-a" href='/tag/optimization/'>Оптимизация</a><a class="tag-a" href='/tag/dev-organising/'>Организация разработки</a><a class="tag-a" href='/tag/programming-concepts/'>Основные принципы программирования</a><a class="tag-a" href='/tag/debugging/'>Отладка</a><a class="tag-a" href='/tag/parsing/'>Парсинг</a><a class="tag-a" href='/tag/partnered/'>Партнёрский материал</a><a class="tag-a" href='/tag/design-patterns/'>Паттерны проектирования</a><a class="tag-a" href='/tag/performance/'>Производительность</a><a class="tag-a" href='/tag/job/'>Работа</a><a class="tag-a" href='/tag/recognition/'>Распознавание</a><a class="tag-a" href='/tag/reactive/'>Реактивное программирование</a><a class="tag-a" href='/tag/retro/'>Ретро</a><a class="tag-a" href='/tag/services/'>Сервисы</a><a class="tag-a" href='/tag/network-protocols/'>Сетевые протоколы</a><a class="tag-a" href='/tag/job-interview/'>Собеседование</a><a class="tag-a" href='/tag/advices/'>Советы</a><a class="tag-a" href='/tag/social-networks/'>Социальные сети</a><a class="tag-a" href='/tag/startups/'>Стартапы</a><a class="tag-a" href='/tag/supercomputers/'>Суперкомпьютеры</a><a class="tag-a" href='/tag/data-storage-formats/'>Форматы хранения данных</a><a class="tag-a" href='/tag/frameworks/'>Фреймворки</a><a class="tag-a" href='/tag/functional-programming/'>Функциональное программирование</a><a class="tag-a" href='/tag/meltdown-spectre/'>Чипокалипсис</a><a class="tag-a" href='/tag/cheatsheets/'>Шпаргалки</a><a class="tag-a" href='/tag/programming-languages/'>Языки программирования</a></div> </div>
</div>
</div>
<script defer src="https://tproger.ru/wp-content/cache/minify/adc36.x75398.js"></script>
<script type='text/javascript' id='tproger-elevator-js-extra'>
/* <![CDATA[ */
var tprogerElevator = {"pluginsUrl":"https:\/\/tproger.ru\/wp-content\/plugins"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/f86eb.x75398.js"></script>
<script type='text/javascript' id='mistape-front-js-extra'>
/* <![CDATA[ */
var mistape_args = {"ajaxurl":"https:\/\/tproger.ru\/wp-admin\/admin-ajax.php","nonce":"1b1001215e"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/e8bb6.x75398.js"></script>
<script type='text/javascript' id='post-views-counter-frontend-js-extra'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"ajax","requestURL":"https:\/\/tproger.ru\/wp-content\/plugins\/tproger-post-views-counter\/includes\/ajax.php","postID":"138080","nonce":"fd2d895ca5"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/9b13e.x75398.js"></script>
<script>
				const blu = {'site_url': 'https://tproger.ru', 'ajaxurl': 'https://tproger.ru/wp-admin/admin-ajax.php'};
			</script>
<div id="eventfrozen" class="event-frozen" style="display:none"></div>
</body>
</html>