В пакетном менеджере pip прекращена поддержка Python 2.7 и 3.5

Для пользователей Python 2 выпустили специальное обновление PIP 20.3.4.

Пакетный менеджер pip обновили до версии 21.0. Ключевым изменением стало прекращение поддержки Python 2.7 и 3.5, а также отказ от совместимости с записями в кэше, созданными в версиях pip < 20.0.

Однако о пользователях Python 2 тоже не забыли. Специально для них выпустили pip 20.3.4 с некоторыми исправлениями. Это последний выпуск, совместимый с Python 2. Его пользователям необходимо оставаться на старых версиях pip. Версия скрипта get-pip.py, совместимая с Python 2.7, также предоставляется отдельно.

Источник: Python.org