
<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#  profile: http://ogp.me/ns/profile# fb: http://ogp.me/ns/fb#" lang="ru-RU">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="preload" href="/wp-content/fonts/Roboto-Regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" as="image" href="/wp-content/themes/bliss/assets/img/logo.svg">
<link rel="preconnect" href="https://mc.yandex.ru">
<link rel="preconnect" href="https://mc.yandex.ru" crossorigin>
<link rel="preconnect" href="https://vk.com">
<link rel="preconnect" href="https://cdn.onesignal.com">
<link rel="preconnect" href="https://onesignal.com" crossorigin>
<link rel="preconnect" href="https://tproger.ru" crossorigin>
<link rel="preconnect" href="https://sentry.tproger.ru" crossorigin>
<link rel="dns-prefetch" href="https://track.tproger.ru">
<link rel="preconnect" href="https://comments.tproger.ru" crossorigin>
<script defer src="https://tproger.ru/wp-content/themes/bliss/assets/js/sentry.es6.min.x34751.js" onload="Sentry.init({ dsn: 'https://63f279b4a66348b9ade9e95f8bcb2e0e@sentry.tproger.ru/5302604', environment: 'tproger.ru', release: 'd8a8ed92f972ebda1a7abd1ab02aef2a9443091f', tracesSampleRate: 0, beforeSend(event) { return ((window.ses = window.ses ? window.ses + 1 : 1) > 16) ? null : event }, }); window.setAnalyticsSentryTags && setAnalyticsSentryTags()"></script>

<title>«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире — новости на Tproger</title>
<meta name="description" content="«Яндекс» показала новую технологию, которая автоматически переводит видео с английского и озвучивает его на русском в режиме реального времени." />
<link rel="canonical" href="https://tproger.ru/news/jandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire/" />
<meta property="og:locale" content="ru_RU" />
<meta property="og:type" content="article" />
<meta property="og:title" content="«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире" />
<meta property="og:description" content="«Яндекс» показала новую технологию, которая автоматически переводит видео с английского и озвучивает его на русском в режиме реального времени." />
<meta property="og:url" content="https://tproger.ru/news/jandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire/" />
<meta property="og:site_name" content="Tproger" />
<meta property="article:publisher" content="https://www.facebook.com/tproger/" />
<meta property="article:published_time" content="2021-07-16T07:39:55+00:00" />
<meta property="article:modified_time" content="2021-07-16T07:58:00+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:image" content="https://tproger.ru/og/image/tw/170867.jpeg" />
<meta name="twitter:creator" content="@tproger" />
<meta name="twitter:site" content="@tproger" />
<meta name="author" content="Андрей Борисов" />

<link rel="amphtml" href="https://tproger.ru/news/jandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire/amp/" /><link rel='dns-prefetch' href='//tproger.ru' />
<link rel="alternate" type="application/rss+xml" title="Tproger &raquo; Лента" href="https://tproger.ru/feed/" />
<script defer src="https://tproger.ru/wp-content/cache/minify/8de3c.x34751.js"></script>
<script async src="https://tproger.ru/wp-content/cache/minify/3f2c6.x34751.js"></script>
<meta property="vk:image" content="https://tproger.ru/og/image/vk/170867.jpeg" />
<link rel="https://api.w.org/" href="https://tproger.ru/wp-json/" /><link rel="alternate" type="application/json" href="https://tproger.ru/wp-json/wp/v2/posts/170867" /><link rel='shortlink' href='https://tproger.ru/?p=170867' />
<link rel="icon" href="/favicon.ico?v=2">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="192x192" href="/android-chrome-192x192.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#2aa5a0">
<meta name="apple-mobile-web-app-title" content="Tproger">
<meta name="application-name" content="Tproger">
<meta name="theme-color" content="#2aa5a0">
</head>
<body class="post-template-default single single-post postid-170867 single-format-standard dark">
<style id="fake-style">
				@font-face {
		font-family: 'Roboto';
		src:
			local('Roboto Medium'),
			local('Roboto-Medium'),
			url('/wp-content/fonts/Roboto-Medium.woff2') format('woff2'),
			url('/wp-content/fonts/Roboto-Medium.woff') format('woff'),
			url('/wp-content/fonts/Roboto-Medium.ttf') format('truetype');
		font-weight: 500;
		font-style: normal;
		font-display: swap;
	}
	body {
		margin: 0;
	}
	.dark {
		background: #2b2a29;
	} 			#fake-post {
				display: block;
				position: fixed;
				top: 127px;
				padding-top: 0px;
				width: 100%;
				height: 100%;
				z-index: 0;
				background: #fff;
			}
			#fake-header {
				margin: 15px 15px 0;
				font-size: 26px;
				font-family: Roboto, sans-serif;
				font-weight: 500;
				line-height: 1.3;
				color: #333;
				
				 
			}
			#fake-scroll {
				display: none;
			}
			@media (min-width: 481px) {
				#fake-post {
					top: 128px;
					left: 20px;
					width: calc(100% - 40px);
					height: 100%;
					border-radius: 4px 4px 0 0;
					padding-top: 0;
				}
				#fake-header {
					padding: 15px 20px 66px 20px;
					margin: 0;
					font-size: 30px;
					 
				}
				#fake-scroll {
					display: block;
					position: relative;
					top: 101vh;
					width: 1px;
					height: 1px;
				}
			}
			@media (min-width: 768px) {
				#fake-header {
					padding: 35px 50px 66px 50px;
					font-size:30px;
					 
				}
			}
			@media (min-width: 977px) {
				#fake-post {
					top: 83px;
					left: calc((100% - 940px) / 2);
					width: 620px;
				}
			}
			@media (min-width: 1320px) {
				#fake-post {
					left: calc((100% - 1270px) / 2);
					width: 880px;
				}
				#fake-header {
					padding: 50px 105px 66px 105px;
					font-size: 34px;
					 
				}
			}
			</style>
<div id="fake-post">
<h1 id="fake-header">«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире</h1>
</div>
<div id="fake-scroll"></div>
<link rel="stylesheet" href="https://tproger.ru/wp-content/cache/minify/87d75.x34751.css" media="all" />
<div id="page" style="display: none;" class="site">
<div id="tproger-login"></div>
<header id="masthead" role="banner" class="">
<div id="header-container">
<div id="reading-progress"></div>
<nav id="header" role="navigation" class="windowed">
<div class="header-toogle">
<div id="main-menu-toggle" class="header-item">
<input id="main-menu-toggle-input" type="checkbox" />
<div id="menu-cover"></div>
<span class="main-menu-toggle-span"></span>
<span class="main-menu-toggle-span"></span>
<span class="main-menu-toggle-span"></span>
<ul id="main-menu" class="show-on-idle"><li id="menu-item-116231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Лента" class="main-menu-a"><i class="icon-menu-hot menu-icons"></i>Лента<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116232" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/" title="Сначала новое" class="main-menu-a"><i class="icon- menu-icons"></i>Сначала новое</a></li> <li id="menu-item-116233" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/hot/" title="Набирает популярность" class="main-menu-a"><i class="icon- menu-icons"></i>Набирает популярность</a></li> <li id="menu-item-116235" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/week/" title="Лучшее за неделю" class="main-menu-a"><i class="icon- menu-icons"></i>Лучшее за неделю</a></li> <li id="menu-item-116236" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/month/" title="Лучшее за месяц" class="main-menu-a"><i class="icon- menu-icons"></i>Лучшее за месяц</a></li> <li id="menu-item-116237" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/top/ever/" title="Лучшее за всё время" class="main-menu-a"><i class="icon- menu-icons"></i>Лучшее за всё время</a></li>
</ul>
</li><li id="menu-item-144836" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/editor/?utm_source=sidebar" title="Написать пост" class="main-menu-a"><i class="icon-edit menu-icons"></i>Написать пост</a></li><li id="menu-item-116286" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/jobs/?utm_source=tproger_ru_main_menu" title="Вакансии" class="main-menu-a"><i class="icon-menu-job menu-icons"></i>Вакансии</a></li><li id="menu-item-85895" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a title="События и курсы, на которых можно поднять свой уровень" href="/events/" title="События и курсы" class="main-menu-a"><i class="icon-menu-time menu-icons"></i>События и курсы</a></li><li id="menu-item-163320" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/category/interactive/" title="Игры" class="main-menu-a"><i class="icon-games menu-icons"></i>Игры</a></li><li id="menu-item-116238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Рубрики" class="main-menu-a"><i class="icon-menu-heading menu-icons"></i>Рубрики<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116246" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/curriculum/" title="Планы обучения" class="main-menu-a"><i class="icon- menu-icons"></i>Планы обучения</a></li> <li id="menu-item-12274" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Задачи с IT-собеседований" href="https://tproger.ru/problems/" title="Задачки" class="main-menu-a"><i class="icon- menu-icons"></i>Задачки</a></li> <li id="menu-item-73978" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Тесты и викторины" href="https://tproger.ru/quiz/" title="Тесты и викторины" class="main-menu-a"><i class="icon- menu-icons"></i>Тесты и викторины</a></li> <li id="menu-item-116243" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/books/" title="Книги" class="main-menu-a"><i class="icon- menu-icons"></i>Книги</a></li> <li id="menu-item-116240" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/video/" title="Видео" class="main-menu-a"><i class="icon- menu-icons"></i>Видео</a></li> <li id="menu-item-116244" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/explain/" title="Коротко о главном" class="main-menu-a"><i class="icon- menu-icons"></i>Коротко о главном</a></li> <li id="menu-item-21201" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a title="Ответы экспертов на вопросы читателей" href="https://tproger.ru/experts/" title="Советы экспертов" class="main-menu-a"><i class="icon- menu-icons"></i>Советы экспертов</a></li> <li id="menu-item-116249" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/articles/" title="Статьи" class="main-menu-a"><i class="icon- menu-icons"></i>Статьи</a></li> <li id="menu-item-116245" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/translations/" title="Переводы" class="main-menu-a"><i class="icon- menu-icons"></i>Переводы</a></li> <li id="menu-item-116247" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/digest/" title="Подборки" class="main-menu-a"><i class="icon- menu-icons"></i>Подборки</a></li> <li id="menu-item-116239" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/devnull/" title="Юмор" class="main-menu-a"><i class="icon- menu-icons"></i>Юмор</a></li> <li id="menu-item-116241" class="menu-item menu-item-type-taxonomy menu-item-object-category tag-menu-item navigation__dropdown-item"><a href="https://tproger.ru/interview/" title="Интервью" class="main-menu-a"><i class="icon- menu-icons"></i>Интервью</a></li>
</ul>
</li><li id="menu-item-116254" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Темы" class="main-menu-a"><i class="icon-menu-topics menu-icons"></i>Темы<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116253" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/for-beginners/" title="Для начинающих" class="main-menu-a"><i class="icon- menu-icons"></i>Для начинающих</a></li> <li id="menu-item-116257" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/algorithms/" title="Алгоритмы" class="main-menu-a"><i class="icon- menu-icons"></i>Алгоритмы</a></li> <li id="menu-item-116258" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/design-patterns/" title="Паттерны проектирования" class="main-menu-a"><i class="icon- menu-icons"></i>Паттерны проектирования</a></li> <li id="menu-item-116260" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/software-development/" title="Методологии разработки" class="main-menu-a"><i class="icon- menu-icons"></i>Методологии разработки</a></li> <li id="menu-item-116255" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/web/" title="Веб-разработка" class="main-menu-a"><i class="icon- menu-icons"></i>Веб-разработка</a></li> <li id="menu-item-116256" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/gamedev/" title="Разработка игр" class="main-menu-a"><i class="icon- menu-icons"></i>Разработка игр</a></li> <li id="menu-item-116262" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/mobiledev/" title="Мобильная разработка" class="main-menu-a"><i class="icon- menu-icons"></i>Мобильная разработка</a></li> <li id="menu-item-116259" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/machine-learning/" title="Машинное обучение" class="main-menu-a"><i class="icon- menu-icons"></i>Машинное обучение</a></li> <li id="menu-item-116264" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/neural-network/" title="Нейронные сети" class="main-menu-a"><i class="icon- menu-icons"></i>Нейронные сети</a></li> <li id="menu-item-116263" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/ai/" title="Искусственный интеллект" class="main-menu-a"><i class="icon- menu-icons"></i>Искусственный интеллект</a></li> <li id="menu-item-116266" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/data-science/" title="Data Science" class="main-menu-a"><i class="icon- menu-icons"></i>Data Science</a></li> <li id="menu-item-116265" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/interface-design-ux/" title="Дизайн интерфейсов и UX" class="main-menu-a"><i class="icon- menu-icons"></i>Дизайн интерфейсов и UX</a></li> <li id="menu-item-116261" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/sysadm/" title="Системное администрирование" class="main-menu-a"><i class="icon- menu-icons"></i>Системное администрирование</a></li> <li id="menu-item-116294" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item divider navigation__dropdown-item"><a href="/" title="&#8212;" class="main-menu-a"><i class="icon- menu-icons"></i>&#8212;</a></li> <li id="menu-item-116291" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="#tagsModal" title="Все темы" class="main-menu-a"><i class="icon- menu-icons"></i>Все темы</a></li>
</ul>
</li><li id="menu-item-116269" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown tag-menu-item navigation__dropdown-item"><a href="javascript:void(0);" title="Языки" class="main-menu-a"><i class="icon-menu-terminal menu-icons"></i>Языки<i class="icon-angle-down"></i></a>
<ul class="dropdown-menu">
<li id="menu-item-116272" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/python/" title="Python" class="main-menu-a"><i class="icon- menu-icons"></i>Python</a></li> <li id="menu-item-116270" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/javascript/" title="JavaScript" class="main-menu-a"><i class="icon- menu-icons"></i>JavaScript</a></li> <li id="menu-item-116275" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/go/" title="Golang" class="main-menu-a"><i class="icon- menu-icons"></i>Golang</a></li> <li id="menu-item-116276" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/java/" title="Java" class="main-menu-a"><i class="icon- menu-icons"></i>Java</a></li> <li id="menu-item-116273" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/cpp/" title="C++" class="main-menu-a"><i class="icon- menu-icons"></i>C++</a></li> <li id="menu-item-116274" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/c-sharp/" title="C#" class="main-menu-a"><i class="icon- menu-icons"></i>C#</a></li> <li id="menu-item-116277" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/php/" title="PHP" class="main-menu-a"><i class="icon- menu-icons"></i>PHP</a></li> <li id="menu-item-116278" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/css/" title="CSS" class="main-menu-a"><i class="icon- menu-icons"></i>CSS</a></li> <li id="menu-item-116279" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/sql/" title="SQL" class="main-menu-a"><i class="icon- menu-icons"></i>SQL</a></li> <li id="menu-item-136633" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/swift/" title="Swift" class="main-menu-a"><i class="icon- menu-icons"></i>Swift</a></li> <li id="menu-item-136634" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/c-language/" title="Язык Си" class="main-menu-a"><i class="icon- menu-icons"></i>Язык Си</a></li> <li id="menu-item-136635" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/asm/" title="Язык ассемблера" class="main-menu-a"><i class="icon- menu-icons"></i>Язык ассемблера</a></li> <li id="menu-item-136636" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/r-language/" title="Язык R" class="main-menu-a"><i class="icon- menu-icons"></i>Язык R</a></li> <li id="menu-item-136637" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/objective-c/" title="Оbjective-С" class="main-menu-a"><i class="icon- menu-icons"></i>Оbjective-С</a></li> <li id="menu-item-136638" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/perl/" title="Perl" class="main-menu-a"><i class="icon- menu-icons"></i>Perl</a></li> <li id="menu-item-136639" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/dot-net/" title=".NET" class="main-menu-a"><i class="icon- menu-icons"></i>.NET</a></li> <li id="menu-item-136640" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/django/" title="Django" class="main-menu-a"><i class="icon- menu-icons"></i>Django</a></li> <li id="menu-item-136641" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/docker/" title="Docker" class="main-menu-a"><i class="icon- menu-icons"></i>Docker</a></li> <li id="menu-item-136642" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/mysql/" title="MySQL" class="main-menu-a"><i class="icon- menu-icons"></i>MySQL</a></li> <li id="menu-item-136643" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/node-js/" title="Node.js" class="main-menu-a"><i class="icon- menu-icons"></i>Node.js</a></li> <li id="menu-item-136644" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/react/" title="React" class="main-menu-a"><i class="icon- menu-icons"></i>React</a></li> <li id="menu-item-136645" class="menu-item menu-item-type-custom menu-item-object-custom tag-menu-item navigation__dropdown-item"><a href="/tag/webassembly/" title="WebAssembly" class="main-menu-a"><i class="icon- menu-icons"></i>WebAssembly</a></li>
</ul>
</li>
<li class="hide-on-desktop dropdown menu-item">
<a href="/ad/" class="main-menu-a main-menu__advertising">Реклама на tproger.ru</a>
</li>
<li class="hide-on-desktop last-main-menu menu-item">
<span class="main-menu-a">Контакты для сотрудничества:</span>
<span class="main-menu-a">Телефон:&nbsp;<a href="tel:+7 916 559-71-10">+7 916 559-71-10</a></span>
<span class="main-menu-a">E-mail:&nbsp;<a href="mailto:sales@tproger.ru">sales@tproger.ru</a></span>
</li>
</ul> </div>
</div>
<div id="header-logo">
<a id="main-logo" class="header-item header-clickable" href="https://tproger.ru"> <img src="/wp-content/themes/bliss/assets/img/logo.svg" alt="Логотип Tproger" width="30" height="30">
<span id="logo-text" class="hide-on-mobile hide-on-narrow">Tproger</span>
</a> </div>
<div class="header-right">
<a id="editor-button" href="/editor/?utm_source=desktop-header-button" class="icon-edit hoverable" title="Написать пост"><span class="editor-button__text">Написать&nbsp;пост</span></a>
<a id="search-button" href="/search/" class="header-item header-clickable icon-search" title="Поиск по сайту"></a>
<a id="tproger-login-button" class="header-item hoverable"></a>
</div>
</nav>
<div class="search">
<div class="search__container">
<form method="get" action="/search" class="search__form">
<input name="searchid" type="hidden" value="2415386">
<input name="text" maxlength="128" class="search__input" placeholder="Поиск по сайту">
<input name="web" type="hidden" value="0">
<button class="search__submit icon-search hoverable" type="submit"></button>
</form>
<div class="search__header">Популярные темы</div>
<div class="search__popular">
<a class="search__popular_link" href="/python/">Python</a><a class="search__popular_link" href="/cpp/">С++</a><a class="search__popular_link" href="/javascript/">JavaScript</a><a class="search__popular_link" href="/tag/web/">Web-разработка</a><a class="search__popular_link" href="/problems/">Задачи с разбором</a><a class="search__popular_link" href="/tag/gamedev/">Разработка игр</a><a class="search__popular_link" href="/quiz/">Тесты и викторины</a><a class="search__popular_link" href="/tag/for-beginners/">Для начинающих</a> </div>
</div>
</div>
</div>
<div class="header-searchbox" id="searchbox" style="display: none;">
<form method="get" action="/search">
<div class="header-searchbox-input-wrapper">
<input name="searchid" type="hidden" value="2415386">
<input name="text" maxlength="128" class="header-searchbox-input" placeholder="Что ищем?">
<input name="web" type="hidden" value="0">
<span class="header-searchbox-input-cancel icon-close"></span>
</div>
</form>
</div>
</header>


<div id="main" class="windowed">
<div id="above-content-container" data-loaded="no"><a id="above-content-link" class="mobile-show-on-idle" href="https://t.me/joinchat/RPeksuQCqdI3YzNi" rel="nofollow"><div id="above-content-button" class="box"><i id="above-content-image" class="colored icon-telegram"></i>Читать новости в Telegram</div></a></div> <div id="tproger_ads_widget-4" style="display:none;" class='tproger-widget float-widget-container subscription-widget' data-ad data-type="2">
<div class="float-widget">
<a class="float-widget-a" href="" target="_blank" rel="noopener">
<div class="float-widget-blocks">
<div class="box float-widget-text">Tproger.ru</div>
<div class="float-widget-btn float-widget-positive-btn"></div>
<div class="float-widget-btn float-widget-negative-btn">Закрыть</div>
</div>
<div class="float-widget-close-btn" id="float-widget-close-btn" style="display:none;">✕</div>
<img class="no-lazy-img float-widget-img lazy" src="" decoding="async">
</a>
</div>
</div>
<div id="primary" class="row right_side">
<div id="content" role="main">
<article id="post-170867" class="box single post-170867 post type-post status-publish format-standard hentry category-news tag-machine-learning tag-yandex" itemscope itemtype="http://schema.org/NewsArticle">
<div class="sticky-header show-on-idle layout-boundary">
<div class="sticky-header-container content-windowed">
<div class="sticky-caption">«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире</div>
<div class="sticky-icons" data-container-loaded="no">
<div class="meta-content post-tool-block">
<div class="tproger-comment-count" data-loaded="no" data-post="170867"></div>
<div class="tproger-bookmark" data-loaded="no" data-post="170867"></div>
<div class="sharing-button-contaier sharing-button-contaier--slide-down">
<div class="sharing-button hoverable icon-share"></div>
</div>
</div>
<div id="close-post" class="close-post icon-close hoverable"></div>
</div>
</div>
</div>
<div class="post-title">
<h1 class="entry-title" itemprop="headline">«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире</h1>
<div class="post-meta">
<div class="post-meta__item post-meta__item--break-after">

<span itemscope itemtype="http://schema.org/BreadcrumbList"> <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
<a class="post-meta__a" itemprop="item" href="https://tproger.ru/news/" title="Все посты рубрики «Новости»">
<span itemprop="name">Новости</span></a>,
<meta itemprop="position" content="1" />
</span> </span>

<time class="timeago" datetime="2021-07-16T10:39:55+03:00" itemprop="datePublished" content="2021-07-16T10:39:55+03:00" title="16 июля 2021 в 10:39 МСК">16 июля в 10:39</time>

<span class="post-views-count icon-eye" data-count="39">39</span>
<link rel="preload" as="fetch" href="/wp-content/themes/bliss/fast-ajax.php?action=get-post-views&post-id=170867" crossorigin="anonymous">
</div>
<div class="post-meta__item">

<span itemprop="author" itemscope itemtype="http://schema.org/Person"><a class="post-meta__a" itemprop="name" content="Андрей Борисов" href="/author/karpaff/" data-wpel-link="internal" rel="follow">Андрей Борисов</a></span> </div> </div>
<div class="announcement">Прототип одновременно переводит и озвучивает видео</div> </div>
<meta itemprop="image" content="https://tproger.ru/og.png">
<div class="entry-container noimg">
<meta itemprop="description" content="Прототип одновременно переводит и озвучивает видео" />
<meta itemprop="wordCount" content="134" />
<meta itemprop="dateModified" content="2021-07-16T10:58:00+03:00" />
<span itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="image" content="https://cdn.tproger.ru/android-chrome-32x32.png">
<meta itemprop="width" content="32">
<meta itemprop="height" content="32">
<link itemprop="url" href="https://cdn.tproger.ru/android-chrome-32x32.png">
</span>
<meta itemprop="name" content="Tproger">
<meta itemprop="address" content="Москва, Деловой Центр «Калибр»">
<meta itemprop="telephone" content="+7 916 559-71-10">
</span>
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://tproger.ru/news/jandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire/" content="«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире" />
<div class="entry-content" itemprop="articleBody">
<div class="post-tool-actions-sizer layout-boundary">
<div class="post-tool-actions" data-container-loaded="no">
<div class="tproger-comment-count" data-loaded="no" data-post="170867"></div>
<div class="tproger-bookmark" data-loaded="no" data-post="170867"></div>
<div class="sharing-button-contaier sharing-button-contaier--right-aligned sharing-button-contaier--slide-down">
<div class="sharing-button hoverable icon-share">Поделиться</div>
</div>
</div>
</div><h2>Что случилось</h2>
<p>«Яндекс» показала новую технологию, которая автоматически переводит видео с английского и озвучивает его на русском в режиме реального времени.&nbsp;</p>
<p>С помощью этой функции в Яндекс.Браузере можно будет спокойно смотреть и понимать ролики на английском, даже если вы не знаете иностранного языка. Всё озвучит диктор.&nbsp;</p>
<h2>Как работает</h2>
<p>Новая технология использует машинный перевод, технологии биометрии, распознавания и синтеза речи. </p>
<p>Алгоритмы определяют пол говорящего и подбирают нужный голос. Чтобы реплики совпадали по длине, технология то ускоряет, то замедляет голос переводчика.&nbsp;</p><div class="widget-in-text-ads subscription-widget" data-event><div class="internal-wrapper">
<a href="https://tproger.ru/events/chempionat-cifrovoj-proryv-2021/?utm_source=in_text" data-wpel-link="internal" rel="follow"><div data-style="background: linear-gradient(to right, rgb(255, 255, 255), rgb(255, 255, 255), rgba(255, 255, 255, 0.5) ), 
                    url(https://tproger.ru/s3/uploads/2021/06/Chempionat-Cifrovoj-proryv-2021-670x235.jpg) no-repeat center right;" class="internal-link">
<div class="internal-caption">Чемпионат по‌ ‌машинному‌ ‌обучению‌, ‌искусственному‌ ‌интеллекту‌ ‌и‌ ‌большим‌ ‌данным</div>
<p class="internal-text">14 июля – 18 августа, Онлайн, Беcплатно</p>
<div class="internal-url"><span class="post-views-icon icon-link-ext"></span><span class="internal-site">tproger.ru</span></div></div>
</a>
<div class="partnered-sign"><a href="/events/" targer="_blank" data-wpel-link="internal" rel="follow">События и курсы на tproger.ru</a></div>
</div></div><p>Вот, как это выглядит:&nbsp;</p>
<p><iframe title="Демонстрация технологию автоматического перевода и озвучивания видео от Яндекса" width="740" height="416" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-src="https://www.youtube.com/embed/4m_1FWoxyQs?feature=oembed" class=" lazy"></iframe></p>
<h2>Как попробовать</h2>
<p>Пока это только прототип. Протестировать функцию машинного перевода можно на определённых видео из <a href="https://www.youtube.com/playlist?list=PLkMNi_iVG-shtwkqd918VUJ80NIOJ2pQf" data-wpel-link="external" target="_blank" rel="nofollow noopener noreferrer">этого плейлиста</a>. Это можно сделать из Яндекс.Браузера.</p>
<p class="origin">Источник: <a href="https://www.forbes.ru/newsroom/tehnologii/435095-yandeks-protestiruet-funkciyu-zakadrovogo-perevoda-dlya-video-v-svoem" data-wpel-link="external" target="_blank" rel="nofollow noopener noreferrer">Forbes</a>,&nbsp;<a href="https://www.rbc.ru/technology_and_media/16/07/2021/60f121f49a7947ee467ed987" data-wpel-link="external" target="_blank" rel="nofollow noopener noreferrer">РБК</a></p>
<div id="article-end-beacon"></div>
<footer class="entry-meta mobile-show-on-idle layout-boundary">
<div class="article-tags"><a class="tag-a" href="https://tproger.ru/tag/machine-learning/" rel="tag" itemprop="about" itemscope itemtype="https://schema.org/Thing"><span itemprop="name" data-tag-name="Машинное обучение">Машинное обучение</span></a><a class="tag-a" href="https://tproger.ru/tag/yandex/" rel="tag" itemprop="about" itemscope itemtype="https://schema.org/Thing"><span itemprop="name" data-tag-name="Яндекс">Яндекс</span></a> </div><div class="sharing-button-contaier ">
<div class="sharing-button hoverable icon-share">Поделиться</div>
</div> <div class="tproger-mark" data-post="170867"></div>
</footer>
</div>
</div>
<span class="vcard" style="display: none;">
<span class="fn">
<a href="https://tproger.ru/author/karpaff/" class="author">Андрей Борисов</a>
</span>
</span>
</article>
<div id="after-post-widget-container" class="h-widget-container tproger-widget subscription-widget " data-place="" data-ad data-type="3" data-is-default="0">
<a href="/ad/?utm_referrer=after-post-widget-container" class="fix-widget-main-a after-post-widget-a" target="_blank" rel="noopener"> </a>
<div class="box h-widget">
<img class="no-lazy-img after-post-widget-img lazy" src="" decoding="async">
<div class="after-post-widget-text">Реклама на tproger.ru</div>
<a class="btn bluth tproger btn- after-post-widget-button" href="/ad/?utm_referrer=after-post-widget-container" target="_blank" rel="noopener">Узнать подробнее</a>
</div>
<div class="adsLinkBlockFixBaner">
<a href="/ad/?utm_referrer=after-post-widget-container" targer="_blank" class="adsLinkFixBaner" rel="noopener">Реклама на tproger.ru</a>
</div>
<div class="widget-loader">Загрузка</div>
</div>
<div id="right_event_job_widget-18" data-type="3" data-wtype="feed" data-btn-title="Все вакансии" data-btn-url="/jobs/" data-utm="jobs-widget-after-post&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс" data-rbtn-title="Разместить вакансию" data-rbtn-url="/ad/jobs/?utm_referrer=after-post#offer" data-job class="box tproger-event-job-widget subscription-widget widget-feed-type widget-after-post" style="width:100%;"><div class="widget-list"><a href="https://tproger.ru/jobs/specialist-po-mashinnomu-obucheniju-middle/?utm_source=jobs-widget-after-post&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2018/11/mytona-logo-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2018/11/mytona-logo-32x32.png, https://tproger.ru/s3/uploads/2018/11/mytona-logo-50x50.png 1.5x, https://tproger.ru/s3/uploads/2018/11/mytona-logo-90x90.png 2x, https://tproger.ru/s3/uploads/2018/11/mytona-logo-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Специалист по машинному обучению (Middle)</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">full-time</span></div></div></div></a><div class="widget-list-footer"><a href="/jobs/?utm_source=jobs-widget-after-post" class="show-more-widget hoverable">Все вакансии<span class="icon-right-open vertical-middle"></span></a><div class="widget-list-footer-right"> <a href="/ad/jobs/?utm_referrer=after-post#offer" class="btn bluth tproger margin-top-10">Разместить вакансию</a> </div></div></div></div><div id="related-posts" class="entry-content box" data-post-id="170867"><h3 id="related-posts-header"><i class="colored icon-fire"></i>Также рекомендуем</h3><ul class="related-posts show-on-idle"><a href="https://tproger.ru/digest/learning-neuroweb-all-for-begin/" data-target-post-id="12126" class="related-post-target-link" target="_blank"><li class="related-post hoverable"><img width="50" height="50" src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" class="attachment-50x50 size-50x50 wp-post-image lazy" alt="" data-id="12136" data-src="https://tproger.ru/s3/uploads/2016/01/NW_RD-80x80.jpg" data-srcset="https://tproger.ru/s3/uploads/2016/01/NW_RD-80x80.jpg, https://tproger.ru/s3/uploads/2016/01/NW_RD-80x80.jpg 1.5x, https://tproger.ru/s3/uploads/2016/01/NW_RD-150x150.jpg 2x, https://tproger.ru/s3/uploads/2016/01/NW_RD-150x150.jpg 3x" decoding="async"><div class="widget-list-item-right "><div class="widget-list-item-caption related-posts-caption">Изучаем нейронные сети: с чего начать</div></div></li></a><a href="https://tproger.ru/translations/learning-neural-networks/" data-target-post-id="19971" class="related-post-target-link" target="_blank"><li class="related-post hoverable"><img width="50" height="50" src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" class="attachment-50x50 size-50x50 wp-post-image lazy" alt="" data-id="152980" data-src="https://tproger.ru/s3/uploads/2021/03/nn-icon-cover-50x50.png" data-srcset="https://tproger.ru/s3/uploads/2021/03/nn-icon-cover-50x50.png, https://tproger.ru/s3/uploads/2021/03/nn-icon-cover-90x90.png 1.5x, https://tproger.ru/s3/uploads/2021/03/nn-icon-cover-150x150.png 2x, https://tproger.ru/s3/uploads/2021/03/nn-icon-cover-150x150.png 3x" decoding="async"><div class="widget-list-item-right "><div class="widget-list-item-caption related-posts-caption">Изучаем нейронные сети за четыре шага</div></div></li></a><a href="https://tproger.ru/translations/neural-network-zoo-1/" data-target-post-id="21784" class="related-post-target-link" target="_blank"><li class="related-post hoverable"><img width="50" height="50" src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" class="attachment-50x50 size-50x50 wp-post-image lazy" alt="" data-id="150901" data-src="https://tproger.ru/s3/uploads/2021/03/iconfinder_Neural_network_2844558-cover-50x50.png" data-srcset="https://tproger.ru/s3/uploads/2021/03/iconfinder_Neural_network_2844558-cover-50x50.png, https://tproger.ru/s3/uploads/2021/03/iconfinder_Neural_network_2844558-cover-90x90.png 1.5x, https://tproger.ru/s3/uploads/2021/03/iconfinder_Neural_network_2844558-cover-150x150.png 2x, https://tproger.ru/s3/uploads/2021/03/iconfinder_Neural_network_2844558-cover-150x150.png 3x" decoding="async"><div class="widget-list-item-right "><div class="widget-list-item-caption related-posts-caption">Шпаргалка по разновидностям нейронных сетей. Часть первая. Элементарные конфигурации</div></div></li></a><a href="https://tproger.ru/articles/python-roadmap/" data-target-post-id="132274" class="related-post-target-link" target="_blank"><li class="related-post hoverable"><img width="50" height="50" src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;50px&quot; viewBox=&quot;0 0 50 50&quot;%3E%3C/svg%3E" class="attachment-50x50 size-50x50 wp-post-image lazy" alt="" data-id="132307" data-src="https://tproger.ru/s3/uploads/2020/08/iconfinder_356_-Roadmap-_interaction_communication_essential_1451052-cover-50x50.png" data-srcset="https://tproger.ru/s3/uploads/2020/08/iconfinder_356_-Roadmap-_interaction_communication_essential_1451052-cover-50x50.png, https://tproger.ru/s3/uploads/2020/08/iconfinder_356_-Roadmap-_interaction_communication_essential_1451052-cover-90x90.png 1.5x, https://tproger.ru/s3/uploads/2020/08/iconfinder_356_-Roadmap-_interaction_communication_essential_1451052-cover-150x150.png 2x, https://tproger.ru/s3/uploads/2020/08/iconfinder_356_-Roadmap-_interaction_communication_essential_1451052-cover-150x150.png 3x" decoding="async"><div class="widget-list-item-right "><div class="widget-list-item-caption related-posts-caption">Программирование на Python с нуля: дорожная карта разработчика</div></div></li></a></ul></div><div id="tproger-comment-widget" class="lazy" data-lazy-function="loadComments">
<div id="comments"></div>
</div>
</div>
<aside id="side-bar" data-container-loaded="no" data-container-loaded-callback="sideBarInit" data-container-loaded-max-seconds="10" class="widget-area">
<div id="sidebar__inner"> <div id="tproger_ads_widget-3" style="display: none;" class='fix-widget-container tproger-widget subscription-widget' data-loaded="no" data-ad data-type="1" data-place="">
<a href="#" target="_blank" class="fix-widget-main-a" style="color: unset;" rel="noopener"></a>
<div class="fix-widget-content">
<img src="" class="no-lazy-img fix-widget-img lazy" decoding="async">
<p class="fix-widget-text"></p>
<a href="#" target="_blank" class="widget-button-bottom fix-widget-button" rel="noopener">Узнать подробнее</a>
</div>
<div class="fix-widget-close-btn icon-close hoverable"></div>
<div class="adsLinkBlockFixBaner">
<a href="/ad/" targer="_blank" class="adsLinkFixBaner" rel="noopener">Реклама на tproger.ru</a>
</div>
</div>
<div id="bl_html-34" class="cleanwidget  nopadding box bl_html"> <div class="widget-body"><div class="dn21">
<a href="https://tprg.ru/Z50R">
<div class="dn21__left">
<div class="dn21__text">Инсайты по трендам и призы для программистов</div>
<button class="dn21__button">Подробнее</button>
</div>
<img src="/wp-content/uploads/custom/dn21-logo.png" srcset="/wp-content/uploads/custom/dn21-logo@2x.png 2x" class="dn21__img skip-lazy" decoding="async">
</a>
</div>
<style>
.dn21__button {
  border: 0;
  background: #F42C53;
  font-weight: 500;
  color: #fff;
  margin: 0 0 20px 20px;
  font-size: 16px;
}
.dn21__button:hover {
  opacity: .85;
}
.dn21__text {
  color: #fff;
  font-size: 18px;
  line-height: 1.3;
  padding: 17px 0 13px 20px;
  font-weight: 500;
  width: min(66%, 220px);
}
.dn21__left {
  position: absolute;
}
.dn21 {
  background: #330D7B;
  height: 144px;
  border-radius: 3px;
}
.dn21__img {
  float: right;
  margin-right: -20px;
}
@media (min-width: 1319px) {
  .dn21__left {
    margin-left: 20px;
  }
}
</style></div>
</div> <a id="tproger-editor-widget" class="tproger-editor-widget box" href="/editor/?utm_source=sidebar" data-widget-id="editor_widget-2">
<div class="text-redirect-editor">Написать пост</div>
<img alt="keyboard-images" class="keyboard-images lazy" data-src="/wp-content/themes/bliss/assets/img/tproger-widget-posts-347.png" data-srcset="
            /wp-content/themes/bliss/assets/img/tproger-widget-posts-174.png 1x,
            /wp-content/themes/bliss/assets/img/tproger-widget-posts-347.png 2x" decoding="async">
</a><div id="right_event_job_widget-8" data-type="10" data-wtype="sidebar" data-btn-title="Все события и курсы" data-btn-url="/events/" data-utm="tproger_events_right_sidebar&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс" data-rbtn-title="" data-rbtn-url="" data-event class="box tproger-event-job-widget subscription-widget nopadding widget-sidebar-type" style="width:100%;"><div class="widget-list"><a href="https://tproger.ru/events/data-science-meetup-2/?utm_source=tproger_events_right_sidebar&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/07/Data-Science-Meetup-lg-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/07/Data-Science-Meetup-lg-32x32.png, https://tproger.ru/s3/uploads/2021/07/Data-Science-Meetup-lg-50x50.png 1.5x, https://tproger.ru/s3/uploads/2021/07/Data-Science-Meetup-lg-90x90.png 2x, https://tproger.ru/s3/uploads/2021/07/Data-Science-Meetup-lg-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Data Science Meetup</div><div class="widget-list-description">21 июля в 18:00, онлайн, беcплатно</div></div></div></a><a href="https://tproger.ru/events/python-evrone-meetup/?utm_source=tproger_events_right_sidebar&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/04/Novyj-proekt-1_tilda4078338-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/04/Novyj-proekt-1_tilda4078338-32x32.png, https://tproger.ru/s3/uploads/2021/04/Novyj-proekt-1_tilda4078338-50x50.png 1.5x, https://tproger.ru/s3/uploads/2021/04/Novyj-proekt-1_tilda4078338-90x90.png 2x, https://tproger.ru/s3/uploads/2021/04/Novyj-proekt-1_tilda4078338-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Python Evrone Meetup</div><div class="widget-list-description">22 июля в 19:00, онлайн, беcплатно</div></div></div></a><a href="https://tproger.ru/events/chempionat-cifrovoj-proryv-2021/?utm_source=tproger_events_right_sidebar&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/05/Cifrovoj-proryv-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/05/Cifrovoj-proryv-32x32.png, https://tproger.ru/s3/uploads/2021/05/Cifrovoj-proryv-50x50.png 1.5x, https://tproger.ru/s3/uploads/2021/05/Cifrovoj-proryv-90x90.png 2x, https://tproger.ru/s3/uploads/2021/05/Cifrovoj-proryv-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Чемпионат по‌ ‌машинному‌ ‌обучению‌, ‌искусственному‌ ‌интеллекту‌ ‌и‌ ‌большим‌ ‌данным</div><div class="widget-list-description">14 июля – 18 августа, онлайн, беcплатно</div></div></div></a><a href="https://tproger.ru/events/kurs-professija-data-scientist-s-trudoustrojstvom/?utm_source=tproger_events_right_sidebar&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2020/10/Skillbox-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2020/10/Skillbox-32x32.png, https://tproger.ru/s3/uploads/2020/10/Skillbox-50x50.png 1.5x, https://tproger.ru/s3/uploads/2020/10/Skillbox-90x90.png 2x, https://tproger.ru/s3/uploads/2020/10/Skillbox-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Курс «Профессия Data Scientist» с трудоустройством</div><div class="widget-list-description">Постоянный доступ, онлайн, 5574&thinsp;₽ в месяц</div></div></div></a><div class="widget-list-footer"><a href="/events/?utm_source=tproger_events_right_sidebar" class="show-more-widget hoverable">Все события и курсы<span class="icon-right-open vertical-middle"></span></a></div></div></div><div id="right_event_job_widget-6" data-type="2" data-wtype="sidebar" data-btn-title="Все вакансии" data-btn-url="/jobs/" data-utm="tproger_ru_right_banner&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс" data-rbtn-title="" data-rbtn-url="" data-job class="box tproger-event-job-widget subscription-widget nopadding widget-sidebar-type" style="width:100%;"><div class="widget-list"><a href="https://tproger.ru/jobs/android-developer-2-for-aviasales/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/05/logo-2x-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/05/logo-2x-32x32.png, https://tproger.ru/s3/uploads/2021/05/logo-2x-50x50.png 1.5x, https://tproger.ru/s3/uploads/2021/05/logo-2x-90x90.png 2x, https://tproger.ru/s3/uploads/2021/05/logo-2x-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Android developer</div><div class="widget-list-description"><span class="meta-text-description__locations">Санкт-Петербург, Пхукет, Таиланд, Москва, можно удалённо</span>, <span class="meta-text-description__employment-type">full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/middle-front-end-razrabotchik-for-csssr/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/06/logo-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/06/logo-32x32.png, https://tproger.ru/s3/uploads/2021/06/logo-50x50.png 1.5x, https://tproger.ru/s3/uploads/2021/06/logo-90x90.png 2x, https://tproger.ru/s3/uploads/2021/06/logo-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Middle front-end разработчик</div><div class="widget-list-description"><span class="meta-text-description__locations">Удалённо</span>, <span class="meta-text-description__employment-type">full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/frontend-razrabotchik-vue-electron-cordova/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/04/logo-300-32x32.png" data-srcset="https://tproger.ru/s3/uploads/2021/04/logo-300-32x32.png, https://tproger.ru/s3/uploads/2021/04/logo-300-50x50.png 1.5x, https://tproger.ru/s3/uploads/2021/04/logo-300-90x90.png 2x, https://tproger.ru/s3/uploads/2021/04/logo-300-90x90.png 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Frontend-разработчик (Vue / Electron / Cordova)</div><div class="widget-list-description"><span class="meta-text-description__locations">Москва, можно удалённо</span>, <span class="meta-text-description__employment-type">full-time</span></div></div></div></a><a href="https://tproger.ru/jobs/java-razrabotchik-for-kotelov/?utm_source=tproger_ru_right_banner&utm_medium=post&utm_term=Машинное обучение&utm_term=Яндекс"><div class="widget-list-item hoverable "><div class="widget-list-item-left"><img src="data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20width=%2230px%22%20viewBox=%220%200%2030%2030%22%3E%3C/svg%3E" sizes="" class="widget-list-item-image lazy" alt="" width="30" height="30" data-src="https://tproger.ru/s3/uploads/2021/06/photo_2021-06-15_14-39-16-autoconverted-32x32.jpeg" data-srcset="https://tproger.ru/s3/uploads/2021/06/photo_2021-06-15_14-39-16-autoconverted-32x32.jpeg, https://tproger.ru/s3/uploads/2021/06/photo_2021-06-15_14-39-16-autoconverted-50x50.jpeg 1.5x, https://tproger.ru/s3/uploads/2021/06/photo_2021-06-15_14-39-16-autoconverted-90x90.jpeg 2x, https://tproger.ru/s3/uploads/2021/06/photo_2021-06-15_14-39-16-autoconverted-90x90.jpeg 3x" decoding="async"></div><div class="widget-list-item-right"><div class="widget-list-item-caption">Java разработчик</div><div class="widget-list-description"><span class="meta-text-description__locations">Санкт-Петербург</span>, <span class="meta-text-description__employment-type">full-time</span></div></div></div></a><div class="widget-list-footer"><a href="/jobs/?utm_source=tproger_ru_right_banner" class="show-more-widget hoverable">Все вакансии<span class="icon-right-open vertical-middle"></span></a></div></div></div> <div id="tproger_ads_widget-5" style="display: none;" class='fix-widget-container tproger-widget subscription-widget' data-loaded="no" data-ad data-type="1" data-place="">
<a href="#" target="_blank" class="fix-widget-main-a" style="color: unset;" rel="noopener"></a>
<div class="fix-widget-content">
<img src="" class="no-lazy-img fix-widget-img lazy" decoding="async">
<p class="fix-widget-text"></p>
<a href="#" target="_blank" class="widget-button-bottom fix-widget-button" rel="noopener">Узнать подробнее</a>
</div>
<div class="fix-widget-close-btn icon-close hoverable"></div>
<div class="adsLinkBlockFixBaner">
<a href="/ad/" targer="_blank" class="adsLinkFixBaner" rel="noopener">Реклама на tproger.ru</a>
</div>
</div>
</div> </aside>
</div>
</div>
<div id="cookie-notice-wrapper" style="display:none">
<div id="cookie-notice"><span class="cookie-notice-text">Обычное дело: мы используем cookie.</span> <a href="/about/cookie/" target="_blank" class="cookie-notice-about">Здесь&nbsp;можно&nbsp;узнать,&nbsp;зачем</a></div>
<div class="btn bluth tproger cookie-notice-close">Хорошо</div>
</div>
<footer id="footer" class="show-on-idle">
<div id="footer-body" class="windowed">
<div id="custom_html-2" class="widget_text span4 widget_custom_html"><div class="textwidget custom-html-widget"><div><span class="footer-header">Типичный программист</span>
<a href="/about/" class="footer-a">О&nbsp;проекте</a>
<a href="/ad/?utm_referrer=footer" class="footer-a">Реклама</a>
</div><div class="footer-dark-a-wrapper"><a href="https://tproger.ru/terms.pdf" class="footer-dark-a">Пользовательское&nbsp;соглашение</a><a href="https://tproger.ru/privacy.pdf" class="footer-dark-a">Политика&nbsp;конфиденциальности</a></div>
<div class="footer-dark-a-wrapper footer-with-logo"><a href="https://tprg.ru/regru-footer" class="footer-dark-a" data-wpel-link="external" target="_blank" rel="nofollow noopener noreferrer">Используем&nbsp;серверы&nbsp;<img src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; width=&quot;57px&quot; viewBox=&quot;0 0 57 28&quot;%3E%3C/svg%3E" class="footer-sponsor-img lazy" width="57" height="28" alt="Логотип REG.RU" data-src="https://tproger.ru/s3/uploads/custom/regru-logo.svg" decoding="async"></a></div></div></div><div id="custom_html-4" class="widget_text span4 widget_custom_html"><div class="textwidget custom-html-widget"><span class="footer-header">Наши аккаунты</span>
<span class="social-footer" itemscope itemtype="http://schema.org/Organization">
<meta itemprop="logo" content="https://cdn.tproger.ru/android-chrome-32x32.png">
<meta itemprop="url" content="https://tproger.ru">
<meta itemprop="name" content="Tproger">
<link itemprop="url" href="https://tproger.ru/">
<a class="social-footer-a icon-vkontakte" itemprop="sameAs" href="https://vk.com/tproger"></a>
<a class="social-footer-a icon-facebook" itemprop="sameAs" href="https://www.facebook.com/tproger/"></a>
<a class="social-footer-a icon-twitter" itemprop="sameAs" href="https://twitter.com/tproger"></a>
<a class="social-footer-a icon-telegram" itemprop="sameAs" href="tg://resolve?domain=tproger_official"></a>
<a class="social-footer-a icon-yazen" itemprop="sameAs" href="https://zen.yandex.ru/tproger"></a>
<a class="social-footer-a icon-rss" href="https://tproger.ru/feed/"></a>
</span>
<div id="subscribe-wrapper">
<a href="javascript:void(0)" id="subscribe-link"><i class="icon-bell"></i> Включить уведомления</a>
</div>
<span id="mistape-widget-message">
Нашли опечатку? Выделите фрагмент и отправьте нажатием Ctrl+Enter.
</span></div></div><div id="custom_html-5" class="widget_text span4 widget_custom_html"><div class="textwidget custom-html-widget"><div class="footer-contacts"><span class="footer-header">Контакты для сотрудничества</span>
<span>Телефон: <a href="tel:+79165597110">+7 916 559-71-10</a></span>
<span>E-mail: <a href="mailto:sales@tproger.ru">sales@tproger.ru</a></span>
</div></div></div> </div>
<div id="wrapfabtest">
<div class="adBanner"></div>
</div>
</footer>
</div>
<script>
window.ym=window.ym||function(){(ym.a=ym.a||[]).push(arguments)};ym.l=1*new Date();
ym(27485085, "init", {clickmap: false, trackLinks: true, accurateTrackBounce: true, webvisor: false});
</script>
<script type="text/javascript" src="https://proxy.tproger.ru/yandex-metrika.js" async></script>
<noscript><div><img src="https://mc.yandex.ru/watch/27485085" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://tproger.ru/",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://tproger.ru/search/?searchid=2415386&text={search_term_string}&web=0",
    "query-input": "required name=search_term_string"
  }
}
</script>
<div style="display:none;" class="tproger-elevator-block" id="tproger-elevator">
<div id="tproger-arrow" class="elevator-arrow icon-up-open"></div>
</div>
<script>var OneSignal = window.OneSignal || [];</script>
<script type="text/javascript" src="https://proxy.tproger.ru/vk-openapi.js" onload="window.setupVK && window.setupVK()" async="async"></script>
<script type="text/javascript" src="https://proxy.tproger.ru/onesignal-sdk.js" onload="window.setupOneSignal && window.setupOneSignal()" async="async"></script>
<script type="module" src="/wp-content/themes/bliss/assets/js/instant-page.x34751.js"></script><script>
	window.ta=window.ta||function(){(ta.q=ta.q||[]).push([new Date,...arguments])};
	ta('pageview.post', 3, { postId: 170867, pageReferrer: document.referrer });	</script><script>var widgetsNonce='2aeaf13a17';</script> <script>
	  		!function(){if('PerformanceLongTaskTiming' in window){var g=window.__tti={e:[]};
	  		g.o=new PerformanceObserver(function(l){g.e=g.e.concat(l.getEntries())});
	  		g.o.observe({entryTypes:['longtask']})}}();
	  		</script> <div id="tagsModal" style="display:none">
<div class="closebt-container close-tagsModal">
<img class="closebt lazy" alt="Закрыть" data-src="/wp-content/themes/bliss/assets/img/close-modal.svg" decoding="async"> </div>
<div class="modal-container widget_tag_cloud">
<div class="modal-tag-cloud tagcloud">
<div class="tag-category" data-tag="brands"><h3>По брендам</h3><a class="tag-a" href='/tag/adobe/'>Adobe</a><a class="tag-a" href='/tag/amazon/'>Amazon</a><a class="tag-a" href='/tag/apple/'>Apple</a><a class="tag-a" href='/tag/cloudflare/'>Cloudflare</a><a class="tag-a" href='/tag/facebook/'>Facebook</a><a class="tag-a" href='/tag/github/'>GitHub</a><a class="tag-a" href='/tag/gitlab/'>GitLab</a><a class="tag-a" href='/tag/google/'>Google</a><a class="tag-a" href='/tag/ibm/'>IBM</a><a class="tag-a" href='/tag/intel/'>Intel</a><a class="tag-a" href='/tag/jetbrains/'>JetBrains</a><a class="tag-a" href='/tag/microsoft/'>Microsoft</a><a class="tag-a" href='/tag/mit/'>MIT</a><a class="tag-a" href='/tag/mozilla/'>Mozilla</a><a class="tag-a" href='/tag/nvidia/'>NVIDIA</a><a class="tag-a" href='/tag/oracle/'>Oracle</a><a class="tag-a" href='/tag/samsung/'>Samsung</a><a class="tag-a" href='/tag/stack-overflow/'>Stack Overflow</a><a class="tag-a" href='/tag/telegram/'>Telegram</a><a class="tag-a" href='/tag/windows/'>Windows</a><a class="tag-a" href='/tag/vkontakte/'>ВКонтакте</a><a class="tag-a" href='/tag/rkn/'>Роскомнадзор</a><a class="tag-a" href='/tag/yandex/'>Яндекс</a></div><div class="tag-category" data-tag="fields"><h3>По направлениям</h3><a class="tag-a" href='/tag/big-data/'>Big Data</a><a class="tag-a" href='/tag/data-science/'>Data Science</a><a class="tag-a" href='/tag/devops/'>DevOps</a><a class="tag-a" href='/tag/hardware/'>Hardware</a><a class="tag-a" href='/tag/hr/'>HR</a><a class="tag-a" href='/tag/bots/'>Боты</a><a class="tag-a" href='/tag/blockchain/'>Блокчейн</a><a class="tag-a" href='/tag/veb-design/'>Веб-дизайн</a><a class="tag-a" href='/tag/web/'>Веб-разработка</a><a class="tag-a" href='/tag/virtual-reality/'>Виртуальная реальность</a><a class="tag-a" href='/tag/interface-design-ux/'>Дизайн интерфейсов и UX</a><a class="tag-a" href='/tag/augmented-reality/'>Дополненная реальность</a><a class="tag-a" href='/tag/iot/'>Интернет вещей</a><a class="tag-a" href='/tag/ai/'>Искусственный интеллект</a><a class="tag-a" href='/tag/quantum-computing/'>Квантовые вычисления</a><a class="tag-a" href='/tag/computer-graphics/'>Компьютерная графика</a><a class="tag-a" href='/tag/computer-vision/'>Компьютерное зрение</a><a class="tag-a" href='/tag/cryptocurrency/'>Криптовалюты</a><a class="tag-a" href='/tag/crypto/'>Криптография</a><a class="tag-a" href='/tag/machine-learning/'>Машинное обучение</a><a class="tag-a" href='/tag/mobiledev/'>Мобильная разработка</a><a class="tag-a" href='/tag/neural-network/'>Нейронные сети</a><a class="tag-a" href='/tag/cloud/'>Облачные технологии</a><a class="tag-a" href='/tag/gamedev/'>Разработка игр</a><a class="tag-a" href='/tag/robots/'>Роботы</a><a class="tag-a" href='/tag/sysadm/'>Системное администрирование</a><a class="tag-a" href='/tag/testing/'>Тестирование</a><a class="tag-a" href='/tag/project-management/'>Управление проектами</a><a class="tag-a" href='/tag/frontend/'>Фронтенд</a><a class="tag-a" href='/tag/math-and-probability/'>Математика и теория вероятностей</a><a class="tag-a" href='/tag/fintech/'>Финтех</a></div><div class="tag-category" data-tag="languages"><h3>По языкам и технологиям</h3><a class="tag-a" href='/cpp/'>C++</a><a class="tag-a" href='/tag/c-sharp/'>C#</a><a class="tag-a" href='/java/'>Java</a><a class="tag-a" href='/javascript/'>JavaScript</a><a class="tag-a" href='/tag/css/'>CSS</a><a class="tag-a" href='/tag/html/'>HTML</a><a class="tag-a" href='/tag/golang/'>Golang</a><a class="tag-a" href='/tag/kotlin/'>Kotlin</a><a class="tag-a" href='/tag/php/'>PHP</a><a class="tag-a" href='/python/'>Python</a><a class="tag-a" href='/tag/ruby/'>Ruby</a><a class="tag-a" href='/tag/ruby-on-rails/'>Ruby on Rails</a><a class="tag-a" href='/tag/rust/'>Rust</a><a class="tag-a" href='/tag/scala/'>Scala</a><a class="tag-a" href='/tag/sql/'>SQL</a><a class="tag-a" href='/tag/swift/'>Swift</a><a class="tag-a" href='/tag/typescript/'>TypeScript</a><a class="tag-a" href='/tag/c-language/'>Язык Си</a><a class="tag-a" href='/tag/asm/'>Язык ассемблера</a><a class="tag-a" href='/tag/r-language/'>Язык R</a><a class="tag-a" href='/tag/lua/'>Lua</a><a class="tag-a" href='/tag/objective-c/'>Objective-C</a><a class="tag-a" href='/tag/perl/'>Perl</a><a class="tag-a" href='/tag/dot-net/'>.NET</a><a class="tag-a" href='/tag/django/'>Django</a><a class="tag-a" href='/tag/docker/'>Docker</a><a class="tag-a" href='/tag/mysql/'>MySQL</a><a class="tag-a" href='/tag/node-js/'>Node.js</a><a class="tag-a" href='/tag/react/'>React</a><a class="tag-a" href='/tag/webassembly/'>WebAssembly</a></div><div class="tag-category" data-tag="others"><a class="tag-a" href='/tag/3d-printer/'>3D-принтер</a><a class="tag-a" href='/tag/agile/'>Agile</a><a class="tag-a" href='/tag/amd/'>AMD</a><a class="tag-a" href='/tag/android/'>Android</a><a class="tag-a" href='/tag/api/'>API</a><a class="tag-a" href='/tag/app-store/'>App Store</a><a class="tag-a" href='/tag/arduino/'>Arduino</a><a class="tag-a" href='/tag/arm/'>ARM</a><a class="tag-a" href='/tag/asp-net/'>Asp.NET</a><a class="tag-a" href='/tag/bitcoin/'>Bitcoin</a><a class="tag-a" href='/tag/deepmind/'>DeepMind</a><a class="tag-a" href='/tag/diy/'>DIY</a><a class="tag-a" href='/tag/ethereum/'>Ethereum</a><a class="tag-a" href='/tag/f8-2017/'>F8 2017</a><a class="tag-a" href='/tag/firefox/'>Firefox</a><a class="tag-a" href='/tag/fuchsia/'>Fuchsia</a><a class="tag-a" href='/tag/git/'>Git</a><a class="tag-a" href='/tag/google-chrome/'>Google Chrome</a><a class="tag-a" href='/tag/google-io-2017/'>Google I/O 2017</a><a class="tag-a" href='/tag/gtc-2017/'>GTC 2017</a><a class="tag-a" href='/tag/hololens/'>HoloLens</a><a class="tag-a" href='/tag/ide/'>IDE</a><a class="tag-a" href='/tag/ios/'>iOS</a><a class="tag-a" href='/tag/covid-19/'>IT во время чумы</a><a class="tag-a" href='/tag/json/'>JSON</a><a class="tag-a" href='/tag/linux/'>Linux</a><a class="tag-a" href='/tag/macos/'>macOS</a><a class="tag-a" href='/tag/build-2017/'>Microsoft Build 2017</a><a class="tag-a" href='/tag/nosql/'>NoSQL</a><a class="tag-a" href='/tag/open-source/'>Open Source</a><a class="tag-a" href='/tag/openai/'>OpenAI</a><a class="tag-a" href='/tag/opera/'>Opera</a><a class="tag-a" href='/tag/playstation/'>PlayStation</a><a class="tag-a" href='/tag/product-development/'>Product Development</a><a class="tag-a" href='/tag/qa/'>QA</a><a class="tag-a" href='/tag/raspberry-pi/'>Raspberry Pi</a><a class="tag-a" href='/tag/reactjs/'>ReactJS</a><a class="tag-a" href='/tag/redux/'>Redux</a><a class="tag-a" href='/tag/seo/'>SEO</a><a class="tag-a" href='/tag/slack/'>Slack</a><a class="tag-a" href='/tag/soft-skills/'>Soft Skills</a><a class="tag-a" href='/tag/tesla/'>Tesla</a><a class="tag-a" href='/tag/tproger-changelog/'>Tproger Changelog</a><a class="tag-a" href='/tag/twitter/'>Twitter</a><a class="tag-a" href='/tag/unity/'>Unity</a><a class="tag-a" href='/tag/unix/'>unix</a><a class="tag-a" href='/tag/vpn/'>VPN</a><a class="tag-a" href='/tag/wi-fi/'>Wi-Fi</a><a class="tag-a" href='/tag/windows-10/'>Windows 10</a><a class="tag-a" href='/tag/wordpress/'>WordPress</a><a class="tag-a" href='/tag/xbox/'>XBox</a><a class="tag-a" href='/tag/youtube/'>YouTube</a><a class="tag-a" href='/tag/autopilot/'>Автопилот</a><a class="tag-a" href='/tag/algorithms/'>Алгоритмы</a><a class="tag-a" href='/tag/algos-and-data-structs/'>Алгоритмы и структуры данных</a><a class="tag-a" href='/tag/alisa/'>Алиса</a><a class="tag-a" href='/tag/analiz-dannyh/'>Анализ данных</a><a class="tag-a" href='/tag/analytics/'>Аналитика</a><a class="tag-a" href='/tag/software-architecture/'>Архитектура ПО</a><a class="tag-a" href='/tag/db/'>Базы данных</a><a class="tag-a" href='/tag/security/'>Безопасность</a><a class="tag-a" href='/tag/safe-code/'>Безопасный код</a><a class="tag-a" href='/tag/autopilot-2/'>Беспилотники</a><a class="tag-a" href='/tag/beta/'>Бета</a><a class="tag-a" href='/tag/biznes-analitika/'>Бизнес-аналитика</a><a class="tag-a" href='/tag/biotechnology/'>Биотехнологии</a><a class="tag-a" href='/tag/browsers/'>Браузеры</a><a class="tag-a" href='/tag/quick-start/'>Быстрый старт</a><a class="tag-a" href='/tag/backend/'>Бэкенд</a><a class="tag-a" href='/tag/vzlom/'>Взлом</a><a class="tag-a" href='/tag/visualization/'>Визуализация</a><a class="tag-a" href='/tag/brain-teasers/'>Головоломки</a><a class="tag-a" href='/tag/guest-post/'>Гостевая публикация</a><a class="tag-a" href='/tag/for-motivation/'>Для мотивации</a><a class="tag-a" href='/tag/for-beginners/'>Для начинающих</a><a class="tag-a" href='/tag/for-advanced/'>Для продвинутых</a><a class="tag-a" href='/tag/for-amateurs/'>Для продолжающих</a><a class="tag-a" href='/tag/expert-problems/'>Задачи повышенной сложности</a><a class="tag-a" href='/tag/middle-problems/'>Задачи умеренной сложности</a><a class="tag-a" href='/tag/igra/'>Игра</a><a class="tag-a" href='/tag/games/'>Игры для программистов</a><a class="tag-a" href='/tag/ilon-mask/'>Илон Маск</a><a class="tag-a" href='/tag/tools/'>Инструменты</a><a class="tag-a" href='/tag/command-line-tools/'>Инструменты командной строки</a><a class="tag-a" href='/tag/interesting-projects/'>Интересные проекты</a><a class="tag-a" href='/tag/internet/'>Интернет</a><a class="tag-a" href='/tag/it-history/'>История IT</a><a class="tag-a" href='/tag/success-story/'>История успеха</a><a class="tag-a" href='/tag/career/'>Карьера</a><a class="tag-a" href='/tag/kiberbezopasnost/'>Кибербезопасность</a><a class="tag-a" href='/tag/code-style/'>Кодстайл</a><a class="tag-a" href='/tag/compilers/'>Компиляторы</a><a class="tag-a" href='/tag/conferences/'>Конференции</a><a class="tag-a" href='/tag/good-hack/'>Красивый хак</a><a class="tag-a" href='/tag/best-practice/'>Лучшая практика</a><a class="tag-a" href='/tag/toplang2020/'>Лучший язык 2020</a><a class="tag-a" href='/tag/mining/'>Майнинг</a><a class="tag-a" href='/tag/marketing/'>Маркетинг</a><a class="tag-a" href='/tag/arrays-and-strings/'>Массивы и строки</a><a class="tag-a" href='/tag/scalability-and-memory-limits/'>Масштабируемость и ограничения памяти</a><a class="tag-a" href='/tag/guest/'>Материалы от друзей Tproger</a><a class="tag-a" href='/tag/messendzher/'>Мессенджер</a><a class="tag-a" href='/tag/software-development/'>Методологии разработки</a><a class="tag-a" href='/tag/microservices/'>Микросервисы</a><a class="tag-a" href='/tag/multithreading/'>Многопоточность</a><a class="tag-a" href='/tag/music/'>Музыка</a><a class="tag-a" href='/tag/english/'>На английском языке</a><a class="tag-a" href='/tag/skills/'>Навыки</a><a class="tag-a" href='/tag/low-level-coding/'>Низкоуровневое программирование</a><a class="tag-a" href='/tag/new-year/'>Новый Год</a><a class="tag-a" href='/tag/obrazovanie/'>Образование</a><a class="tag-a" href='/tag/courses/'>Обучающие курсы</a><a class="tag-a" href='/tag/learn-programming/'>Обучение программированию</a><a class="tag-a" href='/tag/oop/'>Объектно-ориентированное программирование</a><a class="tag-a" href='/tag/competitive-programming/'>Олимпиадное программирование</a><a class="tag-a" href='/tag/operating-systems/'>Операционные системы</a><a class="tag-a" href='/tag/poll/'>Опрос</a><a class="tag-a" href='/tag/optimization/'>Оптимизация</a><a class="tag-a" href='/tag/dev-organising/'>Организация разработки</a><a class="tag-a" href='/tag/programming-concepts/'>Основные принципы программирования</a><a class="tag-a" href='/tag/debugging/'>Отладка</a><a class="tag-a" href='/tag/pavel-durov/'>Павел Дуров</a><a class="tag-a" href='/tag/parsing/'>Парсинг</a><a class="tag-a" href='/tag/partnered/'>Партнёрский материал</a><a class="tag-a" href='/tag/design-patterns/'>Паттерны проектирования</a><a class="tag-a" href='/tag/personalnye-dannye/'>Персональные данные</a><a class="tag-a" href='/tag/ugc/'>Пост пользователя</a><a class="tag-a" href='/tag/prilozhenie/'>Приложение</a><a class="tag-a" href='/tag/performance/'>Производительность</a><a class="tag-a" href='/tag/processor/'>Процессор</a><a class="tag-a" href='/tag/job/'>Работа</a><a class="tag-a" href='/tag/recognition/'>Распознавание</a><a class="tag-a" href='/tag/reactive/'>Реактивное программирование</a><a class="tag-a" href='/tag/retro/'>Ретро</a><a class="tag-a" href='/tag/rossija/'>Россия</a><a class="tag-a" href='/tag/server/'>Сервер</a><a class="tag-a" href='/tag/services/'>Сервисы</a><a class="tag-a" href='/tag/network-protocols/'>Сетевые протоколы</a><a class="tag-a" href='/tag/job-interview/'>Собеседование</a><a class="tag-a" href='/tag/advices/'>Советы</a><a class="tag-a" href='/tag/social-networks/'>Социальные сети</a><a class="tag-a" href='/tag/startups/'>Стартапы</a><a class="tag-a" href='/tag/statistics/'>Статистика</a><a class="tag-a" href='/tag/stoit-prochitat/'>Стоит прочитать</a><a class="tag-a" href='/tag/supercomputers/'>Суперкомпьютеры</a><a class="tag-a" href='/tag/ugadajki/'>Угадайки</a><a class="tag-a" href='/tag/ujazvimost/'>Уязвимость</a><a class="tag-a" href='/tag/data-storage-formats/'>Форматы хранения данных</a><a class="tag-a" href='/tag/frameworks/'>Фреймворки</a><a class="tag-a" href='/tag/functional-programming/'>Функциональное программирование</a><a class="tag-a" href='/tag/hakery/'>Хакеры</a><a class="tag-a" href='/tag/hobby/'>Хобби</a><a class="tag-a" href='/tag/meltdown-spectre/'>Чипокалипсис</a><a class="tag-a" href='/tag/cheatsheets/'>Шпаргалки</a><a class="tag-a" href='/tag/programming-languages/'>Языки программирования</a></div> </div>
</div>
</div>
<script defer src="https://tproger.ru/wp-content/cache/minify/adc36.x34751.js"></script>
<script type='text/javascript' id='tproger-elevator-js-extra'>
/* <![CDATA[ */
var tprogerElevator = {"pluginsUrl":"https:\/\/tproger.ru\/wp-content\/plugins"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/f86eb.x34751.js"></script>
<script type='text/javascript' id='mistape-front-js-extra'>
/* <![CDATA[ */
var mistape_args = {"ajaxurl":"https:\/\/tproger.ru\/wp-admin\/admin-ajax.php","nonce":"a1b732e005"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/e8bb6.x34751.js"></script>
<script type='text/javascript' id='post-views-counter-frontend-js-extra'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"ajax","requestURL":"https:\/\/tproger.ru\/wp-content\/plugins\/tproger-post-views-counter\/includes\/ajax.php","postID":"170867","nonce":"0e8dd24760"};
/* ]]> */
</script>
<script defer src="https://tproger.ru/wp-content/cache/minify/c0cba.x34751.js"></script>
<script>
				function showPage() {
					window.requestAnimationFrame(() => {
						const page = document.getElementById('page')
						if (page && page.style.display !== '') {
							page.style.display = null
						}
						document.querySelectorAll('#fake-post, #fake-scroll, #fake-style').forEach(element => element.remove())
					})
				}
				setTimeout(showPage, 3000) // in case of error
									document.fonts.ready.then(showPage)
							</script> <script>
			const blu = {'site_url': 'https://tproger.ru', 'ajaxurl': 'https://tproger.ru/wp-admin/admin-ajax.php'};
		</script>
<div class="sharing-lock"></div>
<div class="sharing-menu">
<div class="sharing-close icon-close"></div>
<a title="Копировать ссылку на пост" class="icon-link sharing-menu-item" href="javascript:void(0);" onClick="copyLinkToClipboard('https://tproger.ru/news/jandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire/');">Копировать ссылку</a>
<a title="Поделиться во ВКонтакте" class="icon-vkontakte sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://vk.com/share.php?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fjandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire%2F&title=%C2%AB%D0%AF%D0%BD%D0%B4%D0%B5%D0%BA%D1%81%C2%BB+%D0%BF%D1%80%D0%B5%D0%B4%D1%81%D1%82%D0%B0%D0%B2%D0%B8%D0%BB%D0%B0+%D1%82%D0%B5%D1%85%D0%BD%D0%BE%D0%BB%D0%BE%D0%B3%D0%B8%D1%8E+%D1%80%D1%83%D1%81%D1%81%D0%BA%D0%BE%D0%B3%D0%BE+%D0%B4%D1%83%D0%B1%D0%BB%D1%8F%D0%B6%D0%B0+%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE+%D0%B2+%D1%80%D0%B5%D0%B0%D0%BB%D1%8C%D0%BD%D0%BE%D0%BC+%D0%B2%D1%80%D0%B5%D0%BC%D0%B5%D0%BD%D0%B8.+%D0%A3+%D0%BD%D0%B5%D1%91+%D0%BD%D0%B5%D1%82+%D0%B0%D0%BD%D0%B0%D0%BB%D0%BE%D0%B3%D0%BE%D0%B2+%D0%B2+%D0%BC%D0%B8%D1%80%D0%B5');">ВКонтакте</a>
<a title="Поделиться на Facebook" class="icon-facebook sharing-menu-item" href="javascript:void(0);" onClick="social_share('http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftproger.ru%2Fnews%2Fjandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire%2F&t=%C2%AB%D0%AF%D0%BD%D0%B4%D0%B5%D0%BA%D1%81%C2%BB+%D0%BF%D1%80%D0%B5%D0%B4%D1%81%D1%82%D0%B0%D0%B2%D0%B8%D0%BB%D0%B0+%D1%82%D0%B5%D1%85%D0%BD%D0%BE%D0%BB%D0%BE%D0%B3%D0%B8%D1%8E+%D1%80%D1%83%D1%81%D1%81%D0%BA%D0%BE%D0%B3%D0%BE+%D0%B4%D1%83%D0%B1%D0%BB%D1%8F%D0%B6%D0%B0+%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE+%D0%B2+%D1%80%D0%B5%D0%B0%D0%BB%D1%8C%D0%BD%D0%BE%D0%BC+%D0%B2%D1%80%D0%B5%D0%BC%D0%B5%D0%BD%D0%B8.+%D0%A3+%D0%BD%D0%B5%D1%91+%D0%BD%D0%B5%D1%82+%D0%B0%D0%BD%D0%B0%D0%BB%D0%BE%D0%B3%D0%BE%D0%B2+%D0%B2+%D0%BC%D0%B8%D1%80%D0%B5');">Facebook</a>
<a title="Поделиться в Twitter" class="icon-twitter sharing-menu-item" href="javascript:void(0);" onClick="social_share('http://twitter.com/intent/tweet?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fjandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire%2F&text=«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире');">Twitter</a>
<a title="Сохранить в Pocket" class="icon-pocket small sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://getpocket.com/edit?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fjandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire%2F');">Pocket</a>
<a title="Отправить в Telegram" class="icon-telegram sharing-menu-item" href="javascript:void(0);" onClick="social_share('https://telegram.me/share/url?url=https%3A%2F%2Ftproger.ru%2Fnews%2Fjandeks-perevodit-video-s-anglijskogo-i-odnovremenno-ozvuchivaet-ego-u-novoj-tehnologii-net-analogov-v-mire%2F&text=«Яндекс» представила технологию русского дубляжа видео в реальном времени. У неё нет аналогов в мире');">Telegram</a>
</div>
</body>
</html>
